summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2012-11-21 21:21:28 +0000
committerAndreas Schuerch <nativemad@gentoo.org>2012-11-21 21:21:28 +0000
commitcd941173fb8c332ff82b42b82162c4b483d36f17 (patch)
tree2f4a15788440ba3f6c7d9b9ced366af218b433a7 /media-sound/ardour
parentVersion bump to 0.7.0 Bug #405287 (diff)
downloadgentoo-2-cd941173fb8c332ff82b42b82162c4b483d36f17.tar.gz
gentoo-2-cd941173fb8c332ff82b42b82162c4b483d36f17.tar.bz2
gentoo-2-cd941173fb8c332ff82b42b82162c4b483d36f17.zip
Added a little patch for boost-1.50. See bug 425578, Thanks Diego!
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog6
-rw-r--r--media-sound/ardour/ardour-2.8.14.ebuild6
-rw-r--r--media-sound/ardour/files/ardour-2.8.14-boost-150.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index bca4b34c0ce4..105ea428f356 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.103 2012/11/20 20:30:19 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.104 2012/11/21 21:21:28 nativemad Exp $
+
+ 22 Nov 2012; Andreas Schuerch <nativemad@gentoo.org> ardour-2.8.14.ebuild,
+ +files/ardour-2.8.14-boost-150.patch:
+ added a little patch for boost-1.50. See bug 425578, Thanks Diego.
*ardour-2.8.14 (21 Nov 2012)
diff --git a/media-sound/ardour/ardour-2.8.14.ebuild b/media-sound/ardour/ardour-2.8.14.ebuild
index 4e184278da74..76a7312a4609 100644
--- a/media-sound/ardour/ardour-2.8.14.ebuild
+++ b/media-sound/ardour/ardour-2.8.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.14.ebuild,v 1.1 2012/11/20 20:30:19 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.14.ebuild,v 1.2 2012/11/21 21:21:28 nativemad Exp $
EAPI=4
inherit eutils flag-o-matic toolchain-funcs scons-utils
@@ -51,7 +51,9 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-2.8.11-flags.patch \
- "${FILESDIR}"/${P}-syslibs.patch
+ "${FILESDIR}"/${P}-syslibs.patch \
+ "${FILESDIR}"/${P}-boost-150.patch
+
}
src_compile() {
diff --git a/media-sound/ardour/files/ardour-2.8.14-boost-150.patch b/media-sound/ardour/files/ardour-2.8.14-boost-150.patch
new file mode 100644
index 000000000000..0d23568a309c
--- /dev/null
+++ b/media-sound/ardour/files/ardour-2.8.14-boost-150.patch
@@ -0,0 +1,13 @@
+--- /home/mad/ardour-2.8.14/SConstruct 2012-11-21 00:30:54.000000000 +0100
++++ SConstruct 2012-11-21 17:34:02.000000000 +0100
+@@ -955,7 +961,9 @@
+ # FLAC ....
+ #
+
+-# boost (we don't link against boost, just use some header files)
++# boost (we need to link against boost with >=1.50. header files alone will not work anymore)
++
++env.Append(LIBS=['boost_system'])
+
+ libraries['boost'] = LibraryInfo ()
+ prep_libcheck(env, libraries['boost'])