summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-11 18:14:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-11 18:14:45 +0000
commitcc4d4c3f564a5e0683df7bb0a683b0c73aeac27b (patch)
tree324d5b981bfe0c8cbf10e8ceabe70e614f11af06 /media-sound/audacity
parentStable on ppc64; bug #221063 (diff)
downloadgentoo-2-cc4d4c3f564a5e0683df7bb0a683b0c73aeac27b.tar.gz
gentoo-2-cc4d4c3f564a5e0683df7bb0a683b0c73aeac27b.tar.bz2
gentoo-2-cc4d4c3f564a5e0683df7bb0a683b0c73aeac27b.zip
version bump
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog9
-rw-r--r--media-sound/audacity/audacity-1.3.5.ebuild100
-rw-r--r--media-sound/audacity/files/audacity-1.3.5-cflags_with_non_standard_macros.patch35
-rw-r--r--media-sound/audacity/files/audacity-1.3.5-libtool22.patch13
4 files changed, 156 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index a7c594329ff9..bf5bdcd098a2 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.95 2008/04/16 15:31:46 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.96 2008/05/11 18:14:45 aballier Exp $
+
+*audacity-1.3.5 (11 May 2008)
+
+ 11 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/audacity-1.3.5-cflags_with_non_standard_macros.patch,
+ +files/audacity-1.3.5-libtool22.patch, +audacity-1.3.5.ebuild:
+ version bump
16 Apr 2008; Peter Volkov <pva@gentoo.org> audacity-1.3.4-r3.ebuild:
amd64 stable, bug #212806, thank Angelo Arrifano for tests.
diff --git a/media-sound/audacity/audacity-1.3.5.ebuild b/media-sound/audacity/audacity-1.3.5.ebuild
new file mode 100644
index 000000000000..f594ca32c5e0
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.5.ebuild,v 1.1 2008/05/11 18:14:45 aballier Exp $
+
+inherit eutils wxwidgets autotools
+
+IUSE="alsa flac id3tag jack ladspa libsamplerate mp3 soundtouch twolame vamp vorbis"
+
+MY_P="${PN}-src-${PV}"
+#MY_PA_P="pa_stable_v19_20071207"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+# http://www.portaudio.com/archives/${MY_PA_P}.tar.gz
+# mirror://gentoo/${P}-portaudio-cvs-rev1.7.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+RESTRICT="test"
+
+COMMON_DEPEND="=x11-libs/wxGTK-2.8*
+ >=app-arch/zip-2.3
+ dev-libs/expat
+ >=media-libs/libsndfile-1.0.0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.103.0 )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b )
+ id3tag? ( media-libs/libid3tag )
+ flac? ( media-libs/flac )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ vamp? ( media-libs/vamp-plugin-sdk )
+ twolame? ( media-sound/twolame )"
+RDEPEND="${COMMON_DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}-beta"
+
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+# einfo "Updating portaudio-v19 snapshot to ${MY_PA_P}"
+# rm -r "${S}/lib-src/portaudio-v19" || die
+# mv "${WORKDIR}/portaudio" "${S}/lib-src/portaudio-v19" || die
+
+ cd "${S}"
+
+# cd lib-src/portaudio-v19
+# epatch "${WORKDIR}/${P}-portaudio-cvs-rev1.7.patch"
+
+# cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.3.4-automagic.patch"
+ epatch "${FILESDIR}/${P}-cflags_with_non_standard_macros.patch"
+ epatch "${FILESDIR}/${P}-libtool22.patch"
+ eautoreconf
+}
+
+src_compile() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+
+ econf \
+ --with-libexpat=system \
+ --enable-unicode \
+ $(use_with ladspa) \
+ $(use_with vorbis libvorbis) \
+ $(use_with mp3 libmad) \
+ $(use_with id3tag libid3tag) \
+ $(use_with flac libflac) \
+ $(use_enable vamp) \
+ $(use_with twolame libtwolame) \
+ $(use_with soundtouch) \
+ $(use_with libsamplerate) \
+ $(use_with alsa) \
+ $(use_with jack)
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+}
diff --git a/media-sound/audacity/files/audacity-1.3.5-cflags_with_non_standard_macros.patch b/media-sound/audacity/files/audacity-1.3.5-cflags_with_non_standard_macros.patch
new file mode 100644
index 000000000000..b22ae2cf68b7
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.5-cflags_with_non_standard_macros.patch
@@ -0,0 +1,35 @@
+Index: audacity-src-1.3.5-beta/configure.in
+===================================================================
+--- audacity-src-1.3.5-beta.orig/configure.in
++++ audacity-src-1.3.5-beta/configure.in
+@@ -161,30 +161,6 @@ if test x"$debug_preference" = "xyes" ;
+ CXXFLAGS="${CXXFLAGS} -g "
+ fi
+
+-dnl --------------------------------------------------------------------------
+-dnl We would like warnings enabled on the builds, but different compilers need
+-dnl different options for these. This bit tries to work out what flags we
+-dnl should add to the compiler we are using.
+-dnl --------------------------------------------------------------------------
+-
+-dnl Strict prototypes flags for C (only C because doesn't work for C++)
+-AX_CFLAGS_STRICT_PROTOTYPES(CFLAGS)
+-
+-dnl Sensible warnings for C
+-AX_CFLAGS_WARN_ALL(wall_flags)
+-CFLAGS="${CFLAGS} $wall_flags"
+-dnl try and use it on C++ as well
+-AX_CXX_CHECK_FLAG([$wall_flags], [[int foo;]], [[foo = 1;]], cxx_does_wall="yes", cxx_does_wall="no")
+-if test "x$cxx_does_wall" = "xyes" ; then
+- dnl can use all warnings flag on the C++ compiler
+- CXXFLAGS="${CXXFLAGS} $wall_flags"
+-fi
+-AX_CXXCPP_CHECK_FLAG([$wall_flags], [[int foo;]], [[foo = 1;]], cpp_does_wall="yes", cpp_does_wall="no")
+-if test "x$cpp_does_wall" = "xyes" ; then
+- dnl can use all warnings flag on the C++ pre-processor
+- CPPFLAGS="${CPPFLAGS} $wall_flags"
+-fi
+-
+ AC_CONFIG_SUBDIRS([lib-src/FileDialog])
+
+ LIBRARIES="LIBVORBIS LIBMAD LIBSNDFILE LIBFLAC LIBID3TAG LIBSAMPLERATE LIBRESAMPLE LIBSOUNDTOUCH LIBNYQUIST LIBVAMP LIBEXPAT LIBTWOLAME"
diff --git a/media-sound/audacity/files/audacity-1.3.5-libtool22.patch b/media-sound/audacity/files/audacity-1.3.5-libtool22.patch
new file mode 100644
index 000000000000..4780c9deac11
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.5-libtool22.patch
@@ -0,0 +1,13 @@
+Index: audacity-src-1.3.5-beta/lib-src/portaudio-v19/Makefile.in
+===================================================================
+--- audacity-src-1.3.5-beta.orig/lib-src/portaudio-v19/Makefile.in
++++ audacity-src-1.3.5-beta/lib-src/portaudio-v19/Makefile.in
+@@ -39,7 +39,7 @@ OTHER_OBJS = @OTHER_OBJS@
+ PALIB = libportaudio.la
+ PAINC = include/portaudio.h
+
+-PA_LDFLAGS = $(LDFLAGS) $(SHARED_FLAGS) -rpath $(libdir) -no-undefined \
++PA_LDFLAGS = $(LDFLAGS) -rpath $(libdir) -no-undefined \
+ -export-symbols-regex "(Pa|PaMacCore|PaJack|PaAlsa)_.*" \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+