summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-19 00:03:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-19 00:03:19 +0000
commit33499cdefb0807efad0060616c6a4a2366b0b6cb (patch)
tree908f95014cac6334a4c86c1ccd0b3758d10444c2 /media-sound/awesfx/awesfx-0.5.0d.ebuild
parentAdded ~amd64 keyword. Closes bug #106347. (diff)
downloadgentoo-2-33499cdefb0807efad0060616c6a4a2366b0b6cb.tar.gz
gentoo-2-33499cdefb0807efad0060616c6a4a2366b0b6cb.tar.bz2
gentoo-2-33499cdefb0807efad0060616c6a4a2366b0b6cb.zip
Don't try to link to libdl unconditionally, use dlopen_lib from portability eclass.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'media-sound/awesfx/awesfx-0.5.0d.ebuild')
-rw-r--r--media-sound/awesfx/awesfx-0.5.0d.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-sound/awesfx/awesfx-0.5.0d.ebuild b/media-sound/awesfx/awesfx-0.5.0d.ebuild
index 4a27d2618420..f469e58fd764 100644
--- a/media-sound/awesfx/awesfx-0.5.0d.ebuild
+++ b/media-sound/awesfx/awesfx-0.5.0d.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.0d.ebuild,v 1.2 2004/12/19 05:36:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.0d.ebuild,v 1.3 2005/09/19 00:03:19 flameeyes Exp $
IUSE="alsa"
-inherit eutils
+inherit eutils portability
DESCRIPTION="AWE Utilities - sfxload"
HOMEPAGE="http://www.alsa-project.org/~iwai/awedrv.html#Utils"
@@ -25,7 +25,7 @@ src_compile() {
epatch ${FILESDIR}/${PN}-0.5.0b-configure-noalsa.patch
econf --with-sfpath=${BANK_LOC} || die
epatch ${FILESDIR}/${PN}-0.5.0b-makefile-noalsa.patch
- sed -i -e 's/'^LIBS.*-lasound.*$'/LIBS = -lm -ldl -lpthread/' Makefile
+ sed -i -e 's/'^LIBS.*-lasound.*$'/LIBS = -lm $(dlopen_lib) -lpthread/' Makefile
else
econf --with-sfpath=${BANK_LOC} || die
fi