summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-08 18:45:59 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-08 18:45:59 +0000
commit0276f40e2702d21c528a79df3660a5fcea00de72 (patch)
tree623ed48e075d1ffdda71ad79a2f9cd7eedbd6b45 /media-sound/christine
parentbump to 1.4.0. Remove openssl dep, bug #216705. Clean up old revisions. (diff)
downloadgentoo-2-0276f40e2702d21c528a79df3660a5fcea00de72.tar.gz
gentoo-2-0276f40e2702d21c528a79df3660a5fcea00de72.tar.bz2
gentoo-2-0276f40e2702d21c528a79df3660a5fcea00de72.zip
Initial commit, thanks to n0sferatu for spiritual support.
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-sound/christine')
-rw-r--r--media-sound/christine/ChangeLog9
-rw-r--r--media-sound/christine/Manifest4
-rw-r--r--media-sound/christine/christine-0.1.6.ebuild50
-rw-r--r--media-sound/christine/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/christine/ChangeLog b/media-sound/christine/ChangeLog
new file mode 100644
index 000000000000..aaab4c68528c
--- /dev/null
+++ b/media-sound/christine/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/christine
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/christine/ChangeLog,v 1.1 2008/06/08 18:45:59 drac Exp $
+
+*christine-0.1.6 (08 Jun 2008)
+
+ 08 Jun 2008; Samuli Suominen <drac@gentoo.org> +christine-0.1.6.ebuild:
+ Initial commit, thanks to n0sferatu for spiritual support.
+
diff --git a/media-sound/christine/Manifest b/media-sound/christine/Manifest
new file mode 100644
index 000000000000..8c97d3575ff5
--- /dev/null
+++ b/media-sound/christine/Manifest
@@ -0,0 +1,4 @@
+DIST christine-0.1.6-1.tar.bz2 367138 RMD160 818a5da8fc98915d8aed5940a250fd00038dafa6 SHA1 734b76ef2334b071392f3ef04899bac301157012 SHA256 7ecf96535c80d900689718e30b312a9318c518b02af672960777438f4438b6dc
+EBUILD christine-0.1.6.ebuild 1307 RMD160 24f82706ff921dadc3a0b9eff9a4da09563623ff SHA1 1c42ca35f6acc5891481d4a03e7d5604f4b36cbc SHA256 069231f06ebc5bb348ea8410d8c6562dba7b30c25f35a793c4b608906a7db90d
+MISC ChangeLog 290 RMD160 a134914edeaa81a64a8561425ee3a87726b2a659 SHA1 2d47b1f35f4dcdbd694886ea23f169db3bb9fe84 SHA256 f2a0e604aae822d0bf9e7636a2c2647a407b45de5b39e250889423ca365113d7
+MISC metadata.xml 158 RMD160 6842e2189a50bd8a98e84802c38180ac1421c00e SHA1 703cea5a2109d41f7c87993c1f01d418a4c85174 SHA256 dfb5b47e6836db39fb187301dfcff1c2605e91d13d21db160806a563d8c75f9b
diff --git a/media-sound/christine/christine-0.1.6.ebuild b/media-sound/christine/christine-0.1.6.ebuild
new file mode 100644
index 000000000000..c901d3c1d86b
--- /dev/null
+++ b/media-sound/christine/christine-0.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/christine/christine-0.1.6.ebuild,v 1.1 2008/06/08 18:45:59 drac Exp $
+
+inherit multilib python
+
+DESCRIPTION="Python, GTK+ and GStreamer based media player (audio and video)"
+HOMEPAGE="http://christine-project.org"
+# It seems 0.x.x-1.tar.bz2 is 0.x.x release, deb lovers..
+SRC_URI="mirror://sourceforge/${PN}/${P}-1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ >=dev-python/pygtk-2
+ >=dev-python/gst-python-0.10
+ >=media-plugins/gst-plugins-meta-0.10
+ media-libs/mutagen"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_compile() {
+ addpredict $(unset HOME; echo ~)/.gconf
+ addpredict $(unset HOME; echo ~)/.gconfd
+ addpredict $(unset HOME; echo ~)/.gstreamer-0.10
+ econf --disable-dependency-tracking $(use_with readline)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ # deb lovers again..
+ rm -f "${D}"/createDeb.sh
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/lib${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/lib${PN}
+}
diff --git a/media-sound/christine/metadata.xml b/media-sound/christine/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/christine/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>