summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-29 11:00:58 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-29 11:00:58 +0000
commit6e44bd7e3314d076db4e55ee8e02dc954248babe (patch)
treee6ee5770ed5bb78aa333072d1503b7d61d26a28f /media-sound/csound
parentEAPI=4 on line 5 (diff)
downloadgentoo-2-6e44bd7e3314d076db4e55ee8e02dc954248babe.tar.gz
gentoo-2-6e44bd7e3314d076db4e55ee8e02dc954248babe.tar.bz2
gentoo-2-6e44bd7e3314d076db4e55ee8e02dc954248babe.zip
Fix build with portmidi (bug #417769).
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/csound')
-rw-r--r--media-sound/csound/ChangeLog6
-rw-r--r--media-sound/csound/csound-5.17.6.ebuild3
-rw-r--r--media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch20
3 files changed, 27 insertions, 2 deletions
diff --git a/media-sound/csound/ChangeLog b/media-sound/csound/ChangeLog
index 9977dafd8cd3..53db8efadbee 100644
--- a/media-sound/csound/ChangeLog
+++ b/media-sound/csound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/csound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.15 2012/04/16 19:16:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.16 2012/05/29 11:00:58 radhermit Exp $
+
+ 29 May 2012; Tim Harder <radhermit@gentoo.org> csound-5.17.6.ebuild,
+ +files/csound-5.17.6-porttime-in-portmidi.patch:
+ Fix build with portmidi (bug #417769).
16 Apr 2012; Tim Harder <radhermit@gentoo.org> csound-5.17.6.ebuild,
+files/csound-5.17.6-fltk.patch:
diff --git a/media-sound/csound/csound-5.17.6.ebuild b/media-sound/csound/csound-5.17.6.ebuild
index 7239e66ddd3b..7ec06c62587c 100644
--- a/media-sound/csound/csound-5.17.6.ebuild
+++ b/media-sound/csound/csound-5.17.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.6.ebuild,v 1.2 2012/04/16 19:16:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.6.ebuild,v 1.3 2012/05/29 11:00:58 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -82,6 +82,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-5.16.6-tests.patch
epatch "${FILESDIR}"/${P}-fltk.patch
+ epatch "${FILESDIR}"/${P}-porttime-in-portmidi.patch
sed -i -e "s:^\(csoundExecutable =\).*:\1 \"${WORKDIR}/${P}_build/csound\":" \
tests/test.py || die
diff --git a/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch b/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
new file mode 100644
index 000000000000..3f69a3795f04
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
@@ -0,0 +1,20 @@
+--- Csound5.17.6/InOut/CMakeLists.txt
++++ Csound5.17.6/InOut/CMakeLists.txt
+@@ -26,7 +26,6 @@
+ endif()
+ if(USE_PORTMIDI)
+ find_library(PORTMIDI_LIBRARY portmidi)
+- find_library(PORTTIME_LIBRARY porttime)
+ check_include_file(portmidi.h PORTMIDI_HEADER)
+ endif()
+ if(USE_JACK)
+@@ -116,9 +115,6 @@
+ check_deps(USE_PORTMIDI PORTMIDI_HEADER PORTMIDI_LIBRARY)
+ if(USE_PORTMIDI)
+ set(pmidi_LIBS ${PORTMIDI_LIBRARY})
+- if(NOT APPLE)
+- list(APPEND pmidi_LIBS ${PORTTIME_LIBRARY})
+- endif()
+ if(WIN32)
+ list(APPEND pmidi_LIBS ${CSOUND_WINDOWS_LIBRARIES})
+ endif()