summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-28 15:41:02 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-28 15:41:02 +0000
commit17d7ffe99aabafa25eb048d08a27c5b0528ef8ff (patch)
tree418cf247bd11a700f9041dbd54edf09448d84de7 /media-sound/daapd
parentAdd virtual. (diff)
downloadgentoo-2-17d7ffe99aabafa25eb048d08a27c5b0528ef8ff.tar.gz
gentoo-2-17d7ffe99aabafa25eb048d08a27c5b0528ef8ff.tar.bz2
gentoo-2-17d7ffe99aabafa25eb048d08a27c5b0528ef8ff.zip
new upstream version
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/daapd')
-rw-r--r--media-sound/daapd/ChangeLog8
-rw-r--r--media-sound/daapd/Manifest7
-rw-r--r--media-sound/daapd/daapd-0.2.4.ebuild57
-rw-r--r--media-sound/daapd/files/daapd-0.2.4-gentoo.patch43
-rw-r--r--media-sound/daapd/files/digest-daapd-0.2.41
-rw-r--r--media-sound/daapd/metadata.xml7
6 files changed, 114 insertions, 9 deletions
diff --git a/media-sound/daapd/ChangeLog b/media-sound/daapd/ChangeLog
index 2e4ae199fe03..a52dc196f79c 100644
--- a/media-sound/daapd/ChangeLog
+++ b/media-sound/daapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/daapd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/ChangeLog,v 1.13 2005/01/30 01:23:48 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/ChangeLog,v 1.14 2005/04/28 15:41:02 luckyduck Exp $
+
+*daapd-0.2.4 (28 Apr 2005)
+
+ 28 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> metadata.xml,
+ +files/daapd-0.2.4-gentoo.patch, +daapd-0.2.4.ebuild:
+ new upstream version, thanks to iT_m00m1n to point me to that fact.
*daapd-0.2.3d-r1 (30 Jan 2005)
diff --git a/media-sound/daapd/Manifest b/media-sound/daapd/Manifest
index e23196dc25e2..e02114f2a21e 100644
--- a/media-sound/daapd/Manifest
+++ b/media-sound/daapd/Manifest
@@ -1,9 +1,12 @@
+MD5 d15d2888dad9e20f44ad35e89b771a61 daapd-0.2.4.ebuild 1331
MD5 a158216fe286fbf71afe186c37ee6524 daapd-0.2.3d-r1.ebuild 1317
MD5 f1a82bd9846fb2926d132d29851f16fa daapd-0.2.3d.ebuild 1313
-MD5 8fa3a91a8402d22b2a773ed98023b7b0 ChangeLog 2521
-MD5 67fa7232a65762eb47d8773c5fb33811 metadata.xml 592
+MD5 b91306faebd0ed7dde1f6fa2095d3c58 ChangeLog 2742
+MD5 5209c0057b32b7d92999700515bed3aa metadata.xml 440
MD5 3beda326653c14c1fbd33c762af01e2e files/daapd.conf.d 673
MD5 5a1dfee32f50af3462b68b3381a6aa8b files/daapd.init.d 1069
MD5 c25c564a55bdc585c844929ca710971a files/digest-daapd-0.2.3d-r1 61
+MD5 0d6290b8eeee3b95f7aa5e2e1d3a8b2f files/digest-daapd-0.2.4 60
MD5 f1be018e61557e7ca897f2f1078b13b4 files/daapd-0.2.3d-gentoo.patch 1569
MD5 c25c564a55bdc585c844929ca710971a files/digest-daapd-0.2.3d 61
+MD5 660b25ab66dc0cb5147d21b2db00b685 files/daapd-0.2.4-gentoo.patch 1564
diff --git a/media-sound/daapd/daapd-0.2.4.ebuild b/media-sound/daapd/daapd-0.2.4.ebuild
new file mode 100644
index 000000000000..5d4f0dd2a173
--- /dev/null
+++ b/media-sound/daapd/daapd-0.2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/daapd-0.2.4.ebuild,v 1.1 2005/04/28 15:41:02 luckyduck Exp $
+
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="daapd scans a directory for mp3 files and makes them available via the Apple proprietary protocol DAAP"
+HOMEPAGE="http://www.deleet.de/projekte/daap/daapd/"
+SRC_URI="http://www.deleet.de/projekte/daap/daapd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE="aac howl mpeg4"
+
+DEPEND="sys-libs/zlib
+ howl? ( >=net-misc/howl-0.9.6-r1 )
+ aac? ( media-libs/faad2 )
+ >=media-libs/libid3tag-0.15.0b
+ >=net-libs/libhttpd-persistent-1.3p-r8
+ >=media-libs/daaplib-0.1.1a"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ cd ${S}
+ if ! use howl; then
+ sed -ie 's/HOWL_ENABLE = 1/HOWL_ENABLE = 0/g' makefile
+ fi
+
+ if ! use mpeg4; then
+ sed -ie 's/MPEG4_ENABLE = 1/MPEG4_ENABLE = 0/g' makefile
+ fi
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin daapd
+
+ dodoc COPYING README* daapd-example.conf
+ doman ${PN}.8
+
+ insinto /etc
+ newins daapd-example.conf daapd.conf
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/daapd.conf.d daapd || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/daapd.init.d daapd || die
+}
+
diff --git a/media-sound/daapd/files/daapd-0.2.4-gentoo.patch b/media-sound/daapd/files/daapd-0.2.4-gentoo.patch
new file mode 100644
index 000000000000..cfa78fb87c62
--- /dev/null
+++ b/media-sound/daapd/files/daapd-0.2.4-gentoo.patch
@@ -0,0 +1,43 @@
+diff -uprN daapd-0.2.4.orig/makefile daapd-0.2.4/makefile
+--- daapd-0.2.4.orig/makefile 2005-04-28 17:35:27.000000000 +0200
++++ daapd-0.2.4/makefile 2005-04-28 17:36:49.000000000 +0200
+@@ -11,19 +11,19 @@ MPEG4_ENABLE = 0
+ CC = g++
+ MAKE = $(MAKE_COMMAND)
+ TARGET = daapd
+-DEPS = daaplib_ libhttpd_
++DEPS =
+ OBJS = daapd.o db.o dboutput.o songcache.o parsemp3.o util.o
+ LIBS = -ldaaplib -lhttpd-persistent -lid3tag -lz
+-LIBPATH = -L. -L./daaplib/src -L./libhttpd/src -L/usr/local/lib
+-INCPATH = -I. -I./daaplib/include -I./libhttpd/src -I/usr/local/include
+-DEPLOY = /usr/local
++LIBPATH = -L. -L/usr/lib
++INCPATH = -I. -I/usr/include
++DEPLOY = /usr
+ CFLAGS = -Wall -Wno-multichar
+
+ # HOWL
+ ifeq ($(HOWL_ENABLE),1)
+- HOWLDIRS := $(sort $(wildcard /usr/local/include/howl*) )
++ HOWLDIRS := $(sort $(wildcard /usr/include/howl*) )
+ ifeq ($(words $(HOWLDIRS) ), 0)
+-$(error howl not found in /usr/local/include. Install howl or disable it in the makefile)
++$(error howl not found in /usr/include. Install howl or disable it in the makefile)
+ endif
+ HOWLRECENT := $(word $(words $(HOWLDIRS)),$(HOWLDIRS) )
+ INCPATH := $(INCPATH) -I$(HOWLRECENT)
+diff -uprN daapd-0.2.4.orig/types.h daapd-0.2.4/types.h
+--- daapd-0.2.4.orig/types.h 2005-04-28 17:35:27.000000000 +0200
++++ daapd-0.2.4/types.h 2005-04-28 17:37:15.000000000 +0200
+@@ -20,6 +20,10 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#ifndef UINT64_TO_DOUBLE
++#define UINT64_TO_DOUBLE(a) ((double)((int64_t)(a)))
++#endif
++
+ #ifndef DAAP_TYPES_H
+ #define DAAP_TYPES_H
+
diff --git a/media-sound/daapd/files/digest-daapd-0.2.4 b/media-sound/daapd/files/digest-daapd-0.2.4
new file mode 100644
index 000000000000..79b690cc887c
--- /dev/null
+++ b/media-sound/daapd/files/digest-daapd-0.2.4
@@ -0,0 +1 @@
+MD5 f52df2e6bc4c8b85a38f0cfd2e3c97c2 daapd-0.2.4.tgz 205312
diff --git a/media-sound/daapd/metadata.xml b/media-sound/daapd/metadata.xml
index 510c09386434..e3969b5e8f93 100644
--- a/media-sound/daapd/metadata.xml
+++ b/media-sound/daapd/metadata.xml
@@ -1,12 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>net-misc</herd>
- <maintainer>
- <email>sandymac@gentoo.org</email>
- <name>Sandy McArthur</name>
- <description>initial package creator</description>
- </maintainer>
+ <herd>sound</herd>
<longdescription>
daapd scans a directory for mp3 files and makes them available via
the Apple proprietary protocol DAAP. DAAP clients, such as iTunes,