summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-24 06:08:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-24 06:08:36 +0000
commit7ce22e128a752750eb4708cecf84c51a1dcca6e1 (patch)
treecd2821926d5b36230a65c081f214f1f92986e9af /media-sound/djplay
parentversion bump, bug #277139 (diff)
downloadgentoo-2-7ce22e128a752750eb4708cecf84c51a1dcca6e1.tar.gz
gentoo-2-7ce22e128a752750eb4708cecf84c51a1dcca6e1.tar.bz2
gentoo-2-7ce22e128a752750eb4708cecf84c51a1dcca6e1.zip
fix build with gcc 4.4/glibc 2.10
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/djplay')
-rw-r--r--media-sound/djplay/ChangeLog8
-rw-r--r--media-sound/djplay/djplay-0.5.0.ebuild5
-rw-r--r--media-sound/djplay/files/djplay-0.5.0-gcc44.patch26
3 files changed, 35 insertions, 4 deletions
diff --git a/media-sound/djplay/ChangeLog b/media-sound/djplay/ChangeLog
index 0ea0dcc2c2e4..d7e9b2b2b784 100644
--- a/media-sound/djplay/ChangeLog
+++ b/media-sound/djplay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/djplay
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/djplay/ChangeLog,v 1.9 2008/07/27 21:26:20 carlo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/djplay/ChangeLog,v 1.10 2009/07/24 06:08:36 aballier Exp $
+
+ 24 Jul 2009; Alexis Ballier <aballier@gentoo.org> djplay-0.5.0.ebuild,
+ +files/djplay-0.5.0-gcc44.patch:
+ fix build with gcc 4.4/glibc 2.10
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> Manifest:
QA: Get rid of deprecated qt_min_version(). Qouting issues.
diff --git a/media-sound/djplay/djplay-0.5.0.ebuild b/media-sound/djplay/djplay-0.5.0.ebuild
index 5e2413aa6990..2c392dcc5ace 100644
--- a/media-sound/djplay/djplay-0.5.0.ebuild
+++ b/media-sound/djplay/djplay-0.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/djplay/djplay-0.5.0.ebuild,v 1.2 2008/07/27 21:21:45 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/djplay/djplay-0.5.0.ebuild,v 1.3 2009/07/24 06:08:36 aballier Exp $
EAPI=1
@@ -41,6 +41,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-configure.ac.patch"
epatch "${FILESDIR}/${P}-libmpeg3.patch"
+ epatch "${FILESDIR}/${P}-gcc44.patch"
eautoconf || die "eautoconf failed"
}
diff --git a/media-sound/djplay/files/djplay-0.5.0-gcc44.patch b/media-sound/djplay/files/djplay-0.5.0-gcc44.patch
new file mode 100644
index 000000000000..6536b1d384b0
--- /dev/null
+++ b/media-sound/djplay/files/djplay-0.5.0-gcc44.patch
@@ -0,0 +1,26 @@
+Index: djplay-0.5.0/loader.cpp
+===================================================================
+--- djplay-0.5.0.orig/loader.cpp
++++ djplay-0.5.0/loader.cpp
+@@ -82,7 +82,7 @@ void Loader::run()
+
+ if(!new_source)
+ {
+- char *ext=strrchr(File, '.');
++ const char *ext=strrchr(File, '.');
+ if(!ext)
+ ext="";
+
+Index: djplay-0.5.0/mainwnd.ui.h
+===================================================================
+--- djplay-0.5.0.orig/mainwnd.ui.h
++++ djplay-0.5.0/mainwnd.ui.h
+@@ -975,7 +975,7 @@ void MainWnd::loaderEvent(QLoaderEvent *
+ pframe=0;
+ warned=false;
+ current_file=e->file();
+- char *ext=strrchr(current_file, '.');
++ const char *ext=strrchr(current_file, '.');
+ if(!ext)
+ ext="";
+ current_file_name=info.fileName().left(info.fileName().length()-strlen(ext));