summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-26 18:07:04 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-26 18:07:04 +0000
commit25063cc5454475a1f2e48a950312d3a781d7c33d (patch)
treef26a6ca1cd9c4e11738ef86786a96418c9746ca6 /media-sound/exaile
parentFix anon umask uploads, #183213 thanks to Serhij S. Stasyuk (diff)
downloadgentoo-2-25063cc5454475a1f2e48a950312d3a781d7c33d.tar.gz
gentoo-2-25063cc5454475a1f2e48a950312d3a781d7c33d.tar.bz2
gentoo-2-25063cc5454475a1f2e48a950312d3a781d7c33d.zip
Apply patch from upstream to fix bug 183293, issue with default screen depth. Thanks to Jean-Baptiste Mestelan for reporting.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog10
-rw-r--r--media-sound/exaile/exaile-0.2.10-r1.ebuild (renamed from media-sound/exaile/exaile-0.2.10.ebuild)3
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.10-r1 (renamed from media-sound/exaile/files/digest-exaile-0.2.10)0
-rw-r--r--media-sound/exaile/files/exaile-0.2.10-visual.patch14
4 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index c55b5c4b3884..162025a173a1 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.19 2007/06/25 06:24:34 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.20 2007/06/26 18:07:04 drac Exp $
+
+*exaile-0.2.10-r1 (26 Jun 2007)
+
+ 26 Jun 2007; Samuli Suominen <drac@gentoo.org>
+ +files/exaile-0.2.10-visual.patch, -exaile-0.2.10.ebuild,
+ +exaile-0.2.10-r1.ebuild:
+ Apply patch from upstream to fix bug 183293, issue with default screen
+ depth. Thanks to Jean-Baptiste Mestelan for reporting.
*exaile-0.2.10 (25 Jun 2007)
diff --git a/media-sound/exaile/exaile-0.2.10.ebuild b/media-sound/exaile/exaile-0.2.10-r1.ebuild
index 768b09808e08..d8a65846aa2f 100644
--- a/media-sound/exaile/exaile-0.2.10.ebuild
+++ b/media-sound/exaile/exaile-0.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.10.ebuild,v 1.3 2007/06/25 07:02:41 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.10-r1.ebuild,v 1.1 2007/06/26 18:07:04 drac Exp $
inherit eutils fdo-mime python
@@ -60,6 +60,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/${P}-visual.patch
}
diff --git a/media-sound/exaile/files/digest-exaile-0.2.10 b/media-sound/exaile/files/digest-exaile-0.2.10-r1
index e790925c2ac7..e790925c2ac7 100644
--- a/media-sound/exaile/files/digest-exaile-0.2.10
+++ b/media-sound/exaile/files/digest-exaile-0.2.10-r1
diff --git a/media-sound/exaile/files/exaile-0.2.10-visual.patch b/media-sound/exaile/files/exaile-0.2.10-visual.patch
new file mode 100644
index 000000000000..1545fd9d72a8
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.2.10-visual.patch
@@ -0,0 +1,14 @@
+diff -ur exaile_0.2.10.orig/xl/xlmisc.py exaile_0.2.10/xl/xlmisc.py
+--- exaile_0.2.10.orig/xl/xlmisc.py 2007-06-07 15:48:24.000000000 +0300
++++ exaile_0.2.10/xl/xlmisc.py 2007-06-26 20:57:12.000000000 +0300
+@@ -1709,8 +1709,8 @@
+ """
+ if BITMAP_CACHE.has_key("%s - %sx%s - %s" % (text, width, height, bgcolor)):
+ return BITMAP_CACHE["%s - %sx%s - %s" % (text, width, height, bgcolor)]
+-
+- pixmap = gtk.gdk.Pixmap(None, width, height, 24)
++ default_visual = gtk.gdk.visual_get_system()
++ pixmap = gtk.gdk.Pixmap(None, width, height, default_visual.depth)
+ colormap = gtk.gdk.colormap_get_system()
+ white = colormap.alloc_color(65535, 65535, 65535)
+ black = colormap.alloc_color(0, 0, 0)