summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-28 14:56:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-28 14:56:56 +0000
commit6d8e2e3609bbf2b5947c677b35ff3420aba7da7e (patch)
treeea0318af63bc041bbc0581b4d8b5d71b60aab008 /media-sound/ezstream
parentAdd Gtk+ 2 slot dep (diff)
downloadgentoo-2-6d8e2e3609bbf2b5947c677b35ff3420aba7da7e.tar.gz
gentoo-2-6d8e2e3609bbf2b5947c677b35ff3420aba7da7e.tar.bz2
gentoo-2-6d8e2e3609bbf2b5947c677b35ff3420aba7da7e.zip
Version bump wrt #294040 by Mr. Anderson.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ezstream')
-rw-r--r--media-sound/ezstream/ChangeLog9
-rw-r--r--media-sound/ezstream/ezstream-0.5.6.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-sound/ezstream/ChangeLog b/media-sound/ezstream/ChangeLog
index 1befc75c6a75..3b66f079a31d 100644
--- a/media-sound/ezstream/ChangeLog
+++ b/media-sound/ezstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ezstream
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ChangeLog,v 1.9 2009/07/23 08:15:50 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ChangeLog,v 1.10 2011/03/28 14:56:56 ssuominen Exp $
+
+*ezstream-0.5.6 (28 Mar 2011)
+
+ 28 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +ezstream-0.5.6.ebuild:
+ Version bump wrt #294040 by Mr. Anderson.
23 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> ezstream-0.5.3.ebuild,
+files/ezstream.confd, +files/ezstream.initd:
diff --git a/media-sound/ezstream/ezstream-0.5.6.ebuild b/media-sound/ezstream/ezstream-0.5.6.ebuild
new file mode 100644
index 000000000000..31c9cd038df4
--- /dev/null
+++ b/media-sound/ezstream/ezstream-0.5.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ezstream-0.5.6.ebuild,v 1.1 2011/03/28 14:56:56 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="http://www.icecast.org/ezstream.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+COMMON_DEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2.2
+ media-libs/libvorbis
+ taglib? ( media-libs/taglib )"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/icecast"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local docdir=/usr/share/doc/${PF}
+
+ econf \
+ --docdir=${docdir} \
+ --enable-examplesdir=${docdir}/examples \
+ $(use_with taglib)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+}