summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-28 20:15:08 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-28 20:15:08 +0000
commitc72ab95ca8a0ce6306bb073dcc7de976a16c4e47 (patch)
treef9ecc698cd87cd9f17c3c9e3910bdff4e7ad38df /media-sound/fluidsynth
parentAdded alsa to IUSE. (Manifest recommit) (diff)
downloadgentoo-2-c72ab95ca8a0ce6306bb073dcc7de976a16c4e47.tar.gz
gentoo-2-c72ab95ca8a0ce6306bb073dcc7de976a16c4e47.tar.bz2
gentoo-2-c72ab95ca8a0ce6306bb073dcc7de976a16c4e47.zip
Version bump. Added ~sparc.
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog8
-rw-r--r--media-sound/fluidsynth/Manifest4
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.51
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.5.ebuild60
4 files changed, 71 insertions, 2 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 84b267b4d75d..e99b16f544bf 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.15 2004/09/03 17:17:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.16 2004/09/28 20:15:08 eradicator Exp $
+
+*fluidsynth-1.0.5 (28 Sep 2004)
+
+ 28 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +fluidsynth-1.0.5.ebuild:
+ Version bump. Added ~sparc.
03 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
fluidsynth-1.0.3.ebuild:
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 05bf967f32e0..02ba2e478f98 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,7 +1,9 @@
MD5 92c3eefe66d8a91fc0e29750fe9a29ea ChangeLog 2159
MD5 a56aff4f21cf525850ec7607709334ee fluidsynth-1.0.1.ebuild 1386
-MD5 08f73bf08781a82851c5951630dc0de4 fluidsynth-1.0.3.ebuild 1653
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 222f5173e10bcaafeb60ca1c4aba40fb fluidsynth-1.0.5.ebuild 1644
+MD5 08f73bf08781a82851c5951630dc0de4 fluidsynth-1.0.3.ebuild 1653
MD5 c1870b0eef4d2331c692f1206a55ac6d files/1.0.3-nonx86.patch 215
MD5 76597f227dd6266c408aab1d4f58da85 files/digest-fluidsynth-1.0.1 68
MD5 751ab7ab31fc6b9ccf266a683545b750 files/digest-fluidsynth-1.0.3 68
+MD5 7f3eace12f38e061b55b4b207bc65184 files/digest-fluidsynth-1.0.5 68
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.5 b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.5
new file mode 100644
index 000000000000..019c9fd96411
--- /dev/null
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.5
@@ -0,0 +1 @@
+MD5 eaee2276ef9cdc3bd17138c74098de83 fluidsynth-1.0.5.tar.gz 991183
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild
new file mode 100644
index 000000000000..95bb79193861
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild,v 1.1 2004/09/28 20:15:08 eradicator Exp $
+
+IUSE="alsa jack sse ladcca"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="IIWU Synth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ alsa? ( media-libs/alsa-lib
+ ladcca? ( >=media-libs/ladcca-0.3 ) )"
+
+# Alsa is required for ladcca support in this package.
+
+asrc_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/1.0.3-nonx86.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="--enable-ladspa"
+ if use alsa; then
+ myconf="${myconf} --enable-alsa `use_enable ladcca`"
+ else
+ myconf="${myconf} --disable-alsa --disable-ladcca"
+ fi
+ use jack || myconf="--disable-jack-support ${myconf}"
+ if use sse; then
+ myconf="--enable-SSE ${myconf}"
+ # If your CFLAGS include optimizations for sse, ie:
+ # -march=pentium4 -mfpmath=sse -msse2
+ # AND your USE flags include sse, ie: USE=sse,
+ # the sounds with fluidsynth will be distorted.
+ if [ `is-flag "-march=pentium4"` ]; then
+ filter-flags "-msse2"
+ filter-flags "-mfpmath=sse"
+ fi
+ fi
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING INSTALL NEWS README THANKS TODO
+}
+
+