summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-16 06:30:16 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-16 06:30:16 +0000
commiteac878cc8216a7a53f329db7159814220128e67e (patch)
treefa05f70f58429c153a039d7de17f9253a4afa7eb /media-sound/fluidsynth
parentAdding ebuilds for 2.4.26 from linux-mips CVS. Also some typo fixes in the o... (diff)
downloadgentoo-2-eac878cc8216a7a53f329db7159814220128e67e.tar.gz
gentoo-2-eac878cc8216a7a53f329db7159814220128e67e.tar.bz2
gentoo-2-eac878cc8216a7a53f329db7159814220128e67e.zip
~amd64
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog6
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.3.ebuild13
2 files changed, 13 insertions, 6 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 753bb32e3338..190d5d13aec3 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.8 2004/04/08 07:52:53 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.9 2004/04/16 06:30:16 lv Exp $
+
+ 16 Apr 2004; Travis Tilley <lv@gentoo.org> fluidsynth-1.0.3.ebuild:
+ adding ~amd64 keyword and versioned ladcca dependency - see bug #46916 for
+ more information
08 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
fluidsynth-1.0.1.ebuild, fluidsynth-1.0.3.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
index b4c8abe197ab..bb3e59360587 100644
--- a/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild,v 1.7 2004/04/08 07:52:53 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild,v 1.8 2004/04/16 06:30:16 lv Exp $
inherit flag-o-matic eutils
@@ -10,12 +10,13 @@ SRC_URI="http://savannah.nongnu.org/download/fluid/stable.pkg/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86 ppc ~amd64"
IUSE="alsa jack sse"
-DEPEND="jack? ( virtual/jack ) \
- media-libs/ladspa-sdk \
+DEPEND="jack? ( virtual/jack )
+ media-libs/ladspa-sdk
+ amd64? ( ladcca? ( =media-libs/ladcca-0.3* ) )
alsa? ( media-libs/alsa-lib )"
# Removed as it doesn't support new ladcca yet ... bug #46916
@@ -32,7 +33,9 @@ src_unpack() {
src_compile() {
local myconf
myconf="--enable-ladspa"
-# use ladcca || myconf="--disable-ladcca ${myconf}"
+ #use ladcca || myconf="--disable-ladcca ${myconf}"
+ use amd64 && myconf="`use_enable ladcca` ${myconf}" \
+ || myconf="--disable-ladcca ${myconf}"
use alsa || myconf="--disable-alsa ${myconf}"
use jack || myconf="--disable-jack-support ${myconf}"
if [ `use sse` ]; then