summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-20 04:51:01 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-20 04:51:01 +0000
commit6c4fc9371e7cb600d92bdc7ca6bc33146e043c55 (patch)
treecc66db96541842fc5c647e2511d0a8f0feb29c46 /media-sound/frescobaldi
parentAdded ~alpha, bug 548352. (diff)
downloadgentoo-2-6c4fc9371e7cb600d92bdc7ca6bc33146e043c55.tar.gz
gentoo-2-6c4fc9371e7cb600d92bdc7ca6bc33146e043c55.tar.bz2
gentoo-2-6c4fc9371e7cb600d92bdc7ca6bc33146e043c55.zip
bump; py3 support added
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/ChangeLog9
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.18.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-sound/frescobaldi/ChangeLog b/media-sound/frescobaldi/ChangeLog
index 6de39eac49b2..5d774aeaef8f 100644
--- a/media-sound/frescobaldi/ChangeLog
+++ b/media-sound/frescobaldi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/frescobaldi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/frescobaldi/ChangeLog,v 1.28 2014/10/27 05:44:48 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/frescobaldi/ChangeLog,v 1.29 2015/05/20 04:51:01 idella4 Exp $
+
+*frescobaldi-2.18 (20 May 2015)
+
+ 20 May 2015; Ian Delaney <idella4@gentoo.org> +frescobaldi-2.18.ebuild:
+ bump; py3 support added
27 Oct 2014; Samuli Suominen <ssuominen@gentoo.org>
-frescobaldi-2.0.13.ebuild, -frescobaldi-2.0.14.ebuild,
diff --git a/media-sound/frescobaldi/frescobaldi-2.18.ebuild b/media-sound/frescobaldi/frescobaldi-2.18.ebuild
new file mode 100644
index 000000000000..0f049b9d2f41
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/frescobaldi/frescobaldi-2.18.ebuild,v 1.1 2015/05/20 04:51:01 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( $(python_gen_cond_dep 'media-libs/portmidi[${PYTHON_USEDEP}]' python2_7) )"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # Instructs install unconditionally for a Windows system
+ rm setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}