summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-08-20 11:14:09 +0000
committerChristoph Mende <angelos@gentoo.org>2011-08-20 11:14:09 +0000
commit49f35ed163870ef0570602a34d146dcc7ffe4e04 (patch)
tree43b25c10f2ffa29d65ec66a9e3bba81f37c7dc68 /media-sound/gmpc/gmpc-11.8.16.ebuild
parentAdd x11-themes/chameleon-xcursors-0.5 (diff)
downloadgentoo-2-49f35ed163870ef0570602a34d146dcc7ffe4e04.tar.gz
gentoo-2-49f35ed163870ef0570602a34d146dcc7ffe4e04.tar.bz2
gentoo-2-49f35ed163870ef0570602a34d146dcc7ffe4e04.zip
Version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/gmpc/gmpc-11.8.16.ebuild')
-rw-r--r--media-sound/gmpc/gmpc-11.8.16.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/gmpc/gmpc-11.8.16.ebuild b/media-sound/gmpc/gmpc-11.8.16.ebuild
new file mode 100644
index 000000000000..c875ee65f7da
--- /dev/null
+++ b/media-sound/gmpc/gmpc-11.8.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-11.8.16.ebuild,v 1.1 2011/08/20 11:14:09 angelos Exp $
+
+EAPI=4
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls xspf +unique"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ >=media-libs/libmpd-11.8
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ unique? ( dev-libs/libunique:1 )
+ xspf? ( >=media-libs/libxspf-1.2 )"
+DEPEND="${RDEPEND}
+ dev-lang/vala:0.12
+ >=dev-util/gob-2.0.17
+ dev-util/pkgconfig
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ VALAC=$(type -p valac-0.12) \
+ econf \
+ --disable-static \
+ --disable-libspiff \
+ --disable-appindicator \
+ --enable-mmkeys \
+ $(use_enable nls) \
+ $(use_enable unique) \
+ $(use_enable xspf libxspf)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }