summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-19 09:03:44 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-19 09:03:44 +0000
commit895f21604b19f61ec218c93605834e6c03607048 (patch)
tree911a66e0fc21e90fb1ffcab5657f94d157eec5a1 /media-sound/grip
parentNo more CD ripping for 2.4 users because gnome is also masked here. (diff)
downloadgentoo-2-895f21604b19f61ec218c93605834e6c03607048.tar.gz
gentoo-2-895f21604b19f61ec218c93605834e6c03607048.tar.bz2
gentoo-2-895f21604b19f61ec218c93605834e6c03607048.zip
Remove unused patches and ebuild.
(Portage version: 2.1.3.6)
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/files/3.3.0-crashfix.patch20
-rw-r--r--media-sound/grip/files/digest-grip-3.3.03
-rw-r--r--media-sound/grip/files/grip-3.2.0-proxy.patch44
-rw-r--r--media-sound/grip/grip-3.3.0.ebuild53
4 files changed, 0 insertions, 120 deletions
diff --git a/media-sound/grip/files/3.3.0-crashfix.patch b/media-sound/grip/files/3.3.0-crashfix.patch
deleted file mode 100644
index 49ebac953a0f..000000000000
--- a/media-sound/grip/files/3.3.0-crashfix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- grip-3.3.0/src/discdb.c.orig 2005-03-09 00:02:00.230558368 -0500
-+++ grip-3.3.0/src/discdb.c 2005-03-09 00:24:28.317617984 -0500
-@@ -319,7 +319,7 @@
- query->query_match=MATCH_EXACT;
- query->query_matches=0;
-
-- while((inbuffer=DiscDBReadLine(&dataptr))) {
-+ while(query->query_matches < MAX_INEXACT_MATCHES && (inbuffer=DiscDBReadLine(&dataptr))) {
- query->query_list[query->query_matches].list_genre=
- DiscDBGenreValue(g_strstrip(strtok(inbuffer," ")));
-
-@@ -339,7 +339,7 @@
- query->query_match=MATCH_INEXACT;
- query->query_matches=0;
-
-- while((inbuffer=DiscDBReadLine(&dataptr))) {
-+ while(query->query_matches < MAX_INEXACT_MATCHES && (inbuffer=DiscDBReadLine(&dataptr))) {
- query->query_list[query->query_matches].list_genre=
- DiscDBGenreValue(g_strstrip(strtok(inbuffer," ")));
-
diff --git a/media-sound/grip/files/digest-grip-3.3.0 b/media-sound/grip/files/digest-grip-3.3.0
deleted file mode 100644
index b2bf5d1b2274..000000000000
--- a/media-sound/grip/files/digest-grip-3.3.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a1113ee5462363f94616c0c936653811 grip-3.3.0.tar.gz 795570
-RMD160 a9cb6a1292be5e38fccaa1675d97cd92b86f91d4 grip-3.3.0.tar.gz 795570
-SHA256 2a9bfe456e8240a054430d563ed5f9a3db3dd1f4ca6716b8274fc11e25443112 grip-3.3.0.tar.gz 795570
diff --git a/media-sound/grip/files/grip-3.2.0-proxy.patch b/media-sound/grip/files/grip-3.2.0-proxy.patch
deleted file mode 100644
index c98f1be8e439..000000000000
--- a/media-sound/grip/files/grip-3.2.0-proxy.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur grip-3.2.0/src/discdb.c grip-3.2.0-patched/src/discdb.c
---- grip-3.2.0/src/discdb.c 2004-04-15 12:23:37.000000000 -0600
-+++ grip-3.2.0-patched/src/discdb.c 2004-11-09 15:22:15.000000000 -0700
-@@ -187,17 +187,14 @@
- g_string_sprintf(proxy,"%s:%d",server->proxy->name,
- server->proxy->port);
-
-- curl_easy_setopt(curl_handle,CURLOPT_PROXY,proxy);
--
-- g_string_free(proxy,TRUE);
-+ curl_easy_setopt(curl_handle,CURLOPT_PROXY,proxy->str);
-
- if(*server->proxy->username) {
-+ user=g_string_new(NULL);
- g_string_sprintf(user,"%s:%s",server->proxy->username,
- server->proxy->pswd);
-
-- curl_easy_setopt(curl_handle,CURLOPT_PROXYUSERPWD,user);
--
-- g_string_free(user,TRUE);
-+ curl_easy_setopt(curl_handle,CURLOPT_PROXYUSERPWD,user->str);
- }
- }
-
-@@ -238,11 +235,17 @@
- fclose(outfile);
- }
-
-- g_string_free(uri,TRUE);
--
- curl_slist_free_all(headers);
-
- curl_easy_cleanup(curl_handle);
-+
-+ g_string_free(uri,TRUE);
-+ if(server->use_proxy) {
-+ g_string_free(proxy,TRUE);
-+ if(*server->proxy->username) {
-+ g_string_free(user,TRUE);
-+ }
-+ }
- }
-
- curl_global_cleanup();
diff --git a/media-sound/grip/grip-3.3.0.ebuild b/media-sound/grip/grip-3.3.0.ebuild
deleted file mode 100644
index 8044dd43c33c..000000000000
--- a/media-sound/grip/grip-3.3.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.3.0.ebuild,v 1.15 2007/01/05 07:08:49 flameeyes Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-IUSE="nls vorbis"
-
-DESCRIPTION="GTK+ based Audio CD Player/Ripper."
-HOMEPAGE="http://www.nostatic.org/grip"
-SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-
-RDEPEND=">=x11-libs/gtk+-2.2
- x11-libs/vte
- media-sound/lame
- media-sound/cdparanoia
- >=media-libs/id3lib-3.8.3
- >=gnome-base/libgnomeui-2.2.0
- >=gnome-base/orbit-2
- net-misc/curl
- vorbis? ( media-sound/vorbis-tools )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # see #84704
- epatch ${FILESDIR}/${PV}-crashfix.patch
-}
-
-src_compile() {
- # Bug #69536
- [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
-
- strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nl pt_BR ru zh_CN zh_HK zh_TW
-
- econf \
- --disable-dependency-tracking \
- $(use_enable nls) || die "./configure failed"
- emake || die "emake failed"
-}
-
-src_install () {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CREDITS ChangeLog README TODO
-}