summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-12 13:55:01 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-12 13:55:01 +0000
commit756fed7b4851fec2223bff8972e98fd228b809ae (patch)
tree3518ab9ebd30fc92d4dfabe26a08bdd725babe24 /media-sound/k4guitune
parent[app-emulation/xen-tools] re-expand newinitd, fixes Bug 392403, patch prepare... (diff)
downloadgentoo-2-756fed7b4851fec2223bff8972e98fd228b809ae.tar.gz
gentoo-2-756fed7b4851fec2223bff8972e98fd228b809ae.tar.bz2
gentoo-2-756fed7b4851fec2223bff8972e98fd228b809ae.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/k4guitune')
-rw-r--r--media-sound/k4guitune/ChangeLog10
-rw-r--r--media-sound/k4guitune/files/k4guitune-1.1.1-desktop_entry.patch10
-rw-r--r--media-sound/k4guitune/k4guitune-1.1.1.ebuild38
3 files changed, 56 insertions, 2 deletions
diff --git a/media-sound/k4guitune/ChangeLog b/media-sound/k4guitune/ChangeLog
index 38ea31f19dbc..c940174952d3 100644
--- a/media-sound/k4guitune/ChangeLog
+++ b/media-sound/k4guitune/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/k4guitune
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/k4guitune/ChangeLog,v 1.5 2011/10/28 23:42:44 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k4guitune/ChangeLog,v 1.6 2012/01/12 13:55:01 johu Exp $
+
+*k4guitune-1.1.1 (12 Jan 2012)
+
+ 12 Jan 2012; Johannes Huber <johu@gentoo.org>
+ +files/k4guitune-1.1.1-desktop_entry.patch, +k4guitune-1.1.1.ebuild:
+ Version bump.
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> k4guitune-1.1.0.ebuild:
Bump to EAPI=4
diff --git a/media-sound/k4guitune/files/k4guitune-1.1.1-desktop_entry.patch b/media-sound/k4guitune/files/k4guitune-1.1.1-desktop_entry.patch
new file mode 100644
index 000000000000..34ff6501df29
--- /dev/null
+++ b/media-sound/k4guitune/files/k4guitune-1.1.1-desktop_entry.patch
@@ -0,0 +1,10 @@
+--- k4guitune.orig/src/k4guitune.desktop 2009-12-29 14:54:54.000000000 +0100
++++ k4guitune/src/k4guitune.desktop 2012-01-12 14:42:56.000000000 +0100
+@@ -7,6 +7,6 @@
+ DocPath=k4guitune/index.html
+ Categories=Qt;KDE;AudioVideo;
+ GenericName=A chromatic tumer for KDE4
+-Terminal=0
++Terminal=false
+
+ X-Ubuntu-Gettext-Domain=desktop_kdesdk
diff --git a/media-sound/k4guitune/k4guitune-1.1.1.ebuild b/media-sound/k4guitune/k4guitune-1.1.1.ebuild
new file mode 100644
index 000000000000..80d2cad29543
--- /dev/null
+++ b/media-sound/k4guitune/k4guitune-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k4guitune/k4guitune-1.1.1.ebuild,v 1.1 2012/01/12 13:55:01 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK=optional
+inherit kde4-base
+
+DESCRIPTION="A program to tune a musical instrument using your computer and it's mic- or line- input"
+HOMEPAGE="http://wspinell.altervista.org/k4guitune/ http://www.kde-apps.org/content/show.php/K4Guitune?content=117669"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/117669-${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="=sci-libs/fftw-3*"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}/${P}-desktop_entry.patch" )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -e '/set[[:space:]]*([[:space:]]*HTML_INSTALL_DIR/s/^/# DISABLED /' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ )
+
+ kde4-base_src_configure
+}