summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-25 22:59:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-25 22:59:05 +0000
commitbc307ac67470441b87bae953cb11a84f8e89132f (patch)
tree52ac7bc37b5ebf87fa3ecc173ad9f74d58fb6483 /media-sound/lame
parentBump. (diff)
downloadgentoo-2-bc307ac67470441b87bae953cb11a84f8e89132f.tar.gz
gentoo-2-bc307ac67470441b87bae953cb11a84f8e89132f.tar.bz2
gentoo-2-bc307ac67470441b87bae953cb11a84f8e89132f.zip
use ABI vs DEFAULT_ABI to determine the default ABI as suggested by mgorny in bug #473852
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog6
-rw-r--r--media-sound/lame/lame-3.99.5-r1.ebuild12
2 files changed, 8 insertions, 10 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index f038f29d1da8..5e59add656c1 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.164 2013/06/19 17:18:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.165 2013/06/25 22:59:05 aballier Exp $
+
+ 25 Jun 2013; Alexis Ballier <aballier@gentoo.org> lame-3.99.5-r1.ebuild:
+ use ABI vs DEFAULT_ABI to determine the default ABI as suggested by mgorny in
+ bug #473852
*lame-3.99.5-r1 (19 Jun 2013)
diff --git a/media-sound/lame/lame-3.99.5-r1.ebuild b/media-sound/lame/lame-3.99.5-r1.ebuild
index 7700e91199fc..3713ce5b21e2 100644
--- a/media-sound/lame/lame-3.99.5-r1.ebuild
+++ b/media-sound/lame/lame-3.99.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.5-r1.ebuild,v 1.1 2013/06/19 17:18:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.5-r1.ebuild,v 1.2 2013/06/25 22:59:05 aballier Exp $
EAPI=5
@@ -41,18 +41,12 @@ src_prepare() {
AT_M4DIR=. eautoreconf
}
-is_best_abi() {
- local all_abis=( $(multilib_get_enabled_abis) )
- local best_abi="${all_abis[$(( ${#all_abis[@]} - 1 ))]}"
- [ "${ABI}" = "${best_abi}" ]
-}
-
multilib_src_configure() {
local myconf
use mmx && myconf+="--enable-nasm" #361879
- # Only build the frontend for the best ABI.
- if is_best_abi ; then
+ # Only build the frontend for the default ABI.
+ if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
myconf+=" $(use_enable mp3rtp)"
use sndfile && myconf+=" --with-fileio=sndfile"
else