summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-09 18:25:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-09 18:25:49 +0000
commit2c0d8002cec757c00e76fc272eeb57c7c0aa83ae (patch)
tree1fcc02d6fa6502a9b2ddefbb65364907f11a6dcd /media-sound/lash
parentarm stable wrt bug #513378 (diff)
downloadgentoo-2-2c0d8002cec757c00e76fc272eeb57c7c0aa83ae.tar.gz
gentoo-2-2c0d8002cec757c00e76fc272eeb57c7c0aa83ae.tar.bz2
gentoo-2-2c0d8002cec757c00e76fc272eeb57c7c0aa83ae.zip
Fix underlinking bugs #367589 (missing -luuid) and #514748 (missing -lm). Thanks to Diego Elio Pettenò, Christian Compagnon and Ted Tanberry. Fix missing include of string.h for strcmp() while at it.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound/lash')
-rw-r--r--media-sound/lash/ChangeLog9
-rw-r--r--media-sound/lash/files/lash-0.5.4-strcmp.patch12
-rw-r--r--media-sound/lash/files/lash-0.5.4-underlinking.patch23
-rw-r--r--media-sound/lash/lash-0.5.4-r2.ebuild8
4 files changed, 48 insertions, 4 deletions
diff --git a/media-sound/lash/ChangeLog b/media-sound/lash/ChangeLog
index a10747c0afb4..013c8c7e69dc 100644
--- a/media-sound/lash/ChangeLog
+++ b/media-sound/lash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.40 2014/05/03 08:27:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.41 2014/07/09 18:25:49 ssuominen Exp $
+
+ 09 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/lash-0.5.4-strcmp.patch, +files/lash-0.5.4-underlinking.patch,
+ lash-0.5.4-r2.ebuild:
+ Fix underlinking bugs #367589 (missing -luuid) and #514748 (missing -lm).
+ Thanks to Diego Elio Pettenò, Christian Compagnon and Ted Tanberry. Fix
+ missing include of string.h for strcmp() while at it.
*lash-0.5.4-r2 (03 May 2014)
diff --git a/media-sound/lash/files/lash-0.5.4-strcmp.patch b/media-sound/lash/files/lash-0.5.4-strcmp.patch
new file mode 100644
index 000000000000..ea9f7ee2fda3
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-strcmp.patch
@@ -0,0 +1,12 @@
+clients/synth/lash.c:85:2: warning: implicit declaration of function ‘strcmp’ [-Wimplicit-function-declaration]
+
+--- clients/synth/lash.c
++++ clients/synth/lash.c
+@@ -22,6 +22,7 @@
+
+ #include "config.h"
+
++#include <string.h>
+ #include <unistd.h>
+
+ #include <lash/lash.h>
diff --git a/media-sound/lash/files/lash-0.5.4-underlinking.patch b/media-sound/lash/files/lash-0.5.4-underlinking.patch
new file mode 100644
index 000000000000..3e52807d267f
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-underlinking.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/367589
+http://bugs.gentoo.org/514748
+
+--- clients/control/Makefile.am
++++ clients/control/Makefile.am
+@@ -18,6 +18,7 @@
+
+ lash_control_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(LASH_LIBS) @READLINE_LIBS@
++ $(LASH_LIBS) @READLINE_LIBS@ \
++ $(UUID_LIBS)
+
+ endif
+--- clients/synth/Makefile.am
++++ clients/synth/Makefile.am
+@@ -20,4 +20,5 @@
+ $(JACK_LIBS) \
+ $(ALSA_LIBS) \
+ $(GTK2_LIBS) \
+- -lpthread
++ -lpthread \
++ -lm
diff --git a/media-sound/lash/lash-0.5.4-r2.ebuild b/media-sound/lash/lash-0.5.4-r2.ebuild
index e98390fb5726..6a41f7bcacbf 100644
--- a/media-sound/lash/lash-0.5.4-r2.ebuild
+++ b/media-sound/lash/lash-0.5.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4-r2.ebuild,v 1.1 2014/05/03 08:27:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4-r2.ebuild,v 1.2 2014/07/09 18:25:49 ssuominen Exp $
EAPI=5
@@ -45,9 +45,11 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-glibc2.8.patch \
"${FILESDIR}"/${P}-swig_version_comparison.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-underlinking.patch \
+ "${FILESDIR}"/${P}-strcmp.patch
- AT_M4DIR="m4" eautoreconf
+ AT_M4DIR=m4 eautoreconf
}
multilib_src_configure() {