summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2007-04-10 20:09:52 +0000
committerStephen Klimaszewski <steev@gentoo.org>2007-04-10 20:09:52 +0000
commit922a12e3b4734152dbd6d55c1b5ac9e0e1a3e67a (patch)
tree1a4be8a6706da5c0d5fb64490d80b78e93cf1b3a /media-sound/last-exit
parentadded FDL license, added a die comment, restructured and added some quotes, r... (diff)
downloadgentoo-2-922a12e3b4734152dbd6d55c1b5ac9e0e1a3e67a.tar.gz
gentoo-2-922a12e3b4734152dbd6d55c1b5ac9e0e1a3e67a.tar.bz2
gentoo-2-922a12e3b4734152dbd6d55c1b5ac9e0e1a3e67a.zip
Add patch from Gnome bugzilla to fix parsing. Closes bug #174076, thanks to Jakub for reporting
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-sound/last-exit')
-rw-r--r--media-sound/last-exit/ChangeLog7
-rw-r--r--media-sound/last-exit/files/last-exit-4.0-decimal_parse.patch18
-rw-r--r--media-sound/last-exit/last-exit-4.0.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/media-sound/last-exit/ChangeLog b/media-sound/last-exit/ChangeLog
index 51d488df0d18..42ccb15534ee 100644
--- a/media-sound/last-exit/ChangeLog
+++ b/media-sound/last-exit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/last-exit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/ChangeLog,v 1.10 2007/01/25 17:27:03 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/ChangeLog,v 1.11 2007/04/10 20:09:52 steev Exp $
+
+ 10 Apr 2007; Steev Klimaszewski <steev@gentoo.org>
+ +files/last-exit-4.0-decimal_parse.patch, last-exit-4.0.ebuild:
+ Add patch from Gnome bugzilla to fix parsing. Closes bug #174076, thanks to
+ Jakub for reporting.
25 Jan 2007; Steev Klimaszewski <steev@gentoo.org> last-exit-4.0.ebuild:
Need to run eautoreconf when patching Makefile.am. I fail. Fixed now, thanks
diff --git a/media-sound/last-exit/files/last-exit-4.0-decimal_parse.patch b/media-sound/last-exit/files/last-exit-4.0-decimal_parse.patch
new file mode 100644
index 000000000000..ff3e167e3778
--- /dev/null
+++ b/media-sound/last-exit/files/last-exit-4.0-decimal_parse.patch
@@ -0,0 +1,18 @@
+Index: FindStation.cs
+===================================================================
+--- src/FindStation.cs (revision 104)
++++ src/FindStation.cs (working copy)
+@@ -422,13 +422,11 @@
+ while (ienum.MoveNext ()) {
+ XmlNode a_node = (XmlNode) ienum.Current;
+ SimilarArtist similar = new SimilarArtist ();
+-
+ similar.Name = get_node_text (a_node, "name");
+ similar.Streamable = (get_node_text (a_node, "streamable") == "0");
+ similar.Mbid = get_node_text (a_node, "mbid");
+ similar.Url = get_node_text (a_node, "url");
+- similar.Relevance = Int32.Parse (get_node_text (a_node, "match"));
+-
++ similar.Relevance = Decimal.ToInt32(Decimal.Parse (get_node_text (a_node, "match")));
+ artist.AddSimilarArtist (similar);
+ }
diff --git a/media-sound/last-exit/last-exit-4.0.ebuild b/media-sound/last-exit/last-exit-4.0.ebuild
index 52faf0eace0d..97382c131574 100644
--- a/media-sound/last-exit/last-exit-4.0.ebuild
+++ b/media-sound/last-exit/last-exit-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/last-exit-4.0.ebuild,v 1.4 2007/01/25 17:27:03 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/last-exit/last-exit-4.0.ebuild,v 1.5 2007/04/10 20:09:52 steev Exp $
inherit mono gnome2 eutils autotools
@@ -38,6 +38,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}"/${PN}-dbus-sharp-parallel-build-fix.patch
+ epatch "${FILESDIR}"/${PN}-4.0-decimal_parse.patch
eautoreconf
}