summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-11 11:17:36 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-11 11:17:36 +0000
commit7f51c02a5fd8a28f7a5f4f17d5280ca8c4320d1d (patch)
tree2c0e610b4c793e02d5e7808a2416740c6b3f9df6 /media-sound/lastfmplayer
parentStable on ppc wrt bug #141577. (diff)
downloadgentoo-2-7f51c02a5fd8a28f7a5f4f17d5280ca8c4320d1d.tar.gz
gentoo-2-7f51c02a5fd8a28f7a5f4f17d5280ca8c4320d1d.tar.bz2
gentoo-2-7f51c02a5fd8a28f7a5f4f17d5280ca8c4320d1d.zip
version bump thanks to Jouni Rinne in bug 164044
(Portage version: 2.1.2-r7)
Diffstat (limited to 'media-sound/lastfmplayer')
-rw-r--r--media-sound/lastfmplayer/ChangeLog9
-rw-r--r--media-sound/lastfmplayer/files/digest-lastfmplayer-1.1.33
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild66
3 files changed, 76 insertions, 2 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index f0d075b75f97..4f8f570b9e08 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lastfmplayer
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.10 2006/11/04 20:58:19 genstef Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.11 2007/02/11 11:17:36 genstef Exp $
+
+*lastfmplayer-1.1.3 (11 Feb 2007)
+
+ 11 Feb 2007; <genstef@gentoo.org> +lastfmplayer-1.1.3.ebuild:
+ version bump thanks to Jouni Rinne in bug 164044
04 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
lastfmplayer-1.0.0.1_p2113.ebuild:
diff --git a/media-sound/lastfmplayer/files/digest-lastfmplayer-1.1.3 b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.1.3
new file mode 100644
index 000000000000..2f5b667e9411
--- /dev/null
+++ b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.1.3
@@ -0,0 +1,3 @@
+MD5 237531e1b30f75c4c0c07e7e39e9a250 last.fm-1.1.3.src.tar.bz2 856755
+RMD160 bfbddb23975dec3186251ebb3e1dcd4d0ad4ff9f last.fm-1.1.3.src.tar.bz2 856755
+SHA256 e05f9b1e177f6c4801295d33246e891690447c594b1138a292779dcef7d85cec last.fm-1.1.3.src.tar.bz2 856755
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild
new file mode 100644
index 000000000000..ce66e163e8f9
--- /dev/null
+++ b/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild,v 1.1 2007/02/11 11:17:36 genstef Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="The player allows you to listen to last.fm radio streams"
+HOMEPAGE="http://www.last.fm/help/player"
+MY_P="${P/lastfmplayer/last.fm}"
+SRC_URI="http://static.last.fm/client/Linux/${MY_P}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="nomirror"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=x11-libs/qt-4.2
+ media-libs/alsa-lib"
+
+src_compile() {
+ ./configure
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ # Docs
+ dodoc ChangeLog README
+
+ # The root at which the player, data, and cache
+ # are to be installed
+ local destination="/opt/lastfm"
+ cd bin
+
+ # Make ${destination} writable by audio group
+ diropts -m0775 -g audio
+ dodir ${destination}
+
+ # Install the player
+ cp -R * ${D}/${destination}
+
+ # Make a folder such that album art cache works
+ diropts -m0775 -g audio
+ dodir ${destination}/cache
+ keepdir ${destination}/cache
+
+ # Icon, menu, protcol
+ make_wrapper lastfm ./last.fm ${destination} ${destination}
+ newicon data/icons/as.png lastfm.png
+ make_desktop_entry lastfm "Last.fm Player" lastfm.png
+
+ insinto /usr/share/services
+ doins ${FILESDIR}/lastfm.protocol
+}
+
+pkg_postinst() {
+ einfo "To use the Last.fm player with a mozilla based browser:"
+ einfo " 1. Go to about:config in the browser"
+ einfo " 2. Right-click on the page"
+ einfo " 3. Select New and then String"
+ einfo " 4. For the name: network.protocol-handler.app.lastfm"
+ einfo " 5. For the value: /usr/bin/lastfm"
+ einfo
+ einfo "If you experiance awkward fonts or widgets, try running qtconfig."
+}