summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-23 19:59:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-23 19:59:03 +0000
commita8c7f9b9a920d425ebb6110292ec170b04c37cdc (patch)
tree85018c50650ab0b191b0c3ccd527f20ae63eef27 /media-sound/lxmusic
parentmarked x86 per bug 417203 (diff)
downloadgentoo-2-a8c7f9b9a920d425ebb6110292ec170b04c37cdc.tar.gz
gentoo-2-a8c7f9b9a920d425ebb6110292ec170b04c37cdc.tar.bz2
gentoo-2-a8c7f9b9a920d425ebb6110292ec170b04c37cdc.zip
Version bump
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lxmusic')
-rw-r--r--media-sound/lxmusic/ChangeLog8
-rw-r--r--media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch27
-rw-r--r--media-sound/lxmusic/lxmusic-0.4.5.ebuild25
3 files changed, 59 insertions, 1 deletions
diff --git a/media-sound/lxmusic/ChangeLog b/media-sound/lxmusic/ChangeLog
index 67e70f9a26fb..d49a0b0e1516 100644
--- a/media-sound/lxmusic/ChangeLog
+++ b/media-sound/lxmusic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lxmusic
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/ChangeLog,v 1.4 2012/05/05 08:33:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/ChangeLog,v 1.5 2012/05/23 19:59:03 hwoarang Exp $
+
+*lxmusic-0.4.5 (23 May 2012)
+
+ 23 May 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/lxmusic-0.4.5-libnotify-0.7.patch, +lxmusic-0.4.5.ebuild:
+ Version bump
05 May 2012; Michał Górny <mgorny@gentoo.org> lxmusic-0.4.4.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch b/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch
new file mode 100644
index 000000000000..01f513de4c3a
--- /dev/null
+++ b/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+Upstream:
+https://sourceforge.net/tracker/?func=detail&aid=3529198&group_id=180858&atid=894869
+Index: lxmusic-0.4.5/src/lxmusic-notify.c
+===================================================================
+--- lxmusic-0.4.5.orig/src/lxmusic-notify.c
++++ lxmusic-0.4.5/src/lxmusic-notify.c
+@@ -84,9 +84,20 @@ LXMusicNotification lxmusic_do_notify_pr
+ else
+ g_string_append( message, title );
+ struct _LXMusicNotification *lxn = g_new ( struct _LXMusicNotification, 1);
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ lxn->notify = notify_notification_new (summary, message->str, NULL);
++#else
+ lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
++#endif
++#else
++ lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
++#endif
+ notify_notification_set_urgency (lxn->notify, NOTIFY_URGENCY_NORMAL);
++#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
++ notify_notification_attach_to_status_icon(notify, priv->statusIcon);
+ notify_notification_attach_to_status_icon( lxn->notify, status_icon );
++#endif
+ notify_notification_set_timeout (lxn->notify, NOTIFY_EXPIRES_DEFAULT);
+ g_string_free( message, TRUE );
+ return lxn;
diff --git a/media-sound/lxmusic/lxmusic-0.4.5.ebuild b/media-sound/lxmusic/lxmusic-0.4.5.ebuild
new file mode 100644
index 000000000000..4d1673d56f51
--- /dev/null
+++ b/media-sound/lxmusic/lxmusic-0.4.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/lxmusic-0.4.5.ebuild,v 1.1 2012/05/23 19:59:03 hwoarang Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A simple GUI XMMS2 client with minimal functionality"
+HOMEPAGE="http://lxde.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/xmms2
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}