summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-01 18:20:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-01 18:20:24 +0000
commitfa81653dfe0d35f73a81940f7d98112da39ccfdc (patch)
tree2221e29a35dd71dd2c4844918c17d3ebc128e0c1 /media-sound/mpg123
parentRemove Qt 4.6.0 (diff)
downloadgentoo-2-fa81653dfe0d35f73a81940f7d98112da39ccfdc.tar.gz
gentoo-2-fa81653dfe0d35f73a81940f7d98112da39ccfdc.tar.bz2
gentoo-2-fa81653dfe0d35f73a81940f7d98112da39ccfdc.zip
Version bump wrt #294106, thanks to Shark <shark at bitchx.it> for reporting. Fix ABI handling wrt #295075, thanks to Ferret <ferret at explodingferret.com> for reporting.
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog10
-rw-r--r--media-sound/mpg123/files/mpg123-1.9.2-libtool.patch19
-rw-r--r--media-sound/mpg123/mpg123-1.9.2.ebuild76
3 files changed, 104 insertions, 1 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index 5ad89c06d1d9..e9cf01776e93 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/mpg123
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.209 2009/11/03 17:54:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.210 2009/12/01 18:20:24 ssuominen Exp $
+
+*mpg123-1.9.2 (01 Dec 2009)
+
+ 01 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> +mpg123-1.9.2.ebuild,
+ +files/mpg123-1.9.2-libtool.patch:
+ Version bump wrt #294106, thanks to Shark <shark at bitchx.it> for
+ reporting. Fix ABI handling wrt #295075, thanks to Ferret <ferret at
+ explodingferret.com> for reporting.
03 Nov 2009; Raúl Porcel <armin76@gentoo.org> mpg123-1.9.0.ebuild:
ia64/sparc stable wrt #287239
diff --git a/media-sound/mpg123/files/mpg123-1.9.2-libtool.patch b/media-sound/mpg123/files/mpg123-1.9.2-libtool.patch
new file mode 100644
index 000000000000..ff8ba8f975e7
--- /dev/null
+++ b/media-sound/mpg123/files/mpg123-1.9.2-libtool.patch
@@ -0,0 +1,19 @@
+--- src/module.c
++++ src/module.c
+@@ -123,13 +123,14 @@
+ goto om_bad;
+ }
+ /* Work out the path of the module to open */
+- module_path_len = strlen(type) + 1 + strlen(name) + strlen(MODULE_FILE_SUFFIX) + 1;
++ /* Note that we need to open ./file, not just file! */
++ module_path_len = 2 + strlen(type) + 1 + strlen(name) + strlen(MODULE_FILE_SUFFIX) + 1;
+ module_path = malloc( module_path_len );
+ if (module_path == NULL) {
+ error1( "Failed to allocate memory for module name: %s", strerror(errno) );
+ goto om_bad;
+ }
+- snprintf( module_path, module_path_len, "%s_%s%s", type, name, MODULE_FILE_SUFFIX );
++ snprintf( module_path, module_path_len, "./%s_%s%s", type, name, MODULE_FILE_SUFFIX );
+ /* Display the path of the module created */
+ if(param.verbose > 1) fprintf(stderr, "Module path: %s\n", module_path );
+
diff --git a/media-sound/mpg123/mpg123-1.9.2.ebuild b/media-sound/mpg123/mpg123-1.9.2.ebuild
new file mode 100644
index 000000000000..724291cc104d
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.9.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.9.2.ebuild,v 1.1 2009/12/01 18:20:24 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://www.mpg123.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ http://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="3dnow 3dnowext alsa altivec ipv6 jack mmx nas +network oss portaudio pulseaudio sdl sse"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )
+ sys-devel/libtool"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libtool.patch
+}
+
+src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+ local _ipv6=disable
+
+ for flag in nas portaudio sdl oss jack alsa pulseaudio; do
+ if use ${flag}; then
+ _audio="${_audio} ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+
+ use altivec && _cpu=altivec
+
+ if [[ ${ABI} = amd64 ]] && use sse; then
+ _cpu=x86-64
+ fi
+
+ if [[ ${ABI} = x86 ]]; then
+ _cpu=i586
+ use mmx && _cpu=mmx
+ use 3dnow && _cpu=3dnow
+ use sse && _cpu=x86
+ use 3dnowext && _cpu=x86
+ fi
+
+ if use network && use ipv6; then
+ _ipv6=enable
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --with-optimization=0 \
+ --with-audio="${_audio}" \
+ --with-default-audio=${_output} \
+ --with-cpu=${_cpu} \
+ $(use_enable network) \
+ --${_ipv6}-ipv6
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS* README
+}