summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-13 14:55:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-13 14:55:15 +0000
commit79af64a99bd73513868f283776fdd24efca02f50 (patch)
treefb56a739a9f40f320f4308ebd7c04672a3b13481 /media-sound/musique
parentRemoving older ebuilds (diff)
downloadgentoo-2-79af64a99bd73513868f283776fdd24efca02f50.tar.gz
gentoo-2-79af64a99bd73513868f283776fdd24efca02f50.tar.bz2
gentoo-2-79af64a99bd73513868f283776fdd24efca02f50.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-sound/musique')
-rw-r--r--media-sound/musique/ChangeLog7
-rw-r--r--media-sound/musique/musique-1.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/media-sound/musique/ChangeLog b/media-sound/musique/ChangeLog
index 15a427c53c42..d4f77dd3a0c1 100644
--- a/media-sound/musique/ChangeLog
+++ b/media-sound/musique/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/musique
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/ChangeLog,v 1.12 2013/10/01 21:24:22 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/ChangeLog,v 1.13 2013/10/13 14:55:15 hwoarang Exp $
+
+*musique-1.3 (13 Oct 2013)
+
+ 13 Oct 2013; Markos Chandras <hwoarang@gentoo.org> +musique-1.3.ebuild:
+ Version bump
01 Oct 2013; Davide Pesavento <pesa@gentoo.org> -musique-1.2.ebuild,
-musique-9999.ebuild, musique-1.2.1.ebuild:
diff --git a/media-sound/musique/musique-1.3.ebuild b/media-sound/musique/musique-1.3.ebuild
new file mode 100644
index 000000000000..621cfc3257d5
--- /dev/null
+++ b/media-sound/musique/musique-1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musique/musique-1.3.ebuild,v 1.1 2013/10/13 14:55:15 hwoarang Exp $
+
+EAPI="5"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 music player."
+HOMEPAGE="http://flavio.tordini.org/musique"
+# Same tarball for every release. We repackage it
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4[gtkstyle]
+ dev-qt/qtsql:4[sqlite]
+ || ( dev-qt/qtphonon:4 media-libs/phonon )
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="CHANGES TODO"
+
+src_prepare () {
+ # bug 422665. Upstream only cares about ubuntu
+ # so this bug will be fixed once ubuntu moves
+ # to gcc-4.7. No, I will not send this patch upstream
+ # *again*
+ epatch "${FILESDIR}"/${PN}-1.1-gcc47.patch
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon data/${PN}.svg
+}