summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-29 00:39:37 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-29 00:39:37 +0000
commite46b7309fc8a20374fc98eec11e51859b5e428f8 (patch)
tree48d3b7d986019f24fd4ed293d6d1f48d0a060186 /media-sound/normalize
parentmove from net-ftp #45968 (diff)
downloadgentoo-2-e46b7309fc8a20374fc98eec11e51859b5e428f8.tar.gz
gentoo-2-e46b7309fc8a20374fc98eec11e51859b5e428f8.tar.bz2
gentoo-2-e46b7309fc8a20374fc98eec11e51859b5e428f8.zip
Fixed USE flag support. Closes bug #45944.
Diffstat (limited to 'media-sound/normalize')
-rw-r--r--media-sound/normalize/ChangeLog8
-rw-r--r--media-sound/normalize/Manifest8
-rw-r--r--media-sound/normalize/files/digest-normalize-0.7.6-r2 (renamed from media-sound/normalize/files/digest-normalize-0.7.6)0
-rw-r--r--media-sound/normalize/normalize-0.7.6-r2.ebuild30
-rw-r--r--media-sound/normalize/normalize-0.7.6.ebuild37
5 files changed, 41 insertions, 42 deletions
diff --git a/media-sound/normalize/ChangeLog b/media-sound/normalize/ChangeLog
index 7ebb9a03bfae..3d9885e26881 100644
--- a/media-sound/normalize/ChangeLog
+++ b/media-sound/normalize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/normalize
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.10 2004/03/14 21:54:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.11 2004/03/29 00:39:36 eradicator Exp $
+
+*normalize-0.7.6-r2 (28 Mar 2004)
+
+ 28 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ normalize-0.7.6-r2.ebuild, normalize-0.7.6.ebuild:
+ Fixed USE flag support. Closes bug #45944.
14 Mar 2004; Jason Wever <weeve@gentoo.org> normalize-0.7.6-r1.ebuild:
Stable on sparc.
diff --git a/media-sound/normalize/Manifest b/media-sound/normalize/Manifest
index 3930c1309b79..178685906a3f 100644
--- a/media-sound/normalize/Manifest
+++ b/media-sound/normalize/Manifest
@@ -1,8 +1,8 @@
-MD5 5d55d3ea0e6f7a204d80fca1e5c660f8 ChangeLog 1588
MD5 71e3e9edd5e163ec241bab2def5aaea6 normalize-0.7.4.ebuild 982
MD5 c185e379dda3914c000bf4c4f1e3eae5 normalize-0.7.6-r1.ebuild 816
-MD5 9669d889a4562e8fa397f6840dce17a9 normalize-0.7.6.ebuild 987
+MD5 a65fd98f6790b281a12aa8c5f6e3fc4e normalize-0.7.6-r2.ebuild 830
+MD5 5d55d3ea0e6f7a204d80fca1e5c660f8 ChangeLog 1588
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 d5be91906061cbb310757eeccd79c6cc files/digest-normalize-0.7.4 68
-MD5 ca7f6d0db3e04885c8412eb70cb1a482 files/digest-normalize-0.7.6 68
MD5 ca7f6d0db3e04885c8412eb70cb1a482 files/digest-normalize-0.7.6-r1 68
+MD5 ca7f6d0db3e04885c8412eb70cb1a482 files/digest-normalize-0.7.6-r2 68
+MD5 d5be91906061cbb310757eeccd79c6cc files/digest-normalize-0.7.4 68
diff --git a/media-sound/normalize/files/digest-normalize-0.7.6 b/media-sound/normalize/files/digest-normalize-0.7.6-r2
index ee037f359f68..ee037f359f68 100644
--- a/media-sound/normalize/files/digest-normalize-0.7.6
+++ b/media-sound/normalize/files/digest-normalize-0.7.6-r2
diff --git a/media-sound/normalize/normalize-0.7.6-r2.ebuild b/media-sound/normalize/normalize-0.7.6-r2.ebuild
new file mode 100644
index 000000000000..fd3815dff34b
--- /dev/null
+++ b/media-sound/normalize/normalize-0.7.6-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/normalize-0.7.6-r2.ebuild,v 1.1 2004/03/29 00:39:36 eradicator Exp $
+
+DESCRIPTION="Audio file volume normalizer"
+HOMEPAGE="http://www.cs.columbia.edu/~cvaill/normalize"
+SRC_URI="http://www1.cs.columbia.edu/~cvaill/normalize/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc sparc amd64"
+IUSE="xmms mad audiofile"
+
+DEPEND="xmms? ( >=media-sound/xmms-1.2.7-r6 )
+ mad? ( >=media-sound/mad-0.14.2b )
+ audiofile? ( >=media-libs/audiofile-0.2.3-r1 )"
+
+src_compile() {
+ econf `use_with mad` \
+ `use_enable xmms` \
+ `use_with audiofile` \
+ ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc NEWS README THANKS TODO
+}
diff --git a/media-sound/normalize/normalize-0.7.6.ebuild b/media-sound/normalize/normalize-0.7.6.ebuild
deleted file mode 100644
index 2a39650fe67e..000000000000
--- a/media-sound/normalize/normalize-0.7.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/normalize-0.7.6.ebuild,v 1.5 2004/03/01 05:37:15 eradicator Exp $
-
-IUSE="xmms"
-
-DESCRIPTION="Audio file volume normalizer"
-HOMEPAGE="http://www.cs.columbia.edu/~cvaill/normalize"
-SRC_URI="http://www.cs.columbia.edu/~cvaill/normalize/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
-
-RDEPEND="xmms? ( >=media-sound/xmms-1.2.7-r6 )
- >=media-libs/audiofile-0.2.3-r1
- >=media-sound/mad-0.14.2b-r1"
-
-# NOTE: the "audiofile" and "mad" dependencies are NOT
-# actually *required*, they are optional, but there are no
-# appropriate USE variables.
-#
-# The libraries are quite small, so it does not seem to be that
-# big a deal to force installation of them.
-#
-
-src_compile() {
- econf \
- --with-audiofile \
- --with-mad || die
-
- emake || die "emake failed"
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-}