summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-09 20:57:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-09 20:57:02 +0000
commit572bff0cafebdde4c3c7dc8b1b3c2f92b31836e3 (patch)
treecbb1bb721511d8983b098ba82810d6b5ec83f197 /media-sound/nted
parentFix makefile recursion. (diff)
downloadgentoo-2-572bff0cafebdde4c3c7dc8b1b3c2f92b31836e3.tar.gz
gentoo-2-572bff0cafebdde4c3c7dc8b1b3c2f92b31836e3.tar.bz2
gentoo-2-572bff0cafebdde4c3c7dc8b1b3c2f92b31836e3.zip
Fix force --as-needed bug 276286
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog9
-rw-r--r--media-sound/nted/files/makefile_am_ldflags.patch23
-rw-r--r--media-sound/nted/nted-1.6.0-r3.ebuild42
3 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index b4d5734d8c22..ed12b8be1ae7 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/nted
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.3 2009/07/02 14:22:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.4 2009/07/09 20:57:01 hwoarang Exp $
+
+*nted-1.6.0-r3 (09 Jul 2009)
+
+ 09 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +nted-1.6.0-r3.ebuild,
+ +files/makefile_am_ldflags.patch:
+ Fix force --as-needed bug 276286. Thanks to Diego E. 'Flameeyes' Pettenò
+ <flameeyes@gentoo.org>
*nted-1.6.0-r2 (02 Jul 2009)
diff --git a/media-sound/nted/files/makefile_am_ldflags.patch b/media-sound/nted/files/makefile_am_ldflags.patch
new file mode 100644
index 000000000000..8d83a28393dc
--- /dev/null
+++ b/media-sound/nted/files/makefile_am_ldflags.patch
@@ -0,0 +1,23 @@
+Index: nted-1.6.0/Makefile.am
+===================================================================
+--- nted-1.6.0.orig/Makefile.am
++++ nted-1.6.0/Makefile.am
+@@ -33,8 +33,6 @@ AM_CPPFLAGS += -DLOCALEDIR=\"${localedir
+ AM_CPPFLAGS += -I$(top_srcdir)/dialogs -I$(top_srcdir)/commands -I$(top_srcdir)/chords -I$(top_srcdir)/idiotseditor
+ AM_CPPFLAGS += $(FT2_CFLAGS) $(CAIRO_CFLAGS) $(GTK_CFLAGS)
+
+-AM_LDFLAGS = $(CAIRO_LIBS) $(PANGO_LIBS) $(GTK_LIBS) -lasound
+-
+ bin_PROGRAMS = nted
+ nted_SOURCES = mainwindow.cpp resource.cpp page.cpp system.cpp staff.cpp \
+ voice.cpp chordorrest.cpp note.cpp musicxmlimport.cpp \
+@@ -53,7 +51,8 @@ nted_SOURCES += acceleration.h beam.h be
+ temposign.h tuplet.h voice.h volumesign.h positionarray.h dynarray.h COPYING.GFDL COPYING.FONT.TXT \
+ freechord.h freespacer.h pangocairotext.h freechordname.h midiimporter2.h
+
+-nted_LDADD = commands/libcommands.a dialogs/libdialogs.a chords/libchords.a idiotseditor/libidiotseditor.a
++nted_LDADD = commands/libcommands.a dialogs/libdialogs.a chords/libchords.a idiotseditor/libidiotseditor.a $(CAIRO_LIBS) $(PANGO_LIBS) $(GTK_LIBS) -lasound
++
+
+ cleanup: maintainer-clean cleanup-local
+
diff --git a/media-sound/nted/nted-1.6.0-r3.ebuild b/media-sound/nted/nted-1.6.0-r3.ebuild
new file mode 100644
index 000000000000..81dc61140041
--- /dev/null
+++ b/media-sound/nted/nted-1.6.0-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.6.0-r3.ebuild,v 1.1 2009/07/09 20:57:01 hwoarang Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+2"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls debug"
+RDEPEND="doc? ( gnome-extra/yelp app-text/xmlto )
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.desktop.patch"
+ epatch "${FILESDIR}/${P}-time-signature.patch"
+ epatch "${FILESDIR}/makefile_am_ldflags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with doc) \
+ $(use_enable debug) \
+ $(use_enable nls) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ABOUT_* ChangeLog FAQ NEWS README || die "dodoc failed"
+ doman "man/${PN}.1" || die "doman failed"
+}