summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-31 20:10:51 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-31 20:10:51 +0000
commitc4aed0b1fe0c7e57309b484f57c414c43fb50f4b (patch)
tree7ce3c9b4943678af3f3fb3263f5270a4fb10f5c3 /media-sound/radiomixer
parentStable on alpha, bug #254447 (diff)
downloadgentoo-2-c4aed0b1fe0c7e57309b484f57c414c43fb50f4b.tar.gz
gentoo-2-c4aed0b1fe0c7e57309b484f57c414c43fb50f4b.tar.bz2
gentoo-2-c4aed0b1fe0c7e57309b484f57c414c43fb50f4b.zip
Add gcc4.3 build patch and use defaults from bug #251250
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/radiomixer')
-rw-r--r--media-sound/radiomixer/ChangeLog8
-rw-r--r--media-sound/radiomixer/files/radiomixer-1.1_rc1-gcc43.patch11
-rw-r--r--media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild12
3 files changed, 26 insertions, 5 deletions
diff --git a/media-sound/radiomixer/ChangeLog b/media-sound/radiomixer/ChangeLog
index 7427012fe1e9..8e5fa552a34d 100644
--- a/media-sound/radiomixer/ChangeLog
+++ b/media-sound/radiomixer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/radiomixer
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/ChangeLog,v 1.13 2008/03/06 17:20:56 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/ChangeLog,v 1.14 2009/01/31 20:10:51 jokey Exp $
+
+ 31 Jan 2009; <jokey@gentoo.org> +files/radiomixer-1.1_rc1-gcc43.patch,
+ radiomixer-1.1_rc1-r1.ebuild:
+ Add gcc4.3 build patch and use defaults from bug #251250
27 Dec 2007; <rich0@gentoo.org> radiomixer-1.1_rc1-r1.ebuild:
Stable on amd64 - #203348.
diff --git a/media-sound/radiomixer/files/radiomixer-1.1_rc1-gcc43.patch b/media-sound/radiomixer/files/radiomixer-1.1_rc1-gcc43.patch
new file mode 100644
index 000000000000..87b282ae398e
--- /dev/null
+++ b/media-sound/radiomixer/files/radiomixer-1.1_rc1-gcc43.patch
@@ -0,0 +1,11 @@
+diff -rupN radiomixer-1.1RC1b/src/metainfo.cpp radiomixer-1.1RC1/src/metainfo.cpp
+--- radiomixer-1.1RC1b/src/metainfo.cpp 2009-01-24 15:48:58.000000000 -0400
++++ radiomixer-1.1RC1/src/metainfo.cpp 2009-01-24 17:05:04.000000000 -0400
+@@ -20,6 +20,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+ #include "metainfo.h"
++#include <cstdlib>
+
+ metaInfo::metaInfo(QObject *parent, const char *name)
+ : QObject(parent, name)
diff --git a/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild b/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild
index 22f4d2b99c8f..5a5a4ae07bec 100644
--- a/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild
+++ b/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild,v 1.4 2007/12/27 22:43:23 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/radiomixer-1.1_rc1-r1.ebuild,v 1.5 2009/01/31 20:10:51 jokey Exp $
+
+EAPI=2
inherit kde-functions eutils
@@ -11,7 +13,7 @@ SRC_URI="mirror://sourceforge/radiomixer/${PN}-1.1RC1.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="alsa debug hwmixer jack mad vorbis"
+IUSE="alsa debug hwmixer +jack +mad vorbis"
DEPEND="media-libs/libsamplerate
alsa? ( media-libs/alsa-lib )
@@ -61,6 +63,10 @@ pkg_setup() {
elog
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
local myconf
# broken without