summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-23 22:48:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-23 22:48:50 +0000
commit6f3572be6a777ce16c2151567a2a9ca50d16b886 (patch)
tree57d295b36ba34d7522d215b04204dd7dc3f5c315 /media-sound/rhythmbox
parentchanging homepage, bug #231764. (diff)
downloadgentoo-2-6f3572be6a777ce16c2151567a2a9ca50d16b886.tar.gz
gentoo-2-6f3572be6a777ce16c2151567a2a9ca50d16b886.tar.bz2
gentoo-2-6f3572be6a777ce16c2151567a2a9ca50d16b886.zip
Sort IUSE and other cosmetic changes. Add virtualx src_test wrt bug #216146. Update libgpod dependency, bug #231529. Make nautilus-cd-burner dependency optional, bug #209484.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog8
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.11.6.ebuild37
2 files changed, 31 insertions, 14 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 34a5d4c889e0..42274a42ede2 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.131 2008/07/17 23:43:49 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.132 2008/07/23 22:48:50 eva Exp $
+
+ 23 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ rhythmbox-0.11.6.ebuild:
+ Sort IUSE and other cosmetic changes. Add virtualx src_test wrt bug
+ #216146. Update libgpod dependency, bug #231529. Make nautilus-cd-burner
+ dependency optional, bug #209484.
17 Jul 2008; Daniel Gryniewicz <dang@gentoo.org> rhythmbox-0.11.6.ebuild:
Add a celementtree dep. Bug #231530
diff --git a/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild b/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild
index 3b767ef13f30..09279b3f942a 100644
--- a/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild,v 1.3 2008/07/17 23:43:49 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.6.ebuild,v 1.4 2008/07/23 22:48:50 eva Exp $
EAPI="1"
-inherit gnome2 eutils python
+inherit gnome2 eutils python virtualx
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://www.rhythmbox.org/"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
-IUSE="daap dbus doc hal ipod gnome-keyring libnotify lirc musicbrainz mtp python tagwriting"
+IUSE="cdr daap dbus doc hal ipod gnome-keyring libnotify lirc musicbrainz mtp python tagwriting"
# I want tagwriting to be on by default in the future. It is just a local flag
# now because it is still considered experimental by upstream and doesn't work
@@ -25,7 +25,7 @@ RDEPEND=">=x11-libs/gtk+-2.8
>=gnome-base/libglade-2
>=gnome-base/gnome-vfs-2.8
>=dev-libs/totem-pl-parser-2.22.0
- >=gnome-extra/nautilus-cd-burner-2.13
+ cdr? ( >=gnome-extra/nautilus-cd-burner-2.13 )
>=x11-libs/libsexy-0.1.5
>=gnome-extra/gnome-media-2.14.0
gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
@@ -33,7 +33,7 @@ RDEPEND=">=x11-libs/gtk+-2.8
>=net-libs/libsoup-2.4:2.4
lirc? ( app-misc/lirc )
hal? (
- ipod? ( >=media-libs/libgpod-0.4 )
+ ipod? ( >=media-libs/libgpod-0.6 )
mtp? ( >=media-libs/libmtp-0.3.0 )
>=sys-apps/hal-0.5
)
@@ -81,6 +81,11 @@ pkg_setup() {
ewarn "re-emerge with USE=hal to enable MTP support"
fi
+ if ! use cdr ; then
+ ewarn "You have cdr USE flag disabled."
+ ewarn "You will not be able to play audio CDs."
+ fi
+
if use daap ; then
G2CONF="${G2CONF} --enable-daap --with-mdns=avahi"
else
@@ -88,18 +93,19 @@ pkg_setup() {
fi
G2CONF="${G2CONF}
- $(use_enable tagwriting tag-writing)
+ $(use_with cdr libnautilus-burn)
+ $(use_with cdr cd-burning)
+ $(use_with dbus)
+ $(use_with gnome-keyring)
$(use_with ipod)
- $(use_with mtp)
$(use_enable ipod ipod-writing)
- $(use_enable musicbrainz)
- $(use_with dbus)
- $(use_enable python)
$(use_enable libnotify)
$(use_enable lirc)
- $(use_with gnome-keyring)
+ $(use_enable musicbrainz)
+ $(use_with mtp)
+ $(use_enable python)
+ $(use_enable tagwriting tag-writing)
--with-playback=gstreamer-0-10
- --with-cd-burning
--enable-mmkeys
--enable-audioscrobbler
--enable-track-transfer
@@ -114,7 +120,7 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
- #Fix for libmtp-0.3.0 API change
+ # Fix for libmtp-0.3.0 API change
epatch "${FILESDIR}/${PN}-0.11.5-libmtp-0.3.0-API.patch"
# disable pyc compiling
@@ -128,6 +134,10 @@ src_compile() {
gnome2_src_compile
}
+src_test() {
+ Xemake check || die "test failed"
+}
+
pkg_postinst() {
gnome2_pkg_postinst
use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
@@ -142,6 +152,7 @@ pkg_postinst() {
elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
elog "See bug #159538 for more information"
}
+
pkg_postrm() {
gnome2_pkg_postrm
use python && python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins