summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-23 03:30:10 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-23 03:30:10 +0000
commit8e4abbdfb997ef60e9b54847e18c70e7a15f7cc3 (patch)
tree9d8607ac709cb730ce91811ce9772669e0e92a3c /media-sound/shorten/shorten-3.3.ebuild
parentChanged bogus newexe to doexe (diff)
downloadgentoo-2-8e4abbdfb997ef60e9b54847e18c70e7a15f7cc3.tar.gz
gentoo-2-8e4abbdfb997ef60e9b54847e18c70e7a15f7cc3.tar.bz2
gentoo-2-8e4abbdfb997ef60e9b54847e18c70e7a15f7cc3.zip
new shorten utilities
Diffstat (limited to 'media-sound/shorten/shorten-3.3.ebuild')
-rw-r--r--media-sound/shorten/shorten-3.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/shorten/shorten-3.3.ebuild b/media-sound/shorten/shorten-3.3.ebuild
new file mode 100644
index 000000000000..157bacb15704
--- /dev/null
+++ b/media-sound/shorten/shorten-3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.3.ebuild,v 1.1 2001/10/23 03:30:10 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Open source, popular and fast lossless audio compressor"
+SRC_URI="http://shnutils.etree.org/misc/${P}.tar.gz"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# mv Makefile Makefile.orig
+# sed -e "s:-O:${CFLAGS}:g" -e 's:/usr/local:/usr:g' -e 's:/man/:/share/man/:' Makefile.orig > Makefile
+}
+
+src_compile() {
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc LICENSE
+}
+