summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2006-10-07 17:15:29 +0000
committerEldad Zack <eldad@gentoo.org>2006-10-07 17:15:29 +0000
commit76ba98ee7befad7b3942c207aa2e1a009d3c51a1 (patch)
tree80da0c309f2ff75e8361ccd240cf91e0d0b007ba /media-sound/sonik
parentRegenerate digest (this time hopefully..). (diff)
downloadgentoo-2-76ba98ee7befad7b3942c207aa2e1a009d3c51a1.tar.gz
gentoo-2-76ba98ee7befad7b3942c207aa2e1a009d3c51a1.tar.bz2
gentoo-2-76ba98ee7befad7b3942c207aa2e1a009d3c51a1.zip
Version bump and ebuild cleanups. Also closes bug #145366. Removed beta version (which doesn't compile under gcc 4.1.1)
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'media-sound/sonik')
-rw-r--r--media-sound/sonik/ChangeLog9
-rw-r--r--media-sound/sonik/files/digest-sonik-1.0.03
-rw-r--r--media-sound/sonik/sonik-1.0.0.ebuild27
3 files changed, 38 insertions, 1 deletions
diff --git a/media-sound/sonik/ChangeLog b/media-sound/sonik/ChangeLog
index dffcdc2c4a9c..b672b42e6d2b 100644
--- a/media-sound/sonik/ChangeLog
+++ b/media-sound/sonik/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/sonik
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sonik/ChangeLog,v 1.2 2006/06/02 13:40:38 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sonik/ChangeLog,v 1.3 2006/10/07 17:15:29 eldad Exp $
+
+*sonik-1.0.0 (07 Oct 2006)
+
+ 07 Oct 2006; Eldad Zack <eldad@gentoo.org> -sonik-1.0_beta2.ebuild,
+ +sonik-1.0.0.ebuild:
+ Version bump and ebuild cleanups. Also closes bug #145366. Removed beta
+ version (which doesn't compile under gcc 4.1.1)
02 Jun 2006; Eldad Zack <eldad@gentoo.org> sonik-1.0_beta2.ebuild:
Removed arts useflag, better failure notice via kde.eclass. bug #134682.
diff --git a/media-sound/sonik/files/digest-sonik-1.0.0 b/media-sound/sonik/files/digest-sonik-1.0.0
new file mode 100644
index 000000000000..af8429ac11a8
--- /dev/null
+++ b/media-sound/sonik/files/digest-sonik-1.0.0
@@ -0,0 +1,3 @@
+MD5 ac20fed653a8cfb8233a7f9a6fb80a66 sonik-1.0.0.tar.gz 1770336
+RMD160 9b6d3e6bb9b60cc38829f99d8e4feedf6bd09905 sonik-1.0.0.tar.gz 1770336
+SHA256 caabf61edc4593630b55d594a87da4dd15147966eae817f06b6f51f248130d7f sonik-1.0.0.tar.gz 1770336
diff --git a/media-sound/sonik/sonik-1.0.0.ebuild b/media-sound/sonik/sonik-1.0.0.ebuild
new file mode 100644
index 000000000000..a5ed66940e26
--- /dev/null
+++ b/media-sound/sonik/sonik-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sonik/sonik-1.0.0.ebuild,v 1.1 2006/10/07 17:15:29 eldad Exp $
+
+ARTS_REQUIRED="yes"
+
+inherit kde
+
+DESCRIPTION="KDE Audio Editor"
+HOMEPAGE="http://sonik.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sonik/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ladspa"
+
+need-kde 3.3
+
+RDEPEND="media-libs/liblrdf
+ ladspa? ( media-libs/ladspa-sdk )
+ sci-libs/gsl
+ media-libs/audiofile"
+
+src_compile() {
+ myconf="$(use_enable ladspa)"
+ kde_src_compile
+}