summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-01 17:31:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-01 17:31:44 +0000
commitf382ae47bb05388d78dd18fb72cec9dbbb77a25f (patch)
tree4e2d73cab12b00c9b49507e87dcf4a3ea6639c12 /media-sound/splay
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-f382ae47bb05388d78dd18fb72cec9dbbb77a25f.tar.gz
gentoo-2-f382ae47bb05388d78dd18fb72cec9dbbb77a25f.tar.bz2
gentoo-2-f382ae47bb05388d78dd18fb72cec9dbbb77a25f.zip
Prevent collisions with media-sound/mp3blaster, bug #148293
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-sound/splay')
-rw-r--r--media-sound/splay/ChangeLog5
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild21
2 files changed, 22 insertions, 4 deletions
diff --git a/media-sound/splay/ChangeLog b/media-sound/splay/ChangeLog
index 15b3814a990e..78ae402a17e0 100644
--- a/media-sound/splay/ChangeLog
+++ b/media-sound/splay/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/splay
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.13 2007/02/22 01:25:42 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.14 2007/03/01 17:31:44 aballier Exp $
+
+ 01 Mar 2007; Alexis Ballier <aballier@gentoo.org> splay-0.9.5.2.ebuild:
+ Prevent collisions with media-sound/mp3blaster, bug #148293
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
index 5937bb57f9b1..659617563f4a 100644
--- a/media-sound/splay/splay-0.9.5.2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.15 2006/03/07 15:53:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.16 2007/03/01 17:31:44 aballier Exp $
inherit eutils
@@ -21,6 +21,11 @@ src_unpack() {
}
src_compile() {
+ # Prevent collisions with media-sound/mp3blaster
+ # bug #148293
+ mv "apps/splay.1" "apps/osplay.1" || die "moving man failed"
+ sed -i "s/splay.1/osplay.1/" apps/Makefile.in\
+ || die "sedding makefile failed"
# Force compilation to omit X support according to BUG #5856
# even when qt is present on the system.
export ac_cv_lib_qt_main=no
@@ -30,6 +35,16 @@ src_compile() {
src_install() {
# Specify man-page to prevent xsplay.1 from being installed
- einstall man_MANS=splay.1 || die "einstall failed"
+ einstall man_MANS=osplay.1 || die "einstall failed"
+ #rename splay so that it does not collide with media-sound/mp3blaster
+ # bug #148293
+ mv "${D}/usr/bin/splay" "${D}/usr/bin/osplay"\
+ || die "moving splay executable failed"
+
dodoc AUTHORS ChangeLog README README.LIB NEWS
}
+
+pkg_postinst() {
+ elog "Please note that splay has been renamed to osplay"
+ elog "in order to prevent collisions with media-sound/mp3blaster"
+}