summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-13 14:58:40 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-13 14:58:40 +0000
commit8261294beb86e2a46e8e5463b6e2be7dd5a39ee0 (patch)
treefdbad403af7a094459505ca1dc9fe8d92bbf63cb /media-sound/streamripper
parentppc stable (bug #185565) (diff)
downloadgentoo-2-8261294beb86e2a46e8e5463b6e2be7dd5a39ee0.tar.gz
gentoo-2-8261294beb86e2a46e8e5463b6e2be7dd5a39ee0.tar.bz2
gentoo-2-8261294beb86e2a46e8e5463b6e2be7dd5a39ee0.zip
Version bump.
(Portage version: 2.1.3.4)
Diffstat (limited to 'media-sound/streamripper')
-rw-r--r--media-sound/streamripper/ChangeLog9
-rw-r--r--media-sound/streamripper/files/digest-streamripper-1.62.23
-rw-r--r--media-sound/streamripper/files/streamripper-1.62.2-implicit-declarations.patch24
-rw-r--r--media-sound/streamripper/streamripper-1.62.2.ebuild37
4 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/streamripper/ChangeLog b/media-sound/streamripper/ChangeLog
index 0f0a4d9a411a..14e977942be3 100644
--- a/media-sound/streamripper/ChangeLog
+++ b/media-sound/streamripper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/streamripper
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.50 2007/07/02 14:36:25 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.51 2007/08/13 14:58:40 drac Exp $
+
+*streamripper-1.62.2 (13 Aug 2007)
+
+ 13 Aug 2007; Samuli Suominen <drac@gentoo.org>
+ +files/streamripper-1.62.2-implicit-declarations.patch,
+ +streamripper-1.62.2.ebuild:
+ Version bump.
02 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org>
streamripper-1.61.27.ebuild:
diff --git a/media-sound/streamripper/files/digest-streamripper-1.62.2 b/media-sound/streamripper/files/digest-streamripper-1.62.2
new file mode 100644
index 000000000000..b24650334476
--- /dev/null
+++ b/media-sound/streamripper/files/digest-streamripper-1.62.2
@@ -0,0 +1,3 @@
+MD5 540f922a93449ddc579b724774b3a4da streamripper-1.62.2.tar.gz 1252526
+RMD160 b3e24d48f15bccb3b54b5c51b0d047cb060c646a streamripper-1.62.2.tar.gz 1252526
+SHA256 3edc7b2ccdf85b7ebc9480d3dd63be1d4bfbb48da7f2292f2f0ac129a0253510 streamripper-1.62.2.tar.gz 1252526
diff --git a/media-sound/streamripper/files/streamripper-1.62.2-implicit-declarations.patch b/media-sound/streamripper/files/streamripper-1.62.2-implicit-declarations.patch
new file mode 100644
index 000000000000..949334e56498
--- /dev/null
+++ b/media-sound/streamripper/files/streamripper-1.62.2-implicit-declarations.patch
@@ -0,0 +1,24 @@
+diff -ur streamripper-1.62.2.orig/lib/parse.c streamripper-1.62.2/lib/parse.c
+--- streamripper-1.62.2.orig/lib/parse.c 2007-05-26 22:37:00.000000000 +0300
++++ streamripper-1.62.2/lib/parse.c 2007-08-13 17:48:52.000000000 +0300
+@@ -23,7 +23,7 @@
+ #include "mchar.h"
+ #include "debug.h"
+ #include "srtypes.h"
+-#include "regex.h"
++#include <tre/regex.h>
+
+ /* GCS FIX: figure out function prototypes for regwcomp, regwexec */
+
+diff -ur streamripper-1.62.2.orig/lib/utf8.c streamripper-1.62.2/lib/utf8.c
+--- streamripper-1.62.2.orig/lib/utf8.c 2005-12-31 18:02:54.000000000 +0200
++++ streamripper-1.62.2/lib/utf8.c 2007-08-13 17:51:29.000000000 +0300
+@@ -25,7 +25,7 @@
+ #include <string.h>
+
+ #include "utf8.h"
+-
++#include "charset.h"
+
+ #ifdef _WIN32
+
diff --git a/media-sound/streamripper/streamripper-1.62.2.ebuild b/media-sound/streamripper/streamripper-1.62.2.ebuild
new file mode 100644
index 000000000000..ededb45e9507
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.62.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.62.2.ebuild,v 1.1 2007/08/13 14:58:40 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ >=dev-libs/tre-0.7.2"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-implicit-declarations.patch
+}
+
+src_compile() {
+ econf $(use_with vorbis ogg) \
+ --without-included-libmad \
+ --without-included-tre
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc CHANGES README parse_rules.txt THANKS
+}