summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-17 21:57:15 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-17 21:57:15 +0000
commit3a62f8e77bdb6198b449ac0e81b55190f847a579 (patch)
tree67af552e174a19c0d630ec70df3cdc446423ce59 /media-sound/sweep/sweep-0.8.2-r1.ebuild
parentNew bugfix release (diff)
downloadgentoo-2-3a62f8e77bdb6198b449ac0e81b55190f847a579.tar.gz
gentoo-2-3a62f8e77bdb6198b449ac0e81b55190f847a579.tar.bz2
gentoo-2-3a62f8e77bdb6198b449ac0e81b55190f847a579.zip
Build cleanup. Changed from media-sound/mad to
media-libs/{libmad,libid3tag}
Diffstat (limited to 'media-sound/sweep/sweep-0.8.2-r1.ebuild')
-rw-r--r--media-sound/sweep/sweep-0.8.2-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/sweep/sweep-0.8.2-r1.ebuild b/media-sound/sweep/sweep-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..9e7ab8cbf878
--- /dev/null
+++ b/media-sound/sweep/sweep-0.8.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sweep/sweep-0.8.2-r1.ebuild,v 1.1 2003/07/17 21:57:15 raker Exp $
+
+IUSE="oggvorbis alsa nls"
+
+DESCRIPTION="Sweep is an audio editor and live playback tool"
+HOMEPAGE="http://www.metadecks.org/software/sweep/"
+SRC_URI="http://www.metadecks.org/software/sweep/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~mips ~alpha"
+
+DEPEND=">=media-libs/libsndfile-1.0*
+ >=x11-libs/gtk+-1.2*
+ dev-libs/tdb
+ media-libs/libsamplerate
+ media-libs/libmad
+ media-libs/libid3tag
+ media-libs/speex
+ oggvorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ # --enable-experimental Add to myconf if you want this stuff
+
+ use oggvorbis || myconf="${myconf} --disable-oggvorbis"
+ use alsa && myconf="${myconf} --enable-alsa"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf}
+ emake
+}
+
+src_install() {
+ einstall
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Sweep can use ladspa plugins,"
+ einfo "emerge ladspa-sdk and ladspa-cmt if you want them."
+ einfo ""
+}