summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 14:50:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 14:50:42 +0000
commit924556428e6b8ec878136f0c9e7b23e85bc27225 (patch)
tree873c9f72b6f1d1aed0c93b9cd0b81c3f7482826e /media-sound/tap-reverbed/tap-reverbed-0.ebuild
parentTook maintainership and did minor ebuild cleanup (diff)
downloadgentoo-2-924556428e6b8ec878136f0c9e7b23e85bc27225.tar.gz
gentoo-2-924556428e6b8ec878136f0c9e7b23e85bc27225.tar.bz2
gentoo-2-924556428e6b8ec878136f0c9e7b23e85bc27225.zip
Fix build with forced as-needed, bug #247863, respect CFLAGS/LDFLAGS, dont build pic for a binary, handle to proaudio herd.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/tap-reverbed/tap-reverbed-0.ebuild')
-rw-r--r--media-sound/tap-reverbed/tap-reverbed-0.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/media-sound/tap-reverbed/tap-reverbed-0.ebuild b/media-sound/tap-reverbed/tap-reverbed-0.ebuild
index 99c8bd55a300..db4c01dc4e2e 100644
--- a/media-sound/tap-reverbed/tap-reverbed-0.ebuild
+++ b/media-sound/tap-reverbed/tap-reverbed-0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tap-reverbed/tap-reverbed-0.ebuild,v 1.5 2007/01/05 20:07:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tap-reverbed/tap-reverbed-0.ebuild,v 1.6 2008/12/19 14:50:42 aballier Exp $
-IUSE=""
+
+inherit autotools eutils
MY_P="${PN}-r0"
DESCRIPTION="Standalone JACK counterpart of LADSPA plugin TAP Reverberator."
@@ -13,6 +14,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
RDEPEND="media-libs/ladspa-sdk
media-plugins/tap-plugins
@@ -21,12 +23,19 @@ RDEPEND="media-libs/ladspa-sdk
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-flags.patch"
+ eautoreconf
+}
+
src_install() {
einstall
dodoc README AUTHORS
insinto /usr/share/tap-reverbed
- insopts -m0666
+ insopts -m0644
doins src/\.reverbed
}