summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-10 14:23:51 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-10 14:23:51 +0000
commit82813581fbbb282ee47360ffd19c82e3b480bb16 (patch)
tree6c9a1f57c8f077680ffa51f695dc36d9e78abbc8 /media-sound/tapiir
parentStable for HPPA (bug #531408). (diff)
downloadgentoo-2-82813581fbbb282ee47360ffd19c82e3b480bb16.tar.gz
gentoo-2-82813581fbbb282ee47360ffd19c82e3b480bb16.tar.bz2
gentoo-2-82813581fbbb282ee47360ffd19c82e3b480bb16.zip
Version bump. Fix FLTK version check (bug #366193).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'media-sound/tapiir')
-rw-r--r--media-sound/tapiir/ChangeLog10
-rw-r--r--media-sound/tapiir/files/tapiir-0.7.3-acinclude.m4173
-rw-r--r--media-sound/tapiir/tapiir-0.7.3.ebuild42
3 files changed, 223 insertions, 2 deletions
diff --git a/media-sound/tapiir/ChangeLog b/media-sound/tapiir/ChangeLog
index 3c7e83e01593..c8d0b941239b 100644
--- a/media-sound/tapiir/ChangeLog
+++ b/media-sound/tapiir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/tapiir
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tapiir/ChangeLog,v 1.21 2011/03/20 20:06:58 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapiir/ChangeLog,v 1.22 2014/12/10 14:23:51 jer Exp $
+
+*tapiir-0.7.3 (10 Dec 2014)
+
+ 10 Dec 2014; Jeroen Roovers <jer@gentoo.org> +tapiir-0.7.3.ebuild,
+ +files/tapiir-0.7.3-acinclude.m4:
+ Version bump. Fix FLTK version check (bug #366193).
20 Mar 2011; Justin Lecher <jlec@gentoo.org> tapiir-0.7.2.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
diff --git a/media-sound/tapiir/files/tapiir-0.7.3-acinclude.m4 b/media-sound/tapiir/files/tapiir-0.7.3-acinclude.m4
new file mode 100644
index 000000000000..51f42ec4097e
--- /dev/null
+++ b/media-sound/tapiir/files/tapiir-0.7.3-acinclude.m4
@@ -0,0 +1,173 @@
+AC_DEFUN([AM_PATH_ALSA],
+[dnl Save the original CFLAGS, LDFLAGS, and LIBS
+alsa_save_CFLAGS="$CFLAGS"
+alsa_save_LDFLAGS="$LDFLAGS"
+alsa_save_LIBS="$LIBS"
+alsa_found=yes
+
+dnl
+dnl Get the cflags and libraries for alsa
+dnl
+AC_ARG_WITH(alsa-prefix,
+[ --with-alsa-prefix=PFX Prefix where Alsa library is installed(optional)],
+[alsa_prefix="$withval"], [alsa_prefix=""])
+
+AC_ARG_WITH(alsa-inc-prefix,
+[ --with-alsa-inc-prefix=PFX Prefix where include libraries are (optional)],
+[alsa_inc_prefix="$withval"], [alsa_inc_prefix=""])
+
+dnl FIXME: this is not yet implemented
+AC_ARG_ENABLE(alsatest,
+[ --disable-alsatest Do not try to compile and run a test Alsa program],
+[enable_alsatest="$enableval"],
+[enable_alsatest=yes])
+
+dnl Add any special include directories
+AC_MSG_CHECKING(for ALSA CFLAGS)
+if test "$alsa_inc_prefix" != "" ; then
+ ALSA_CFLAGS="$ALSA_CFLAGS -I$alsa_inc_prefix"
+ CFLAGS="$CFLAGS -I$alsa_inc_prefix"
+fi
+AC_MSG_RESULT($ALSA_CFLAGS)
+
+dnl add any special lib dirs
+AC_MSG_CHECKING(for ALSA LDFLAGS)
+if test "$alsa_prefix" != "" ; then
+ ALSA_LIBS="$ALSA_LIBS -L$alsa_prefix"
+ LDFLAGS="$LDFLAGS $ALSA_LIBS"
+fi
+
+dnl add the alsa library
+ALSA_LIBS="$ALSA_LIBS -lasound -lm -ldl -lpthread"
+LIBS="$ALSA_LIBS $LIBS"
+AC_MSG_RESULT($ALSA_LIBS)
+
+dnl Check for a working version of libasound that is of the right version.
+min_alsa_version=ifelse([$1], ,0.1.1,$1)
+AC_MSG_CHECKING(for libasound headers version >= $min_alsa_version)
+no_alsa=""
+ alsa_min_major_version=`echo $min_alsa_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ alsa_min_minor_version=`echo $min_alsa_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ alsa_min_micro_version=`echo $min_alsa_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+
+AC_LANG_SAVE
+AC_LANG_C
+AC_TRY_COMPILE([
+#include <alsa/asoundlib.h>
+], [
+/* ensure backward compatibility */
+#if !defined(SND_LIB_MAJOR) && defined(SOUNDLIB_VERSION_MAJOR)
+#define SND_LIB_MAJOR SOUNDLIB_VERSION_MAJOR
+#endif
+#if !defined(SND_LIB_MINOR) && defined(SOUNDLIB_VERSION_MINOR)
+#define SND_LIB_MINOR SOUNDLIB_VERSION_MINOR
+#endif
+#if !defined(SND_LIB_SUBMINOR) && defined(SOUNDLIB_VERSION_SUBMINOR)
+#define SND_LIB_SUBMINOR SOUNDLIB_VERSION_SUBMINOR
+#endif
+
+# if(SND_LIB_MAJOR > $alsa_min_major_version)
+ exit(0);
+# else
+# if(SND_LIB_MAJOR < $alsa_min_major_version)
+# error not present
+# endif
+
+# if(SND_LIB_MINOR > $alsa_min_minor_version)
+ exit(0);
+# else
+# if(SND_LIB_MINOR < $alsa_min_minor_version)
+# error not present
+# endif
+
+# if(SND_LIB_SUBMINOR < $alsa_min_micro_version)
+# error not present
+# endif
+# endif
+# endif
+exit(0);
+],
+ [AC_MSG_RESULT(found.)],
+ [AC_MSG_RESULT(not present.)
+ ifelse([$3], , [AC_MSG_ERROR(Sufficiently new version of libasound not found.)])
+ alsa_found=no]
+)
+AC_LANG_RESTORE
+
+dnl Now that we know that we have the right version, let's see if we have the library and not just the headers.
+if test "x$enable_alsatest" = "xyes"; then
+AC_CHECK_LIB([asound], [snd_ctl_open],,
+ [ifelse([$3], , [AC_MSG_ERROR(No linkable libasound was found.)])
+ alsa_found=no]
+)
+fi
+
+if test "x$alsa_found" = "xyes" ; then
+ ifelse([$2], , :, [$2])
+ LIBS=`echo $LIBS | sed 's/-lasound//g'`
+ LIBS=`echo $LIBS | sed 's/ //'`
+ LIBS="-lasound $LIBS"
+fi
+if test "x$alsa_found" = "xno" ; then
+ ifelse([$3], , :, [$3])
+ CFLAGS="$alsa_save_CFLAGS"
+ LDFLAGS="$alsa_save_LDFLAGS"
+ LIBS="$alsa_save_LIBS"
+ ALSA_CFLAGS=""
+ ALSA_LIBS=""
+fi
+
+dnl That should be it. Now just export out symbols:
+AC_SUBST(ALSA_CFLAGS)
+AC_SUBST(ALSA_LIBS)
+])
+
+
+AC_DEFUN(AM_PATH_FLTK,
+[
+AC_MSG_CHECKING(fltk version)
+
+min_fltk_version=ifelse([$1], ,1.1.0,$1)
+cur_fltk_version=`fltk-config --version`
+
+fltk_min_major_version=`echo $min_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+fltk_min_minor_version=`echo $min_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+fltk_min_patch_version=`echo $min_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+
+
+fltk_cur_major_version=`echo $cur_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+fltk_cur_minor_version=`echo $cur_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+fltk_cur_patch_version=`echo $cur_fltk_version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+
+fltk_version_ok=no
+
+if test x"$fltk_cur_major_version" != x -a x"$fltk_cur_minor_version" != x -a x"$fltk_cur_patch_version" != x; then
+ if test $fltk_cur_major_version -eq $fltk_min_major_version; then
+ if test $fltk_cur_minor_version -ge $fltk_min_minor_version; then
+ if test $fltk_cur_patch_version -ge $fltk_min_patch_version; then
+ fltk_version_ok=yes
+ fi
+ fi
+ fi
+fi
+
+if test $fltk_version_ok == yes; then
+ AC_MSG_RESULT([ok])
+else
+ AC_MSG_FAILURE([not ok])
+fi
+
+CXXFLAGS=`fltk-config --cxxflags`
+LDFLAGS=`fltk-config --ldflags`
+])
+
+
diff --git a/media-sound/tapiir/tapiir-0.7.3.ebuild b/media-sound/tapiir/tapiir-0.7.3.ebuild
new file mode 100644
index 000000000000..e9673251d7db
--- /dev/null
+++ b/media-sound/tapiir/tapiir-0.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapiir/tapiir-0.7.3.ebuild,v 1.1 2014/12/10 14:23:51 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a flexible audio effects processor, inspired on the classical magnetic tape delay systems"
+HOMEPAGE="http://www.resorama.com/maarten/tapiir/"
+SRC_URI="http://www.resorama.com/maarten/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ media-sound/jack-audio-connection-kit
+ media-libs/alsa-lib
+ x11-libs/fltk:1
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.2-ldflags.patch
+
+ cp "${FILESDIR}"/${P}-acinclude.m4 acinclude.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-dependency-tracking
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ dodoc AUTHORS doc/${PN}.txt
+ dohtml doc/*.html doc/images/*.png
+ insinto /usr/share/${PN}/examples
+ doins doc/examples/*.mtd
+}