summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-22 07:41:48 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-22 07:41:48 +0000
commit1c739944019ac71054c1726993026a47daa0cf96 (patch)
tree9021849548bda5920ec0ec7bdedefc26b687061d /media-sound/vorbisgain
parentold (diff)
downloadgentoo-2-1c739944019ac71054c1726993026a47daa0cf96.tar.gz
gentoo-2-1c739944019ac71054c1726993026a47daa0cf96.tar.bz2
gentoo-2-1c739944019ac71054c1726993026a47daa0cf96.zip
Marked 0.37 stable for amd64 and created 0.37-r1 for bug 200931, fixing improper use of errno and mktemp, thanks to Marc Finet.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/vorbisgain')
-rw-r--r--media-sound/vorbisgain/ChangeLog12
-rw-r--r--media-sound/vorbisgain/files/vorbisgain-0.37-fix-errno-and-warnings.patch80
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild34
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37.ebuild6
4 files changed, 127 insertions, 5 deletions
diff --git a/media-sound/vorbisgain/ChangeLog b/media-sound/vorbisgain/ChangeLog
index 79717990a41c..bbd79bcf6a1b 100644
--- a/media-sound/vorbisgain/ChangeLog
+++ b/media-sound/vorbisgain/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/vorbisgain
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/ChangeLog,v 1.22 2007/11/23 13:02:22 drac Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/ChangeLog,v 1.23 2008/03/22 07:41:48 drac Exp $
+
+*vorbisgain-0.37-r1 (22 Mar 2008)
+
+ 22 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/vorbisgain-0.37-fix-errno-and-warnings.patch,
+ vorbisgain-0.37.ebuild, +vorbisgain-0.37-r1.ebuild:
+ Marked 0.37 stable for amd64 and created 0.37-r1 for bug 200931, fixing
+ improper use of errno and mktemp, thanks to Marc Finet.
*vorbisgain-0.37 (23 Nov 2007)
diff --git a/media-sound/vorbisgain/files/vorbisgain-0.37-fix-errno-and-warnings.patch b/media-sound/vorbisgain/files/vorbisgain-0.37-fix-errno-and-warnings.patch
new file mode 100644
index 000000000000..7d2efb63f33c
--- /dev/null
+++ b/media-sound/vorbisgain/files/vorbisgain-0.37-fix-errno-and-warnings.patch
@@ -0,0 +1,80 @@
+diff -ur vorbisgain-0.37.orig/misc.c vorbisgain-0.37/misc.c
+--- vorbisgain-0.37.orig/misc.c 2004-01-03 23:17:28.000000000 +0200
++++ vorbisgain-0.37/misc.c 2008-03-22 09:32:49.000000000 +0200
+@@ -23,6 +23,7 @@
+ #else /* WIN32 */
+ #include <errno.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ #ifndef DISABLE_WINSIZE
+
+diff -ur vorbisgain-0.37.orig/recurse.c vorbisgain-0.37/recurse.c
+--- vorbisgain-0.37.orig/recurse.c 2004-01-02 14:49:38.000000000 +0200
++++ vorbisgain-0.37/recurse.c 2008-03-22 09:31:52.000000000 +0200
+@@ -377,6 +377,7 @@
+
+ if (result->dir != NULL)
+ {
++ errno = 0;
+ result->entry = readdir(result->dir);
+
+ if (result->entry != NULL)
+@@ -408,6 +409,7 @@
+ */
+ static int read_dir(DIRECTORY *directory)
+ {
++ errno = 0;
+ directory->entry = readdir(directory->dir);
+
+ if (directory->entry != NULL)
+diff -ur vorbisgain-0.37.orig/vorbis.c vorbisgain-0.37/vorbis.c
+--- vorbisgain-0.37.orig/vorbis.c 2005-07-15 01:49:05.000000000 +0300
++++ vorbisgain-0.37/vorbis.c 2008-03-22 09:32:25.000000000 +0200
+@@ -572,6 +572,9 @@
+ int result = -1;
+ int delete_temp = 0;
+ int i;
++#if _BSD_SOURCE || _SVID_SOURCE || _XOPEN_SOURCE >= 500
++ int fd;
++#endif
+
+ infile = fopen(filename, "rb");
+
+@@ -699,6 +702,16 @@
+ strcpy(temp_name, filename);
+ strcpy((char *) last_path(temp_name), TEMP_NAME);
+
++#if _BSD_SOURCE || _SVID_SOURCE || _XOPEN_SOURCE >= 500
++ fd = mkstemp(temp_name);
++ if (fd == -1)
++ {
++ fprintf(stderr, _("Couldn't create temporary file for processing.\n"));
++ goto exit;
++ }
++
++ outfile = fdopen(fd, "wb");
++#else /* #if _BSD_SOURCE || _SVID_SOURCE || _XOPEN_SOURCE >= 500 */
+ #ifdef WIN32
+ temp_name = _mktemp(temp_name);
+ #else
+@@ -712,6 +725,7 @@
+ }
+
+ outfile = fopen(temp_name, "wb");
++#endif /* #if _BSD_SOURCE || _SVID_SOURCE || _XOPEN_SOURCE >= 500 */
+
+ if (outfile == NULL)
+ {
+@@ -824,7 +838,10 @@
+ }
+ }
+
+- free(temp_name);
++ if (temp_name != NULL)
++ {
++ free(temp_name);
++ }
+
+ return result;
+ }
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
new file mode 100644
index 000000000000..4e3cc92a2762
--- /dev/null
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild,v 1.1 2008/03/22 07:41:48 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
+HOMEPAGE="http://sjeng.org/vorbisgain.html"
+SRC_URI="http://sjeng.org/ftp/vorbis/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libvorbis-1
+ media-libs/libogg"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-errno-and-warnings.patch # bug 200931
+}
+
+src_compile() {
+ econf --enable-recursive
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc NEWS README *.txt
+}
diff --git a/media-sound/vorbisgain/vorbisgain-0.37.ebuild b/media-sound/vorbisgain/vorbisgain-0.37.ebuild
index a113534c5de9..c37e7dfc93ea 100644
--- a/media-sound/vorbisgain/vorbisgain-0.37.ebuild
+++ b/media-sound/vorbisgain/vorbisgain-0.37.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/vorbisgain-0.37.ebuild,v 1.1 2007/11/23 13:02:22 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/vorbisgain-0.37.ebuild,v 1.2 2008/03/22 07:41:48 drac Exp $
DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
HOMEPAGE="http://sjeng.org/vorbisgain.html"
@@ -8,7 +8,7 @@ SRC_URI="http://sjeng.org/ftp/vorbis/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
RDEPEND=">=media-libs/libvorbis-1