summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-10-23 22:02:33 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-10-23 22:02:33 +0000
commitafcac229b7ceb7ba1b89260155b7842089f08695 (patch)
treeff843b24e0298f92373af0c1aa24942dc586090e /media-sound/yammi
parentnew release (diff)
downloadgentoo-2-afcac229b7ceb7ba1b89260155b7842089f08695.tar.gz
gentoo-2-afcac229b7ceb7ba1b89260155b7842089f08695.tar.bz2
gentoo-2-afcac229b7ceb7ba1b89260155b7842089f08695.zip
Added patch to enable yammi to compile on machines without KDE.
Diffstat (limited to 'media-sound/yammi')
-rw-r--r--media-sound/yammi/ChangeLog7
-rw-r--r--media-sound/yammi/files/yammi-0.8.2-qt.patch64
-rw-r--r--media-sound/yammi/yammi-0.8.2.ebuild5
3 files changed, 73 insertions, 3 deletions
diff --git a/media-sound/yammi/ChangeLog b/media-sound/yammi/ChangeLog
index 7508e030b34f..2dd121257e00 100644
--- a/media-sound/yammi/ChangeLog
+++ b/media-sound/yammi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/yammi
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/yammi/ChangeLog,v 1.5 2003/07/31 03:30:50 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yammi/ChangeLog,v 1.6 2003/10/23 22:02:33 brandy Exp $
+
+ 24 Oct 2003; brandy <brandy@gentoo.org> yammi-0.8.2.ebuild,
+ files/yammi-0.8.2-qt.patch:
+ Added patch to enable yammi to compile on machines without KDE. Closes bug
+ #30366
30 Jul 2003; <caleb@gentoo.org> yammi-0.8.2.ebuild:
Fix dependency from kde-base/kde to kde-base/kdebase. The first is a meta
diff --git a/media-sound/yammi/files/yammi-0.8.2-qt.patch b/media-sound/yammi/files/yammi-0.8.2-qt.patch
new file mode 100644
index 000000000000..c03056ce4901
--- /dev/null
+++ b/media-sound/yammi/files/yammi-0.8.2-qt.patch
@@ -0,0 +1,64 @@
+diff -ur yammi-0.8.2/configure yammi-0.8.2-gentoo/configure
+--- yammi-0.8.2/configure 2003-05-16 04:14:30.000000000 +1200
++++ yammi-0.8.2-gentoo/configure 2003-10-05 19:22:33.000000000 +1300
+@@ -1718,7 +1718,7 @@
+ id3lib support .......: $configure_enable_id3lib
+ " >&6;}
+
+-if test "x$configure_enable_KDE" = "xyes"; then
++#if test "x$configure_enable_KDE" = "xyes"; then
+
+ unset CDPATH
+
+@@ -1807,7 +1807,7 @@
+ kde_qt_dirs="$QTDIR /usr/lib/qt"
+ fi
+
+-fi
++#fi
+
+ ac_config_commands="$ac_config_commands default-1"
+
+@@ -15248,9 +15248,9 @@
+ # AC_SUBST(all_includes)
+ # AC_SUBST(all_libraries)
+
+-if test "x$configure_enable_KDE" = "xyes"; then
+- { echo "$as_me:15252: Adding KDE support " >&5
+-echo "$as_me: Adding KDE support " >&6;}
++#if test "x$configure_enable_KDE" = "xyes"; then
++# { echo "$as_me:15252: Adding KDE support " >&5
++#echo "$as_me: Adding KDE support " >&6;}
+
+ # Extract the first word of "msgfmt", so it can be a program name with args.
+ set dummy msgfmt; ac_word=$2
+@@ -15379,9 +15379,9 @@
+ fi
+ fi
+
+-fi
++#fi
+
+-if test "x$configure_enable_KDE" = "xyes"; then
++#if test "x$configure_enable_KDE" = "xyes"; then
+ echo "$as_me:15385: checking for ANSI C header files" >&5
+ echo $ECHO_N "checking for ANSI C header files... $ECHO_C" >&6
+ if test "${ac_cv_header_stdc+set}" = set; then
+@@ -21157,7 +21157,7 @@
+
+ fi
+
+-else
++elif test "x$configure_enable_KDE" = "xyes"; then
+
+ # Check whether --enable-mt or --disable-mt was given.
+ if test "${enable_mt+set}" = set; then
+@@ -21987,7 +21987,7 @@
+ fi
+ test -z "$KDE_MT_LIBS" || LIB_QT="$LIB_QT $KDE_MT_LIBS"
+
+-fi
++#fi
+
+ if test "x$configure_enable_KDE" = "xyes"; then
+
diff --git a/media-sound/yammi/yammi-0.8.2.ebuild b/media-sound/yammi/yammi-0.8.2.ebuild
index 8a13172650b7..82b985990277 100644
--- a/media-sound/yammi/yammi-0.8.2.ebuild
+++ b/media-sound/yammi/yammi-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/yammi/yammi-0.8.2.ebuild,v 1.6 2003/09/07 00:06:06 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yammi/yammi-0.8.2.ebuild,v 1.7 2003/10/23 22:02:33 brandy Exp $
inherit flag-o-matic
@@ -28,6 +28,7 @@ DEPEND=">=x11-libs/qt-3.1.0-r1
src_unpack() {
unpack ${P}fixed.tar.gz
+ epatch ${FILESDIR}/${P}-qt.patch
}
src_compile() {
@@ -39,7 +40,7 @@ src_compile() {
local myconf
use xmms || myconf="--disable-xmms"
- use kde || myconf="--disable-noatun ${myconf}"
+ use kde || myconf="--disable-KDE --disable-noatun ${myconf}"
if [ -z "`use xmms`" ] && [ -z "`use kde`" ]
then