summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-30 08:14:15 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-30 08:14:15 +0000
commit545f49c6213b01f2f2ae8fb0028d6348d4cac165 (patch)
treef99a572278a4c8a3be6bb6fa8066b0916fc10a90 /media-sound/yoshimi
parentVersion bump (bug #378445). (diff)
downloadgentoo-2-545f49c6213b01f2f2ae8fb0028d6348d4cac165.tar.gz
gentoo-2-545f49c6213b01f2f2ae8fb0028d6348d4cac165.tar.bz2
gentoo-2-545f49c6213b01f2f2ae8fb0028d6348d4cac165.zip
Version bump (bug #363623).
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/yoshimi')
-rw-r--r--media-sound/yoshimi/ChangeLog8
-rw-r--r--media-sound/yoshimi/files/yoshimi-0.060.10-fltk13.patch46
-rw-r--r--media-sound/yoshimi/yoshimi-0.060.10.ebuild39
3 files changed, 92 insertions, 1 deletions
diff --git a/media-sound/yoshimi/ChangeLog b/media-sound/yoshimi/ChangeLog
index bbbc1b71e3ad..e082fadb7b90 100644
--- a/media-sound/yoshimi/ChangeLog
+++ b/media-sound/yoshimi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/yoshimi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/yoshimi/ChangeLog,v 1.4 2011/03/20 20:06:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yoshimi/ChangeLog,v 1.5 2011/09/30 08:14:15 radhermit Exp $
+
+*yoshimi-0.060.10 (30 Sep 2011)
+
+ 30 Sep 2011; Tim Harder <radhermit@gentoo.org> +yoshimi-0.060.10.ebuild,
+ +files/yoshimi-0.060.10-fltk13.patch:
+ Version bump (bug #363623).
20 Mar 2011; Justin Lecher <jlec@gentoo.org> yoshimi-0.056.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
diff --git a/media-sound/yoshimi/files/yoshimi-0.060.10-fltk13.patch b/media-sound/yoshimi/files/yoshimi-0.060.10-fltk13.patch
new file mode 100644
index 000000000000..1b418844214f
--- /dev/null
+++ b/media-sound/yoshimi/files/yoshimi-0.060.10-fltk13.patch
@@ -0,0 +1,46 @@
+--- yoshimi-0.060.10.orig/src/UI/BankUI.fl
++++ yoshimi-0.060.10/src/UI/BankUI.fl
+@@ -51,7 +51,7 @@
+ class BankProcess_ {open
+ } {
+ Function {process(void)} {open return_type {virtual void}
+- } {}
++ } {code{;}}
+ decl {Bank *bank;} {public
+ }
+ }
+--- yoshimi-0.060.10.orig/src/UI/OscilGenUI.fl
++++ yoshimi-0.060.10/src/UI/OscilGenUI.fl
+@@ -166,7 +166,7 @@
+
+ class PSlider {open : {public Fl_Slider}
+ } {
+- Function {PSlider(int x,int y, int w, int h, const char *label=0):Fl_Slider(x,y,w,h,label)} {} {}
++ Function {PSlider(int x,int y, int w, int h, const char *label=0):Fl_Slider(x,y,w,h,label)} {} {code{;}}
+ Function {handle(int event)} {return_type int
+ } {
+ code {int X=x(),Y=y(),W=w(),H=h();
+--- yoshimi-0.060.10.orig/src/UI/PartUI.fl
++++ yoshimi-0.060.10/src/UI/PartUI.fl
+@@ -89,7 +89,7 @@
+ class PartUI_ {open
+ } {
+ Function {showparameters(int kititem,int engine)} {open return_type virtual
+- } {}
++ } {code{;}}
+ }
+
+ class PartKitItem {: {public Fl_Group}
+--- yoshimi-0.060.10.orig/src/UI/PresetsUI.fl
++++ yoshimi-0.060.10/src/UI/PresetsUI.fl
+@@ -44,8 +44,8 @@
+
+ class PresetsUI_ {} {
+ Function {refresh()} {return_type {virtual void}
+- } {}
+- Function {~PresetsUI_()} {} {}
++ } {code{;}}
++ Function {~PresetsUI_()} {} {code{;}}
+ }
+
+ class PresetsUI {} {
diff --git a/media-sound/yoshimi/yoshimi-0.060.10.ebuild b/media-sound/yoshimi/yoshimi-0.060.10.ebuild
new file mode 100644
index 000000000000..14777de3c9c9
--- /dev/null
+++ b/media-sound/yoshimi/yoshimi-0.060.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yoshimi/yoshimi-0.060.10.ebuild,v 1.1 2011/09/30 08:14:15 radhermit Exp $
+
+EAPI=4
+inherit cmake-utils eutils
+
+DESCRIPTION="A software synthesizer based on ZynAddSubFX"
+HOMEPAGE="http://yoshimi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib
+ media-libs/fontconfig
+ x11-libs/fltk:1
+ sci-libs/fftw:3.0
+ >=dev-libs/mini-xml-2.5
+ >=media-libs/alsa-lib-1.0.17
+ >=media-sound/jack-audio-connection-kit-0.115.6
+ media-libs/libsndfile"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P}/src
+
+DOCS="../0.060.10.notes"
+
+src_prepare() {
+ sed -i \
+ -e '/set (CMAKE_CXX_FLAGS_RELEASE/d' \
+ CMakeLists.txt || die
+
+ epatch "${FILESDIR}"/${P}-fltk13.patch
+}