summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-12 23:38:52 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-12 23:38:52 +0000
commit05f2efa0e07bd09a91d7b6a8d2da833cea23a23a (patch)
tree169ff5c49832f4a94a6218b2e0ab0ceccec8d5cc /media-sound
parentVersion bump (diff)
downloadgentoo-2-05f2efa0e07bd09a91d7b6a8d2da833cea23a23a.tar.gz
gentoo-2-05f2efa0e07bd09a91d7b6a8d2da833cea23a23a.tar.bz2
gentoo-2-05f2efa0e07bd09a91d7b6a8d2da833cea23a23a.zip
die if no audio outputs were enabled, bug 254731
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc1 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/ChangeLog5
-rw-r--r--media-sound/mpd/mpd-0.14.ebuild20
2 files changed, 21 insertions, 4 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index 3660b00efa03..79dce8a4923a 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/mpd
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.148 2009/01/12 21:08:22 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.149 2009/01/12 23:38:52 angelos Exp $
+
+ 12 Jan 2009; Christoph Mende <angelos@gentoo.org> mpd-0.14.ebuild:
+ die if no audio outputs were enabled, bug 254731
12 Jan 2009; Christoph Mende <angelos@gentoo.org> mpd-0.14.ebuild:
Add use_enable for lame, bug 254545
diff --git a/media-sound/mpd/mpd-0.14.ebuild b/media-sound/mpd/mpd-0.14.ebuild
index c524f6d82fb9..97b615fef623 100644
--- a/media-sound/mpd/mpd-0.14.ebuild
+++ b/media-sound/mpd/mpd-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.14.ebuild,v 1.4 2009/01/12 21:08:22 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.14.ebuild,v 1.5 2009/01/12 23:38:52 angelos Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="aac alsa ao audiofile curl debug doc ffmpeg flac icecast id3 ipv6 jack lame libsamplerate mad mikmod musepack ogg oss pulseaudio +sysvipc unicode vorbis wavpack zeroconf"
+IUSE="aac +alsa ao audiofile curl debug doc ffmpeg flac icecast id3 ipv6 jack lame libsamplerate mad mikmod musepack ogg oss pulseaudio +sysvipc unicode vorbis wavpack zeroconf"
RDEPEND="!sys-cluster/mpich2
>=dev-libs/glib-2.4:2
@@ -48,7 +48,7 @@ pkg_setup() {
ewarn "USE=icecast enabled but lame and vorbis disabled,"
ewarn "disabling icecast"
fi
-
+
enewuser mpd "" "" "/var/lib/mpd" audio
}
@@ -60,6 +60,20 @@ src_prepare() {
src_configure() {
local myconf=""
+
+ if ! use alsa && ! use ao && ! use icecast && ! use jack && ! use oss && \
+ ! use pulseaudio; then
+ eerror "You did not enable any output backend."
+ einfo "Please enable one of the following USE flags:"
+ einfo "USE=alsa - output via ALSA"
+ einfo "USE=ao - output via media-libs/libao"
+ einfo "USE=icecast - output via net-misc/icecast"
+ einfo "USE=jack - output via media-sound/jack-audio-connection-kit"
+ einfo "USE=oss - output via OSS"
+ einfo "USE=pulseaudio - output via media-sound/pulseaudio"
+ die "No audio output enabled"
+ fi
+
if use icecast; then
myconf+=" $(use_enable vorbis shout_ogg) $(use_enable lame shout_mp3)
$(use_enable lame lametest) $(use_enable lame)"