summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-17 09:07:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-17 09:07:29 +0000
commit3b22351c80155f9bbf7d45d8c3443c7935719118 (patch)
tree833caf4f20c4b7676e4dc43a540c042681799d63 /media-sound
parentRemove backwards compatibility code. (diff)
downloadgentoo-2-3b22351c80155f9bbf7d45d8c3443c7935719118.tar.gz
gentoo-2-3b22351c80155f9bbf7d45d8c3443c7935719118.tar.bz2
gentoo-2-3b22351c80155f9bbf7d45d8c3443c7935719118.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/listen/ChangeLog12
-rw-r--r--media-sound/listen/files/listen-0.6.2-Makefile.patch37
-rw-r--r--media-sound/listen/files/listen_dbusfix.patch49
-rw-r--r--media-sound/listen/listen-0.5-r1.ebuild107
-rw-r--r--media-sound/listen/listen-0.6.2.ebuild59
5 files changed, 105 insertions, 159 deletions
diff --git a/media-sound/listen/ChangeLog b/media-sound/listen/ChangeLog
index 8bc5eb981b6f..da5c3cbee1a0 100644
--- a/media-sound/listen/ChangeLog
+++ b/media-sound/listen/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for media-sound/listen
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.19 2007/08/11 10:34:15 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.20 2009/07/17 09:07:25 ssuominen Exp $
- 11 Aug 2007; Samuli Suominen <drac@gentoo.org> listen-0.5-r1.ebuild:
+*listen-0.6.2 (17 Jul 2009)
+
+ 17 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> +listen-0.6.2.ebuild,
+ +files/listen-0.6.2-Makefile.patch:
+ Version bump.
+
+ 11 Aug 2007; Samuli Suominen <ssuominen@gentoo.org> listen-0.5-r1.ebuild:
Fix elementtree depends for bug 185533.
16 Jul 2007; Michael Sterrett <mr_bones_@gentoo.org> listen-0.5.ebuild,
diff --git a/media-sound/listen/files/listen-0.6.2-Makefile.patch b/media-sound/listen/files/listen-0.6.2-Makefile.patch
new file mode 100644
index 000000000000..378c5bf7c3be
--- /dev/null
+++ b/media-sound/listen/files/listen-0.6.2-Makefile.patch
@@ -0,0 +1,37 @@
+diff -ur listen-0.6.2.orig/Makefile listen-0.6.2/Makefile
+--- listen-0.6.2.orig/Makefile 2009-05-11 19:37:47.000000000 +0300
++++ listen-0.6.2/Makefile 2009-07-17 11:55:48.000000000 +0300
+@@ -49,10 +49,8 @@
+ echo 'Name=org.gnome.Listen' >> org.gnome.Listen.service
+ echo 'Exec=$(BINDIR)/listen' >> org.gnome.Listen.service
+
+- docbook2x-man misc/listen.1.docbook --to-stdout | gzip > listen.1.gz
++ docbook2man.pl misc/listen.1.docbook
+
+- python -m compileall src
+- python -O -m compileall src
+ @echo "Done"
+ @echo "Type: make install now"
+
+@@ -103,12 +101,8 @@
+
+ install: make-install-dirs
+ install -m 644 src/*.py $(DESTDIR)$(LIBDIR)/listen
+- install -m 644 src/*.pyc $(DESTDIR)$(LIBDIR)/listen
+- install -m 644 src/*.pyo $(DESTDIR)$(LIBDIR)/listen
+ for dir in $(PYSRC_DIR); do \
+ install -m 644 src/$${dir}/*.py $(DESTDIR)$(LIBDIR)/listen/$${dir} ; \
+- install -m 644 src/$${dir}/*.pyc $(DESTDIR)$(LIBDIR)/listen/$${dir} ; \
+- install -m 644 src/$${dir}/*.pyo $(DESTDIR)$(LIBDIR)/listen/$${dir} ; \
+ done
+
+ install -m 644 src/mmkeys.so $(DESTDIR)$(LIBDIR)/listen/
+@@ -120,7 +114,7 @@
+ install -m 644 data/img/listen.png $(DESTDIR)$(DATADIR)/pixmaps/
+
+ install -m 644 listen.desktop $(DESTDIR)$(DATADIR)/applications/
+- install -m 644 listen.1.gz $(DESTDIR)$(MANDIR)/man1/
++ install -m 644 listen.1 $(DESTDIR)$(MANDIR)/man1/
+ install -m 644 org.gnome.Listen.service $(DESTDIR)$(DBUSDIR)/services
+
+ for lang in $(PO); do install -m 644 po/$$lang.mo $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/listen.mo; done
diff --git a/media-sound/listen/files/listen_dbusfix.patch b/media-sound/listen/files/listen_dbusfix.patch
deleted file mode 100644
index 5953352f1dfb..000000000000
--- a/media-sound/listen/files/listen_dbusfix.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: src/dbus_manager.py
-===================================================================
---- src/dbus_manager.py (revision 670)
-+++ src/dbus_manager.py (working copy)
-@@ -30,9 +30,18 @@
- import dbus
- import dbus.service
- #Try connection du message bus
-- dbus.SessionBus()
-- if getattr(dbus, 'version', (0,0,0)) >= (0,41,0):
-+ dbus_version = getattr(dbus, 'version',(0,0,0))
-+ if dbus_version >= (0,41,0) and dbus_version < (0,80,0):
-+ dbus.SessionBus()
- import dbus.glib
-+ elif dbus_version >= (0,80,0):
-+ from dbus.mainloop.glib import DBusGMainLoop
-+ DBusGMainLoop(set_as_default=True)
-+ dbus.SessionBus()
-+ else:
-+ pass
-+
-+
- except: dbus_imported = False
- else: dbus_imported=True
-
-@@ -41,14 +50,14 @@
-
- if not dbus_imported:
- class ListenDBus:
-- def __init__(self,win,player,object_path="/org/gnome/listen/"):
-+ def __init__(self,win,player,object_path="/org/gnome/listen"):
- self.player = player
- self.win = win
- print "No dbus support"
- else:
-
- class ListenDBus(dbus.service.Object):
-- def __init__(self,win,player,object_path="/org/gnome/listen/"):
-+ def __init__(self,win,player,object_path="/org/gnome/listen"):
- self.player = player
- self.win = win
- self.bus = dbus.SessionBus()
-@@ -105,4 +114,4 @@
- song = self.player.song
- return str( song.get_str("title")+ " - ("+song.get_str("album")+" - "+song.get_str("artist")+")")
- else:
-- return ""
-\ No newline at end of file
-+ return ""
diff --git a/media-sound/listen/listen-0.5-r1.ebuild b/media-sound/listen/listen-0.5-r1.ebuild
deleted file mode 100644
index 90466afdf4a9..000000000000
--- a/media-sound/listen/listen-0.5-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.5-r1.ebuild,v 1.5 2009/07/10 12:58:59 ssuominen Exp $
-
-inherit eutils virtualx
-
-DESCRIPTION="A Music player and management for GNOME"
-HOMEPAGE="http://www.listen-project.org"
-SRC_URI="http://download.listen-project.org/${PV}/${P}.tar.bz2"
-LICENSE="GPL-2"
-IUSE="aac cdr flac ipod mad vorbis libsexy"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-
-RDEPEND=">=media-libs/gst-plugins-base-0.10.0
- >=media-libs/gst-plugins-good-0.10.0
- >=media-plugins/gst-plugins-gnomevfs-0.10.0
- >=media-plugins/gst-plugins-gconf-0.10.0
- >=media-plugins/gst-plugins-cdparanoia-0.10.0
- >=media-plugins/gst-plugins-xvideo-0.10.0
- >=media-libs/mutagen-1.6
- || ( >=dev-lang/python-2.5 >=dev-python/elementtree-1.2.6 )
- mad? ( >=media-plugins/gst-plugins-mad-0.10.0
- dev-python/pymad )
- vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.0
- >=media-plugins/gst-plugins-vorbis-0.10.0
- dev-python/pyvorbis
- dev-python/pyogg )
- flac? ( >=media-plugins/gst-plugins-flac-0.10.0 )
- aac? ( >=media-plugins/gst-plugins-faad-0.10.0
- dev-python/ctypes )
- ipod? ( >=media-libs/libgpod-0.3.2-r1 )
- cdr? ( app-cdr/serpentine )"
-# musicbrainz? ( dev-python/python-musicbrainz2
-# media-libs/tunepimp )"
-
-DEPEND="${RDEPEND}
- >=x11-libs/gtk+-2.8
- >=media-libs/gstreamer-0.10.0
- dev-python/dbus-python
- >=dev-lang/python-2.4
- >=dev-python/pygtk-2.6
- >=dev-python/gst-python-0.10
- >=dev-db/sqlite-3.2.7-r1
- >=dev-python/pysqlite-2.3.0
- dev-python/gnome-python
- dev-python/gnome-python-extras
- libsexy? ( dev-python/sexy-python )"
-
-pkg_setup() {
- if use ipod && ! built_with_use media-libs/libgpod python ; then
- echo
- eerror "In order to install iPod suport, you need to have media-libs/libgpod"
- eerror "with 'python' in your USE flags. Please add that flag,"
- eerror "re-emerge libgpod, and then emerge listen."
- die "media-libs/libgpod is missing the python binding."
- fi
-
- if ! built_with_use gnome-base/gnome-vfs hal ; then
- echo
- eerror "In order to install Listen, you need to have gnome-base/gnome-vfs"
- eerror "with 'hal' in your USE flags. Please add that flag,"
- eerror "re-emerge gnome-vfs, and then emerge listen."
- die "gnome-base/gnome-vfs is missing the hal binding."
- fi
-
- if ! built_with_use dev-python/gnome-python-extras firefox ; then
- if ! built_with_use dev-python/gnome-python-extras seamonkey ; then
- if ! built_with_use dev-python/gnome-python-extras xulrunner ; then
- echo
- eerror "In order to install Listen, you need to have dev-python/gnome-python-extras"
- eerror "with 'firefox', 'seamonkey' or ''xulrunner' in your USE flags. Please add that flag,"
- eerror "re-emerge gnome-vfs, and then emerge listen."
- die "dev-python/gnome-python-extras is missing the firefox binding."
- fi
- fi
- fi
-
-}
-
-src_unpack(){
- unpack ${A}
- cd ${S}
- #for fix dev-python/dbus-python-0.80.2 bug#179086
- epatch ${FILESDIR}/listen_dbusfix.patch
-}
-
-src_compile() {
- mkdir -p "${T}/home"
- export HOME="${T}/home"
- export GST_REGISTRY=${T}/home/registry.cache.xml
- addpredict /root/.gconfd
- addpredict /root/.gconf
- addpredict /var/lib/cache/gstreamer-0.10
- sed -i "s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):g" Makefile
- Xemake -j1 || die "make failed"
-}
-
-src_install() {
- Xmake DESTDIR="${D}" PREFIX="/usr" install || die "Install failure"
-}
-
-pkg_postinst() {
- echo "#!/bin/sh" > /usr/bin/listen
- GTKMOZEMBED_PATH=$( pkg-config --libs-only-L mozilla-gtkmozembed 2>/dev/null || pkg-config --libs-only-L firefox-gtkmozembed 2>/dev/null | sed -e "s/-L//g" -e "s/[ ]/\,/" -e "s/[ ]//g" )
- echo "LD_LIBRARY_PATH=\"${GTKMOZEMBED_PATH}\"" "python /usr/lib/listen/listen.py \"\$@\"" >> /usr/bin/listen
-}
diff --git a/media-sound/listen/listen-0.6.2.ebuild b/media-sound/listen/listen-0.6.2.ebuild
new file mode 100644
index 000000000000..5315ac9a756e
--- /dev/null
+++ b/media-sound/listen/listen-0.6.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.6.2.ebuild,v 1.1 2009/07/17 09:07:25 ssuominen Exp $
+
+EAPI=2
+inherit eutils multilib python
+
+DESCRIPTION="A Music player and management for GNOME"
+HOMEPAGE="http://www.listen-project.org"
+SRC_URI="http://download.listen-project.org/lastest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal ipod +libsexy"
+
+RDEPEND=">=dev-lang/python-2.5
+ >=dev-python/pygtk-2.6:2
+ || ( dev-python/python-xlib dev-python/egg-python )
+ media-libs/mutagen
+ dev-python/gst-python:0.10
+ media-plugins/gst-plugins-meta:0.10
+ || ( dev-python/pywebkitgtk dev-python/gtkmozembed-python )
+ dev-python/pyinotify
+ libsexy? ( dev-python/sexy-python )
+ ipod? ( media-libs/libgpod[python] )
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ app-text/docbook2X
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ !<media-sound/listen-0.6.2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ if has_version dev-python/pywebkitgtk; then
+ CHECK_DEPENDS="0" emake || die "emake failed"
+ else
+ USE_GTKMOZEMBED="1" CHECK_DEPENDS="0" emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" emake \
+ install || die "emake install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}