summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-27 19:32:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-27 19:32:13 +0000
commit54c1dcacb7a6123f0eba1f8487389ba7def39a65 (patch)
tree652d6bbd9d340ced1bbe4d22e2beefad340a2c73 /media-sound
parentVersion Bump (diff)
downloadgentoo-2-54c1dcacb7a6123f0eba1f8487389ba7def39a65.tar.gz
gentoo-2-54c1dcacb7a6123f0eba1f8487389ba7def39a65.tar.bz2
gentoo-2-54c1dcacb7a6123f0eba1f8487389ba7def39a65.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/exaile/ChangeLog8
-rw-r--r--media-sound/exaile/exaile-0.3.0.ebuild76
-rw-r--r--media-sound/exaile/files/exaile-0.3.0-Makefile-2.patch12
-rw-r--r--media-sound/exaile/files/exaile-0.3.0-Makefile.patch59
4 files changed, 154 insertions, 1 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index ddef4f9c4f08..508446fd0abe 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.60 2009/08/23 14:23:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.61 2009/08/27 19:32:13 ssuominen Exp $
+
+*exaile-0.3.0 (27 Aug 2009)
+
+ 27 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> +exaile-0.3.0.ebuild,
+ +files/exaile-0.3.0-Makefile.patch, +files/exaile-0.3.0-Makefile-2.patch:
+ Version bump.
*exaile-0.3.0_alpha3-r1 (23 Aug 2009)
diff --git a/media-sound/exaile/exaile-0.3.0.ebuild b/media-sound/exaile/exaile-0.3.0.ebuild
new file mode 100644
index 000000000000..6af31d7de5ce
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0.ebuild,v 1.1 2009/08/27 19:32:13 ssuominen Exp $
+
+EAPI=2
+inherit eutils fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org"
+SRC_URI="http://www.launchpad.net/${PN}/${PV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb doc hal libnotify +libsexy nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.12
+ >=dev-lang/python-2.5[sqlite]
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ hal? ( sys-apps/hal )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="doc? ( dev-python/sphinx )
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-Makefile-2.patch
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die "emake translations failed"
+ fi
+ if use doc; then
+ cd doc
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ local _no_locale
+
+ use nls || _no_locale=_no_locale
+
+ emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+ install${_no_locale} || die "emake install failed"
+
+ dodoc README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/_build/html/* || die "dohtml failed"
+ fi
+
+ insinto /usr/share/exaile/data
+ doins -r data/migrations || die "doins failed"
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/files/exaile-0.3.0-Makefile-2.patch b/media-sound/exaile/files/exaile-0.3.0-Makefile-2.patch
new file mode 100644
index 000000000000..01b97b325926
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.3.0-Makefile-2.patch
@@ -0,0 +1,12 @@
+diff -ur exaile-0.3.0.orig/Makefile exaile-0.3.0/Makefile
+--- exaile-0.3.0.orig/Makefile 2009-08-27 22:24:25.000000000 +0300
++++ exaile-0.3.0/Makefile 2009-08-27 22:25:14.000000000 +0300
+@@ -53,7 +53,7 @@
+ rm -f $(DESTDIR)$(PREFIX)/share/pixmaps/exaile.png
+ make uninstall -C plugins
+
+-install: install-target locale install-locale
++install: install-target install-locale
+
+ install_no_locale: install-target
+
diff --git a/media-sound/exaile/files/exaile-0.3.0-Makefile.patch b/media-sound/exaile/files/exaile-0.3.0-Makefile.patch
new file mode 100644
index 000000000000..007120d86ea0
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.3.0-Makefile.patch
@@ -0,0 +1,59 @@
+diff -ur exaile-0.3.0.orig/Makefile exaile-0.3.0/Makefile
+--- exaile-0.3.0.orig/Makefile 2009-08-25 00:25:03.000000000 +0300
++++ exaile-0.3.0/Makefile 2009-08-27 22:24:25.000000000 +0300
+@@ -1,4 +1,4 @@
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ LIBINSTALLDIR ?= /lib
+ XDGCONFDIR ?= /etc/xdg
+
+@@ -11,7 +11,7 @@
+ compile:
+ python -m compileall -q xl xlgui
+ -python -O -m compileall -q xl xlgui
+- cd plugins && make && cd ..
++ make -C plugins
+
+ make-install-dirs:
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+@@ -51,7 +51,7 @@
+ rm -rf $(DESTDIR)$(XDGCONFDIR)/exaile
+ rm -f $(DESTDIR)$(PREFIX)/share/applications/exaile.desktop
+ rm -f $(DESTDIR)$(PREFIX)/share/pixmaps/exaile.png
+- cd plugins && make uninstall && cd ..
++ make uninstall -C plugins
+
+ install: install-target locale install-locale
+
+@@ -91,8 +91,7 @@
+ --datadir=$(PREFIX)/share/exaile/data --startgui \"\$$@\"" \
+ > exaile && \
+ chmod 755 exaile
+- cd plugins && make install DESTDIR=$(DESTDIR) PREFIX=$(PREFIX) \
+- && cd ..
++ make install -C plugins
+
+ locale:
+ cd po && find . -name "*.po" -exec ../tools/compilepo.sh {} \; && cd ..
+@@ -107,18 +106,17 @@
+ done
+
+ plugins_extra_install:
+- cd plugins && make extra_install DESTDIR=$(DESTDIR) PREFIX=$(PREFIX) \
+- && cd ..
++ make extra_install -C plugins
+
+ plugins_dist:
+- cd plugins && make dist && cd ..
++ make dist -C plugins
+
+ clean:
+ -find . -name "*.py[co]" -exec rm -f {} \;
+ find . -name "*.class" -exec rm -f {} \;
+ find . -name "*.bak" -exec rm -f {} \;
+ find po/* -depth -type d -exec rm -r {} \;
+- cd plugins && make clean && cd ..
++ make clean -C plugins
+
+ pot:
+ @echo "[encoding: UTF-8]" > po/POTFILES.in