summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-03-10 21:18:04 +0000
committerSteve Dibb <beandog@gentoo.org>2009-03-10 21:18:04 +0000
commit596652ba0567f06d7c861bc05563127a61e035f0 (patch)
tree248779eab34073f0e26ccaf57472f03e1aaf9fee /media-sound
parentAdded pambase[consolekit] to RDEPEND to get at least the basics ready needed ... (diff)
downloadgentoo-2-596652ba0567f06d7c861bc05563127a61e035f0.tar.gz
gentoo-2-596652ba0567f06d7c861bc05563127a61e035f0.tar.bz2
gentoo-2-596652ba0567f06d7c861bc05563127a61e035f0.zip
Add patch to build with file-5.0, bug 259652
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/ChangeLog10
-rw-r--r--media-sound/sox/files/sox-14.2.0-file-5.0.patch12
-rw-r--r--media-sound/sox/sox-14.2.0-r1.ebuild74
3 files changed, 94 insertions, 2 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index b06e55347a60..a68583456a0c 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/sox
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.104 2008/12/26 12:48:12 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.105 2009/03/10 21:18:03 beandog Exp $
+
+*sox-14.2.0-r1 (10 Mar 2009)
+
+ 10 Mar 2009; Steve Dibb <beandog@gentoo.org>
+ +files/sox-14.2.0-file-5.0.patch, +sox-14.2.0-r1.ebuild:
+ Add patch to build with file-5.0, bug 259652
26 Dec 2008; Raúl Porcel <armin76@gentoo.org> sox-14.2.0.ebuild:
sparc stable wrt #250671
diff --git a/media-sound/sox/files/sox-14.2.0-file-5.0.patch b/media-sound/sox/files/sox-14.2.0-file-5.0.patch
new file mode 100644
index 000000000000..bc7c251d1e69
--- /dev/null
+++ b/media-sound/sox/files/sox-14.2.0-file-5.0.patch
@@ -0,0 +1,12 @@
+diff -u --recursive --new-file sox-14.2.0/src/mp3.c sox-14.2.0_new/src/mp3.c
+--- sox-14.2.0/src/mp3.c 2008-11-02 21:54:31.000000000 +0100
++++ sox-14.2.0_new/src/mp3.c 2009-02-25 11:48:53.000000000 +0100
+@@ -504,7 +504,7 @@
+
+ SOX_FORMAT_HANDLER(mp3)
+ {
+- static char const * const names[] = {"mp3", "mp2", "audio/mpeg", NULL};
++ static char const * const names[] = {"mp3", "mp2", "audio/mpeg", "audio/mpeg; charset=binary", NULL};
+ static unsigned const write_encodings[] = {
+ SOX_ENCODING_GSM, 0, 0};
+ static sox_format_handler_t const handler = {SOX_LIB_VERSION_CODE,
diff --git a/media-sound/sox/sox-14.2.0-r1.ebuild b/media-sound/sox/sox-14.2.0-r1.ebuild
new file mode 100644
index 000000000000..24b951c1c508
--- /dev/null
+++ b/media-sound/sox/sox-14.2.0-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.2.0-r1.ebuild,v 1.1 2009/03/10 21:18:03 beandog Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="http://sox.sourceforge.net"
+SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa amrnb amrwb ao debug encode ffmpeg flac id3tag ladspa mad libsamplerate ogg oss png sndfile wavpack"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ encode? ( media-sound/lame )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ sndfile? ( media-libs/libsndfile )
+ libsamplerate? ( media-libs/libsamplerate )
+ ogg? ( media-libs/libvorbis media-libs/libogg )
+ ao? ( media-libs/libao )
+ ffmpeg? ( media-video/ffmpeg )
+ ladspa? ( media-libs/ladspa-sdk )
+ >=media-sound/gsm-1.0.12-r1
+ id3tag? ( media-libs/libid3tag )
+ amrnb? ( media-libs/amrnb )
+ amrwb? ( media-libs/amrwb )
+ png? ( media-libs/libpng )
+ wavpack? ( media-sound/wavpack )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-distro.patch"
+ # bug 259652
+ epatch "${FILESDIR}/${P}-file-5.0.patch"
+ eautoreconf
+}
+
+src_compile () {
+ # Fixes wav segfaults. See Bug #35745.
+ append-flags -fsigned-char
+
+ econf $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable ao libao) \
+ $(use_enable oss) \
+ $(use_with encode lame) \
+ $(use_with mad) \
+ $(use_with sndfile) \
+ $(use_with flac) \
+ $(use_with ogg) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with ffmpeg) \
+ $(use_with ladspa) \
+ $(use_with id3tag) \
+ $(use_with amrwb amr-wb) \
+ $(use_with amrnb amr-nb) \
+ $(use_with png) \
+ $(use_with wavpack) \
+ --with-distro="Gentoo" \
+ --enable-fast-ulaw \
+ --enable-fast-alaw \
+ || die "configure failed"
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc NEWS ChangeLog README AUTHORS
+}