summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-07-10 22:02:53 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-07-10 22:02:53 +0000
commit5e5fdb221210fe31afc89da9e16eafc3d9d904ad (patch)
treeb295e54cd04efc61d06a67e8e07ed7c32e620c83 /media-sound
parentMark 1.1.0 stable on ia64 (diff)
downloadgentoo-2-5e5fdb221210fe31afc89da9e16eafc3d9d904ad.tar.gz
gentoo-2-5e5fdb221210fe31afc89da9e16eafc3d9d904ad.tar.bz2
gentoo-2-5e5fdb221210fe31afc89da9e16eafc3d9d904ad.zip
Version bump to 1.1.0 a.k.a. the PPC perfection release. Now with Altivec-accelerated DCT64 for MP3 decoding. Doubled period time of 100ms will keep snd-aoa from stuttering. For all arches: all the goodness from the developer releases in a stabilized form.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog10
-rw-r--r--media-sound/audacious/audacious-1.1.0.ebuild102
-rw-r--r--media-sound/audacious/files/digest-audacious-1.1.06
3 files changed, 117 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 38108a40bd43..4ca6e2500363 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.49 2006/06/25 01:07:27 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.50 2006/07/10 22:02:53 chainsaw Exp $
+
+*audacious-1.1.0 (10 Jul 2006)
+
+ 10 Jul 2006; Tony Vroon <chainsaw@gentoo.org> +audacious-1.1.0.ebuild:
+ Version bump to 1.1.0 a.k.a. the PPC perfection release. Now with
+ Altivec-accelerated DCT64 for MP3 decoding. Doubled period time of 100ms
+ will keep snd-aoa from stuttering. For all arches: all the goodness from the
+ developer releases in a stabilized form.
25 Jun 2006; Tony Vroon <chainsaw@gentoo.org>
audacious-1.1.0_beta2-r1.ebuild:
diff --git a/media-sound/audacious/audacious-1.1.0.ebuild b/media-sound/audacious/audacious-1.1.0.ebuild
new file mode 100644
index 000000000000..e28d95127944
--- /dev/null
+++ b/media-sound/audacious/audacious-1.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.1.0.ebuild,v 1.1 2006/07/10 22:02:53 chainsaw Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aac alsa arts esd flac gnome jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma"
+
+RDEPEND="app-arch/unzip
+ net-misc/curl
+ media-libs/musicbrainz
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ gnome? ( >=gnome-base/gconf-2.6.0 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec
+ media-libs/taglib )
+ mp3? ( media-libs/taglib )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )"
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable mmx simd) \
+ $(use_enable gnome gconf) \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.1.0 b/media-sound/audacious/files/digest-audacious-1.1.0
new file mode 100644
index 000000000000..108b33375937
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.1.0
@@ -0,0 +1,6 @@
+MD5 8a4402580dc1971195e94b18f3f55110 audacious-1.1.0.tgz 3365149
+RMD160 5825caacd093dabadd16d1f37d7225490e1ce1c9 audacious-1.1.0.tgz 3365149
+SHA256 ac2fcba9020d4ae38c578d9494f99761cddd153b0281570b538d7d3a6af6a4f8 audacious-1.1.0.tgz 3365149
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839