summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-07-23 21:18:24 +0000
committerTim Harder <radhermit@gentoo.org>2012-07-23 21:18:24 +0000
commit732c4ac5a0d19fff203e207b8aa793c032ad3fe0 (patch)
tree987d5f8aedbca064a688b81320a04b2fc3daa0bd /media-sound
parentarm stable, bug #427264 (diff)
downloadgentoo-2-732c4ac5a0d19fff203e207b8aa793c032ad3fe0.tar.gz
gentoo-2-732c4ac5a0d19fff203e207b8aa793c032ad3fe0.tar.bz2
gentoo-2-732c4ac5a0d19fff203e207b8aa793c032ad3fe0.zip
Fix build with bison-2.6 and skip check for unused fltk gl library (bug #427268).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/csound/ChangeLog8
-rw-r--r--media-sound/csound/csound-5.17.11.ebuild4
-rw-r--r--media-sound/csound/files/csound-5.17.11-bison-2.6.patch108
-rw-r--r--media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch20
4 files changed, 138 insertions, 2 deletions
diff --git a/media-sound/csound/ChangeLog b/media-sound/csound/ChangeLog
index ba1ad00e75fe..e3a1d9e6225a 100644
--- a/media-sound/csound/ChangeLog
+++ b/media-sound/csound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/csound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.19 2012/05/29 12:12:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.20 2012/07/23 21:18:24 radhermit Exp $
+
+ 23 Jul 2012; Tim Harder <radhermit@gentoo.org> csound-5.17.11.ebuild,
+ +files/csound-5.17.11-bison-2.6.patch,
+ +files/csound-5.17.11-no-fltk-gl.patch:
+ Fix build with bison-2.6 and skip check for unused fltk gl library (bug
+ #427268).
29 May 2012; Tim Harder <radhermit@gentoo.org>
-files/csound-5.16.6-install.patch, -csound-5.17.2-r1.ebuild,
diff --git a/media-sound/csound/csound-5.17.11.ebuild b/media-sound/csound/csound-5.17.11.ebuild
index 13428f7c1978..265e06506000 100644
--- a/media-sound/csound/csound-5.17.11.ebuild
+++ b/media-sound/csound/csound-5.17.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.11.ebuild,v 1.1 2012/05/29 12:02:17 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.11.ebuild,v 1.2 2012/07/23 21:18:24 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -82,6 +82,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-5.17.6-fltk.patch
epatch "${FILESDIR}"/${PN}-5.17.6-porttime-in-portmidi.patch
epatch "${FILESDIR}"/${P}-cmake.patch
+ epatch "${FILESDIR}"/${PN}-5.17.11-bison-2.6.patch
+ epatch "${FILESDIR}"/${PN}-5.17.11-no-fltk-gl.patch
sed -i -e "s:^\(csoundExecutable =\).*:\1 \"${WORKDIR}/${P}_build/csound\":" \
tests/test.py || die
diff --git a/media-sound/csound/files/csound-5.17.11-bison-2.6.patch b/media-sound/csound/files/csound-5.17.11-bison-2.6.patch
new file mode 100644
index 000000000000..545f5f9de912
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.11-bison-2.6.patch
@@ -0,0 +1,108 @@
+--- Csound5.17.11/Engine/csound_orc_compile.c
++++ Csound5.17.11/Engine/csound_orc_compile.c
+@@ -24,6 +24,7 @@
+ */
+
+ #include "csoundCore.h"
++#include "parse_param.h"
+ #include "csound_orc.h"
+ #include <math.h>
+ #include <ctype.h>
+@@ -1849,7 +1850,7 @@
+ }
+
+ /* For diagnostics map file name or macro name to an index */
+-int file_to_int(CSOUND *csound, const char *name)
++uint8_t file_to_int(CSOUND *csound, const char *name)
+ {
+ extern char *strdup(const char *);
+ int n = 0;
+--- Csound5.17.11/Engine/csound_orc.l
++++ Csound5.17.11/Engine/csound_orc.l
+@@ -33,8 +33,9 @@
+ #define YYLTYPE ORCTOKEN*
+ #include "tok.h"
+ #define YY_DECL int yylex (YYLTYPE *lvalp, CSOUND *csound, yyscan_t yyscanner)
+-#include "csound_orcparse.h"
++//#include "parse_param.h"
+ #include "csound_orc.h"
++#include "csound_orcparse.h"
+ #include "corfile.h"
+ YYSTYPE *yylval_param;
+ YYLTYPE *yylloc_param;
+--- Csound5.17.11/Engine/cs_par_dispatch.c
++++ Csound5.17.11/Engine/cs_par_dispatch.c
+@@ -26,7 +26,7 @@
+
+ #include "csoundCore.h"
+ #include "csound_orc.h"
+-#include "tok.h"
++//#include "tok.h"
+ #include "cs_par_base.h"
+ #include "cs_par_orc_semantics.h"
+ #include "cs_par_dispatch.h"
+--- Csound5.17.11/Engine/new_orc_parser.c
++++ Csound5.17.11/Engine/new_orc_parser.c
+@@ -24,9 +24,9 @@
+ */
+
+ #include "csoundCore.h"
+-#include "csound_orcparse.h"
+ #include "csound_orc.h"
+-#include "parse_param.h"
++#include "csound_orcparse.h"
++//#include "parse_param.h"
+ #include "corfile.h"
+
+ extern void csound_orcrestart(FILE*, void *);
+--- Csound5.17.11/Engine/parse_param.h
++++ Csound5.17.11/Engine/parse_param.h
+@@ -1,3 +1,6 @@
++#ifndef __PARSE_PARAM_H
++#define __PARSE_PARAM_H
++
+ #define MARGS (3)
+ #define MAX_INCLUDE_DEPTH 100
+ struct MACRO;
+@@ -54,4 +57,6 @@
+ void cs_init_omacros(CSOUND*, PRE_PARM*, NAMES*);
+
+ uint32_t make_location(PRE_PARM *);
+-extern uint8_t file_to_int(CSOUND*, char*);
++extern uint8_t file_to_int(CSOUND*, const char*);
++
++#endif
+--- Csound5.17.11/Engine/symbtab.c
++++ Csound5.17.11/Engine/symbtab.c
+@@ -27,7 +27,7 @@
+ #include <string.h>
+ #include "csoundCore.h"
+ #include "tok.h"
+-#include "csound_orcparse.h"
++#include "csound_orc.h"
+ #include "insert.h"
+ #include "namedins.h"
+ #include "interlocks.h"
+--- Csound5.17.11/H/csound_orc.h
++++ Csound5.17.11/H/csound_orc.h
+@@ -1,6 +1,7 @@
+ #ifndef __CSOUND_ORC_H
+
+ #define __CSOUND_ORC_H
++#include "parse_param.h"
+ #include "tok.h"
+ typedef struct TREE {
+ int type;
+--- Csound5.17.11/Top/main.c
++++ Csound5.17.11/Top/main.c
+@@ -52,8 +52,8 @@
+ extern OENTRY opcodlst_1[];
+ extern uintptr_t kperfThread(void * cs);
+ #if defined(ENABLE_NEW_PARSER)
+-extern void cs_init_math_constants_macros(CSOUND *csound,void *yyscanner);
+-extern void cs_init_omacros(CSOUND *csound, NAMES *nn);
++extern void cs_init_math_constants_macros(CSOUND *csound,PRE_PARM *yyscanner);
++extern void cs_init_omacros(CSOUND *csound, PRE_PARM* yyscanner, NAMES *nn);
+ #endif
+
+ static void create_opcodlst(CSOUND *csound)
diff --git a/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch b/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
new file mode 100644
index 000000000000..ae07d41a63e3
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
@@ -0,0 +1,20 @@
+--- Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
++++ Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
+@@ -7,6 +7,7 @@
+
+ find_package(Boost)
+ find_library(MUSICXML_LIBRARY musicxml2)
++set(FLTK_SKIP_OPENGL true)
+ find_package(FLTK)
+ find_package(SWIG)
+ find_package(PythonLibs)
+--- Csound5.17.11/InOut/CMakeLists.txt
++++ Csound5.17.11/InOut/CMakeLists.txt
+@@ -56,6 +56,7 @@
+ find_library(COREAUDIO_LIBRARY CoreAudio)
+ endif()
+ if(USE_FLTK OR BUILD_VIRTUAL_KEYBOARD)
++ set(FLTK_SKIP_OPENGL true)
+ find_package(FLTK)
+ endif()
+