summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-29 23:05:43 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-29 23:05:43 +0000
commit8508740867291f0b6c7e7c917775fac57ad5f15a (patch)
tree14dc40b2beddb61cb24d621d860bdd594fd384b6 /media-sound
parentadded wine-20010418, with winesetuptk which provides a simple tcl/tk based se... (diff)
downloadgentoo-2-8508740867291f0b6c7e7c917775fac57ad5f15a.tar.gz
gentoo-2-8508740867291f0b6c7e7c917775fac57ad5f15a.tar.bz2
gentoo-2-8508740867291f0b6c7e7c917775fac57ad5f15a.zip
new xmms
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.4-r31
-rw-r--r--media-sound/xmms/xmms-1.2.4-r3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/xmms/files/digest-xmms-1.2.4-r3 b/media-sound/xmms/files/digest-xmms-1.2.4-r3
new file mode 100644
index 000000000000..90c2194bf4e0
--- /dev/null
+++ b/media-sound/xmms/files/digest-xmms-1.2.4-r3
@@ -0,0 +1 @@
+MD5 df1081cc01628cd8b97cb5f3ca80e063 xmms-1.2.4.tar.gz
diff --git a/media-sound/xmms/xmms-1.2.4-r3.ebuild b/media-sound/xmms/xmms-1.2.4-r3.ebuild
new file mode 100644
index 000000000000..ea1a446eddc1
--- /dev/null
+++ b/media-sound/xmms/xmms-1.2.4-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.4-r3.ebuild,v 1.1 2001/05/29 23:05:43 pete Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X MultiMedia System"
+SRC_URI="ftp://ftp.xmms.org/xmms/1.2.x/${P}.tar.gz"
+HOMEPAGE="http://www.xmms.org/"
+
+DEPEND="gnome? ( >=gnome-base/gnome-core-1.2.2.1 )
+ >=gnome-base/libxml-1.8.10
+ >=media-libs/libmikmod-3.1.9
+ >=media-sound/esound-0.2.22
+ >=media-libs/libvorbis-1.0_beta4
+ >=x11-libs/gtk+-1.2.8
+ virtual/opengl"
+
+RDEPEND="gnome? ( >=gnome-base/gnome-core-1.2.2.1 )
+ >=gnome-base/libxml-1.8.10
+ >=media-libs/libmikmod-3.1.9
+ >=media-sound/esound-0.2.22
+ >=media-libs/libvorbis-1.0_beta4
+ >=x11-libs/gtk+-1.2.8
+ virtual/opengl"
+
+src_compile() {
+ cd ${S}
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--prefix=/opt/gnome --with-gnome"
+ else
+ myopts="--prefix=/usr/X11R6 --without-gnome"
+ fi
+ CFLAGS="$CFLAGS -I/opt/gnome/include" try ./configure --host=${CHOST} ${myopts}
+ try make
+
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome \
+ gnorbadir=${D}/etc/opt/gnome/CORBA/servers \
+ sysdir=${D}/opt/gnome/share/applets/Multimedia \
+ install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
+ insinto /usr/X11R6/include/X11/pixmaps/
+ donewins gnomexmms/gnomexmms.xpm xmms.xpm
+}
+
+
+
+
+