summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-05-20 16:39:31 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-05-20 16:39:31 +0000
commit8d73e3c67e559fa1efade8e530851286e0da85bd (patch)
treeb51d10d02905d427c42783fcae12a71d18976170 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-8d73e3c67e559fa1efade8e530851286e0da85bd.tar.gz
gentoo-2-8d73e3c67e559fa1efade8e530851286e0da85bd.tar.bz2
gentoo-2-8d73e3c67e559fa1efade8e530851286e0da85bd.zip
Bump to 1.1.0 developer release 1. The configfile interface has been poisoned, nobody should have been using this since the 0.2 versions. Moving dialogs should no longer corrupt the screen when composite X is used. Proxy settings are unified, and the musepack playback no longer cuts out a few seconds too early. The AAC plugin has had an overhaul, be sure to test that. Taglib is now used for ID3 tags, which should help with UTF-8 related difficulties.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog14
-rw-r--r--media-sound/audacious/audacious-1.1.0_beta1.ebuild103
-rw-r--r--media-sound/audacious/files/digest-audacious-1.1.0_beta16
3 files changed, 122 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index d34b14d649ee..c3c15c3fdade 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.41 2006/04/29 19:22:35 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.42 2006/05/20 16:39:31 chainsaw Exp $
+
+*audacious-1.1.0_beta1 (20 May 2006)
+
+ 20 May 2006; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-1.1.0_beta1.ebuild:
+ Bump to 1.1.0 developer release 1. The configfile interface has been
+ poisoned, nobody should have been using this since the 0.2 versions. Moving
+ dialogs should no longer corrupt the screen when composite X is used. Proxy
+ settings are unified, and the musepack playback no longer cuts out a few
+ seconds too early. The AAC plugin has had an overhaul, be sure to test that.
+ Taglib is now used for ID3 tags, which should help with UTF-8 related
+ difficulties.
*audacious-1.0.0-r1 (29 Apr 2006)
diff --git a/media-sound/audacious/audacious-1.1.0_beta1.ebuild b/media-sound/audacious/audacious-1.1.0_beta1.ebuild
new file mode 100644
index 000000000000..9695f36cc55a
--- /dev/null
+++ b/media-sound/audacious/audacious-1.1.0_beta1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.1.0_beta1.ebuild,v 1.1 2006/05/20 16:39:31 chainsaw Exp $
+
+IUSE="aac alsa arts esd flac gnome jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma"
+
+inherit flag-o-matic
+
+MY_P="${P/_beta/-dr}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions."
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/beta/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="app-arch/unzip
+ net-misc/curl
+ media-libs/musicbrainz
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ gnome? ( >=gnome-base/gconf-2.6.0 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec
+ media-libs/taglib )
+ mp3? ( media-libs/taglib )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+src_compile() {
+ if ! useq mp3; then
+ ewarn "MP3 support is now optional and you have not enabled it."
+ fi
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ `use_enable mmx simd` \
+ `use_enable gnome gconf` \
+ `use_enable vorbis` \
+ `use_enable esd` \
+ `use_enable mp3` \
+ `use_enable nls` \
+ `use_enable oss` \
+ `use_enable alsa` \
+ `use_enable arts` \
+ `use_enable flac` \
+ `use_enable aac` \
+ `use_enable modplug` \
+ `use_enable lirc` \
+ `use_enable sndfile` \
+ `use_enable wma` \
+ `use_enable sid` \
+ `use_enable musepack` \
+ `use_enable jack` \
+ `use_enable timidity` \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins ${WORKDIR}/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc ${WORKDIR}/README
+}
+
+pkg_postinst() {
+ echo
+ einfo "MP3 support is now optional, you may want to enable the mp3 USE-flag."
+ echo
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.1.0_beta1 b/media-sound/audacious/files/digest-audacious-1.1.0_beta1
new file mode 100644
index 000000000000..999d3b4e9761
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.1.0_beta1
@@ -0,0 +1,6 @@
+MD5 e6e479c159ac209fa0be2413ed8dc357 audacious-1.1.0-dr1.tgz 3189815
+RMD160 49a0df7e52f49f43de5a66da936604d771e3f1e5 audacious-1.1.0-dr1.tgz 3189815
+SHA256 e772792198b61f8372ae2ea9f73efc23ae1703ad1421b632555c23bb0ce105cd audacious-1.1.0-dr1.tgz 3189815
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839