summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-17 11:29:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-17 11:29:36 +0000
commit9bb81ef8536cd920eb286a1db0f87275b890821f (patch)
treec86f4af1d9c049f1054aa07be5f00cdf5d1025ec /media-sound
parentNew snapshot. Adjust dependencies on llvm/clang versions to match working com... (diff)
downloadgentoo-2-9bb81ef8536cd920eb286a1db0f87275b890821f.tar.gz
gentoo-2-9bb81ef8536cd920eb286a1db0f87275b890821f.tar.bz2
gentoo-2-9bb81ef8536cd920eb286a1db0f87275b890821f.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/zynaddsubfx/ChangeLog10
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch14
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-2.5.0.ebuild54
3 files changed, 76 insertions, 2 deletions
diff --git a/media-sound/zynaddsubfx/ChangeLog b/media-sound/zynaddsubfx/ChangeLog
index bf2077763e4d..a4baba469ab4 100644
--- a/media-sound/zynaddsubfx/ChangeLog
+++ b/media-sound/zynaddsubfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/zynaddsubfx
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.46 2014/08/10 21:13:12 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.47 2015/03/17 11:29:36 aballier Exp $
+
+*zynaddsubfx-2.5.0 (17 Mar 2015)
+
+ 17 Mar 2015; Alexis Ballier <aballier@gentoo.org> +zynaddsubfx-2.5.0.ebuild,
+ +files/zynaddsubfx-2.5.0-docs.patch:
+ version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> zynaddsubfx-2.4.1.ebuild,
zynaddsubfx-2.4.2.ebuild, zynaddsubfx-2.4.3.ebuild:
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch
new file mode 100644
index 000000000000..a1b7d9332ea5
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch
@@ -0,0 +1,14 @@
+Index: zynaddsubfx-2.5.0/CMakeLists.txt
+===================================================================
+--- zynaddsubfx-2.5.0.orig/CMakeLists.txt
++++ zynaddsubfx-2.5.0/CMakeLists.txt
+@@ -27,9 +27,6 @@ include(CTestConfig.cmake)
+ #Currently the only directory that uses cmake
+ add_subdirectory(src)
+
+-install(FILES AUTHORS.txt COPYING FAQ.txt HISTORY.txt README.adoc
+- DESTINATION share/doc/zynaddsubfx
+- )
+ install(FILES zynaddsubfx-jack.desktop zynaddsubfx-alsa.desktop
+ DESTINATION share/applications)
+ install(FILES zynaddsubfx.svg
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-2.5.0.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-2.5.0.ebuild
new file mode 100644
index 000000000000..13add9f02f00
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-2.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/zynaddsubfx-2.5.0.ebuild,v 1.1 2015/03/17 11:29:36 aballier Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="ZynAddSubFX is an opensource software synthesizer"
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa +fltk jack lash"
+
+RDEPEND=">=dev-libs/mini-xml-2.2.1
+ sci-libs/fftw:3.0
+ alsa? ( media-libs/alsa-lib )
+ fltk? ( >=x11-libs/fltk-1.3:1 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+# portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream uses the following preferences: alsa > jack > portaudio
+# At least one of them must be enabled
+# We do not support portaudio, so if alsa is disabled force jack.
+REQUIRED_USE="!alsa? ( jack )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-docs.patch
+)
+
+DOCS="ChangeLog FAQ.txt HISTORY.txt README.adoc bugs.txt"
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ use lash || sed -i -e 's/lash-1.0/lash_disabled/' "${S}"/src/CMakeLists.txt
+ mycmakeargs=(
+ `use fltk && echo "-DGuiModule=fltk" || echo "-DGuiModule=off"`
+ `use alsa && echo "-DOutputModule=alsa" || echo "-DOutputModule=jack"`
+ `use alsa && echo "-DAlsaMidiOutput=TRUE" || echo "-DAlsaMidiOutput=FALSE"`
+ `use jack && echo "-DJackOutput=TRUE" || echo "-DJackOutput=FALSE"`
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/${PN}
+ doins -r "${S}"/instruments/*
+}