summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 14:37:25 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 14:37:25 +0000
commitaded1fc11832a871856845b73e22d4d8c39d9ea0 (patch)
tree10c4c2c35a61f17a0a64e749ad0f2d161874feb0 /media-sound
parentEAPI 4 (diff)
downloadgentoo-2-aded1fc11832a871856845b73e22d4d8c39d9ea0.tar.gz
gentoo-2-aded1fc11832a871856845b73e22d4d8c39d9ea0.tar.bz2
gentoo-2-aded1fc11832a871856845b73e22d4d8c39d9ea0.zip
Use python-any-r1 for waf. Remove unnecessary python interpreter sed (the eclass wraps python).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour/ChangeLog8
-rw-r--r--media-sound/ardour/ardour-3.5.308-r1.ebuild12
-rw-r--r--media-sound/ardour/ardour-3.5.357.ebuild12
-rw-r--r--media-sound/ardour/ardour-3.5.380.ebuild12
-rw-r--r--media-sound/ardour/ardour-3.5.403.ebuild10
-rw-r--r--media-sound/ardour/ardour-9999.ebuild12
6 files changed, 46 insertions, 20 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index e179768ece0b..6e64e52a4bc7 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.137 2015/01/01 14:51:29 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.138 2015/01/03 14:37:25 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> ardour-3.5.308-r1.ebuild,
+ ardour-3.5.357.ebuild, ardour-3.5.380.ebuild, ardour-3.5.403.ebuild,
+ ardour-9999.ebuild:
+ Use python-any-r1 for waf. Remove unnecessary python interpreter sed (the
+ eclass wraps python).
01 Jan 2015; Andreas Schuerch <nativemad@gentoo.org> ardour-3.5.403.ebuild:
removed the debug flag due to bug 532302
diff --git a/media-sound/ardour/ardour-3.5.308-r1.ebuild b/media-sound/ardour/ardour-3.5.308-r1.ebuild
index 82cfc846235a..ce31a727d0a4 100644
--- a/media-sound/ardour/ardour-3.5.308-r1.ebuild
+++ b/media-sound/ardour/ardour-3.5.308-r1.ebuild
@@ -1,9 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.308-r1.ebuild,v 1.1 2014/02/07 14:22:45 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.308-r1.ebuild,v 1.2 2015/01/03 14:37:25 mgorny Exp $
EAPI=4
-inherit eutils toolchain-funcs flag-o-matic waf-utils
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
@@ -61,6 +65,7 @@ RDEPEND="media-libs/aubio
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen[dot] )"
@@ -85,7 +90,6 @@ src_prepare(){
fi
epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
- sed 's/python/python2/' -i waf
sed 's/'FLAGS\'\,\ optimization_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
}
diff --git a/media-sound/ardour/ardour-3.5.357.ebuild b/media-sound/ardour/ardour-3.5.357.ebuild
index 4509976f9fce..72566f6dd56c 100644
--- a/media-sound/ardour/ardour-3.5.357.ebuild
+++ b/media-sound/ardour/ardour-3.5.357.ebuild
@@ -1,9 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.357.ebuild,v 1.1 2014/02/25 16:17:24 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.357.ebuild,v 1.2 2015/01/03 14:37:25 mgorny Exp $
EAPI=4
-inherit eutils toolchain-funcs flag-o-matic waf-utils
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
@@ -61,6 +65,7 @@ RDEPEND="media-libs/aubio
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen[dot] )"
@@ -85,7 +90,6 @@ src_prepare(){
fi
epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
- sed 's/python/python2/' -i waf
sed 's/'FLAGS\'\,\ optimization_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
}
diff --git a/media-sound/ardour/ardour-3.5.380.ebuild b/media-sound/ardour/ardour-3.5.380.ebuild
index ee2cb0054e3f..ea65e59166b5 100644
--- a/media-sound/ardour/ardour-3.5.380.ebuild
+++ b/media-sound/ardour/ardour-3.5.380.ebuild
@@ -1,9 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.380.ebuild,v 1.3 2014/10/11 13:02:51 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.380.ebuild,v 1.4 2015/01/03 14:37:25 mgorny Exp $
EAPI=4
-inherit eutils toolchain-funcs flag-o-matic waf-utils
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
@@ -61,6 +65,7 @@ RDEPEND="media-libs/aubio
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen[dot] )"
@@ -85,7 +90,6 @@ src_prepare(){
fi
epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
- sed 's/python/python2/' -i waf
# sed 's/'FLAGS\'\,\ optimization_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
sed 's/'FLAGS\'\,\ compiler_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
append-flags "-lboost_system"
diff --git a/media-sound/ardour/ardour-3.5.403.ebuild b/media-sound/ardour/ardour-3.5.403.ebuild
index 6f0a4a3c158b..fa133a919c20 100644
--- a/media-sound/ardour/ardour-3.5.403.ebuild
+++ b/media-sound/ardour/ardour-3.5.403.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild,v 1.4 2015/01/01 14:51:29 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild,v 1.5 2015/01/03 14:37:25 mgorny Exp $
EAPI=5
-inherit eutils toolchain-funcs flag-o-matic waf-utils
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
@@ -61,6 +65,7 @@ RDEPEND="media-libs/aubio
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen[dot] )"
@@ -85,7 +90,6 @@ src_prepare(){
fi
epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
epatch "${FILESDIR}"/${PN}-3.5.403-sse.patch
- sed 's/python/python2/' -i waf
sed 's/'FLAGS\'\,\ compiler_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
append-flags "-lboost_system"
}
diff --git a/media-sound/ardour/ardour-9999.ebuild b/media-sound/ardour/ardour-9999.ebuild
index 9eb8e5c550cf..31ee68d2b18a 100644
--- a/media-sound/ardour/ardour-9999.ebuild
+++ b/media-sound/ardour/ardour-9999.ebuild
@@ -1,9 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 1.12 2014/10/27 15:58:35 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 1.13 2015/01/03 14:37:25 mgorny Exp $
EAPI=5
-inherit eutils toolchain-funcs flag-o-matic waf-utils
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
@@ -61,6 +65,7 @@ RDEPEND="media-libs/aubio
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen[dot] )"
@@ -85,7 +90,6 @@ src_prepare(){
fi
epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
epatch "${FILESDIR}"/${PN}-3.5.403-sse.patch
- sed 's/python/python2/' -i waf
sed 's/'FLAGS\'\,\ compiler_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
append-flags "-lboost_system"
}