summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-10 09:52:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-10 09:52:36 +0000
commitda19e5a6800eb0daa8516d7273fc69e72613b2a1 (patch)
treea6c403f0df60fbd1fd3a967cebd00c796817d827 /media-sound
parenteapi5: slot dep on ocaml (diff)
downloadgentoo-2-da19e5a6800eb0daa8516d7273fc69e72613b2a1.tar.gz
gentoo-2-da19e5a6800eb0daa8516d7273fc69e72613b2a1.tar.bz2
gentoo-2-da19e5a6800eb0daa8516d7273fc69e72613b2a1.zip
remove old
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/ChangeLog7
-rw-r--r--media-sound/sox/files/sox-14.3.2-ffmpeg.patch40
-rw-r--r--media-sound/sox/files/sox-14.3.2-uclibc.patch21
-rw-r--r--media-sound/sox/sox-14.3.2-r1.ebuild79
-rw-r--r--media-sound/sox/sox-14.4.0.ebuild84
5 files changed, 6 insertions, 225 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 3e0f4b39ff07..4fa0899b927c 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.152 2013/03/09 13:35:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.153 2013/03/10 09:52:36 aballier Exp $
+
+ 10 Mar 2013; Alexis Ballier <aballier@gentoo.org> -sox-14.3.2-r1.ebuild,
+ -files/sox-14.3.2-ffmpeg.patch, -files/sox-14.3.2-uclibc.patch,
+ -sox-14.4.0.ebuild:
+ remove old
09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> sox-14.4.1.ebuild:
Stable for alpha, wrt bug #459452
diff --git a/media-sound/sox/files/sox-14.3.2-ffmpeg.patch b/media-sound/sox/files/sox-14.3.2-ffmpeg.patch
deleted file mode 100644
index 5289b9b471d3..000000000000
--- a/media-sound/sox/files/sox-14.3.2-ffmpeg.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: sox-14.3.2/src/ffmpeg.c
-===================================================================
---- sox-14.3.2.orig/src/ffmpeg.c
-+++ sox-14.3.2/src/ffmpeg.c
-@@ -91,7 +91,7 @@ static int stream_component_open(priv_t
-
- if (!codec || avcodec_open(enc, codec) < 0)
- return -1;
-- if (enc->codec_type != CODEC_TYPE_AUDIO) {
-+ if (enc->codec_type != AVMEDIA_TYPE_AUDIO) {
- lsx_fail("ffmpeg CODEC %x is not an audio CODEC", enc->codec_type);
- return -1;
- }
-@@ -182,7 +182,7 @@ static int startread(sox_format_t * ft)
- /* Find audio stream (FIXME: allow different stream to be selected) */
- for (i = 0; (unsigned)i < ffmpeg->ctxt->nb_streams; i++) {
- AVCodecContext *enc = ffmpeg->ctxt->streams[i]->codec;
-- if (enc->codec_type == CODEC_TYPE_AUDIO && ffmpeg->audio_index < 0) {
-+ if (enc->codec_type == AVMEDIA_TYPE_AUDIO && ffmpeg->audio_index < 0) {
- ffmpeg->audio_index = i;
- break;
- }
-@@ -273,7 +273,7 @@ static AVStream *add_audio_stream(sox_fo
-
- c = st->codec;
- c->codec_id = codec_id;
-- c->codec_type = CODEC_TYPE_AUDIO;
-+ c->codec_type = AVMEDIA_TYPE_AUDIO;
-
- /* put sample parameters */
- c->bit_rate = 256000; /* FIXME: allow specification */
-@@ -423,7 +423,7 @@ static size_t write_samples(sox_format_t
- av_init_packet(&pkt);
- pkt.size = avcodec_encode_audio(c, ffmpeg->audio_buf_aligned, AVCODEC_MAX_AUDIO_FRAME_SIZE, ffmpeg->samples);
- pkt.pts = av_rescale_q(c->coded_frame->pts, c->time_base, ffmpeg->audio_st->time_base);
-- pkt.flags |= PKT_FLAG_KEY;
-+ pkt.flags |= AV_PKT_FLAG_KEY;
- pkt.stream_index = ffmpeg->audio_st->index;
- pkt.data = ffmpeg->audio_buf_aligned;
-
diff --git a/media-sound/sox/files/sox-14.3.2-uclibc.patch b/media-sound/sox/files/sox-14.3.2-uclibc.patch
deleted file mode 100644
index cc07fc012530..000000000000
--- a/media-sound/sox/files/sox-14.3.2-uclibc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=336123
-
---- src/formats.c
-+++ src/formats.c
-@@ -399,7 +399,7 @@
- #if defined _FSTDIO || defined _NEWLIB_VERSION || defined __APPLE__
- fp->_p -= AUTO_DETECT_SIZE;
- fp->_r += AUTO_DETECT_SIZE;
--#elif defined __GLIBC__
-+#elif defined __GLIBC__ && ! defined __UCLIBC__
- fp->_IO_read_ptr = fp->_IO_read_base;
- #elif defined _MSC_VER || defined __MINGW_H || defined _ISO_STDIO_ISO_H
- fp->_ptr = fp->_base;
-@@ -407,7 +407,6 @@
- /* To fix this #error, either simply remove the #error line and live without
- * file-type detection with pipes, or add support for your compiler in the
- * lines above. Test with cat monkey.au | ./sox --info - */
-- #error FIX NEEDED HERE
- #define NO_REWIND_PIPE
- (void)fp;
- #endif
diff --git a/media-sound/sox/sox-14.3.2-r1.ebuild b/media-sound/sox/sox-14.3.2-r1.ebuild
deleted file mode 100644
index c7c0d756496c..000000000000
--- a/media-sound/sox/sox-14.3.2-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.2-r1.ebuild,v 1.12 2012/05/05 08:54:02 mgorny Exp $
-
-EAPI=4
-inherit eutils flag-o-matic
-
-DESCRIPTION="The swiss army knife of sound processing programs"
-HOMEPAGE="http://sox.sourceforge.net"
-SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg openmp oss png pulseaudio sndfile static-libs wavpack"
-
-# libtool required for libltdl
-RDEPEND=">=sys-devel/libtool-2.2.6b
- alsa? ( media-libs/alsa-lib )
- amr? ( media-libs/opencore-amr )
- encode? ( >=media-sound/lame-3.98.4 )
- flac? ( media-libs/flac )
- mad? ( media-libs/libmad )
- sndfile? ( media-libs/libsndfile )
- ogg? ( media-libs/libvorbis media-libs/libogg )
- ao? ( media-libs/libao )
- ffmpeg? ( virtual/ffmpeg )
- ladspa? ( media-libs/ladspa-sdk )
- >=media-sound/gsm-1.0.12-r1
- id3tag? ( media-libs/libid3tag )
- png? ( media-libs/libpng sys-libs/zlib )
- pulseaudio? ( media-sound/pulseaudio )
- wavpack? ( media-sound/wavpack )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_prepare() {
- sed -i -e 's:CFLAGS="-g":CFLAGS="$CFLAGS -g":' configure || die #386027
-
- epatch \
- "${FILESDIR}"/${P}-uclibc.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch
-}
-
-src_configure() {
- # Fixes wav segfaults. See Bug #35745.
- append-flags -fsigned-char
-
- econf \
- $(use_enable static-libs static) \
- $(use_with alsa) \
- $(use_enable debug) \
- $(use_enable openmp gomp) \
- $(use_with ao) \
- $(use_with oss) \
- $(use_with encode lame) \
- $(use_with mad) \
- $(use_with sndfile) \
- $(use_with flac) \
- $(use_with ogg oggvorbis) \
- $(use_with ffmpeg) \
- $(use_with ladspa) \
- $(use_with id3tag) \
- $(use_with amr amrwb) \
- $(use_with amr amrnb) \
- $(use_with png) \
- $(use_with pulseaudio) \
- $(use_with wavpack) \
- --with-distro="Gentoo"
-}
-
-src_install() {
- default
- # libltdl is used for loading plugins, keeping libtool files with empty
- # dependency_libs what otherwise would be -exec rm -f {} +
- find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
-}
diff --git a/media-sound/sox/sox-14.4.0.ebuild b/media-sound/sox/sox-14.4.0.ebuild
deleted file mode 100644
index 514a92b54db1..000000000000
--- a/media-sound/sox/sox-14.4.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.4.0.ebuild,v 1.4 2012/11/25 21:12:32 lu_zero Exp $
-
-EAPI=4
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The swiss army knife of sound processing programs"
-HOMEPAGE="http://sox.sourceforge.net"
-SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg openmp oss png pulseaudio sndfile static-libs twolame wavpack"
-
-# libtool required for libltdl
-RDEPEND=">=sys-devel/libtool-2.2.6b
- >=media-sound/gsm-1.0.12-r1
- alsa? ( media-libs/alsa-lib )
- amr? ( media-libs/opencore-amr )
- ao? ( media-libs/libao )
- encode? ( >=media-sound/lame-3.98.4 )
- ffmpeg? ( >=virtual/ffmpeg-0.9 )
- flac? ( media-libs/flac )
- id3tag? ( media-libs/libid3tag )
- ladspa? ( media-libs/ladspa-sdk )
- mad? ( media-libs/libmad )
- ogg? ( media-libs/libvorbis media-libs/libogg )
- png? ( media-libs/libpng sys-libs/zlib )
- pulseaudio? ( media-sound/pulseaudio )
- sndfile? ( media-libs/libsndfile )
- twolame? ( media-sound/twolame )
- wavpack? ( media-sound/wavpack )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_prepare() {
- sed -i -e 's:CFLAGS="-g":CFLAGS="$CFLAGS -g":' configure || die #386027
-
- epatch \
- "${FILESDIR}"/${PN}-14.3.2-uclibc.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch \
- "${FILESDIR}"/${P}-avcodec54.patch \
- "${FILESDIR}"/${P}-libav-9.patch
- eautoreconf
-}
-
-src_configure() {
- # Fixes wav segfaults. See Bug #35745.
- append-flags -fsigned-char
-
- econf \
- $(use_with alsa) \
- $(use_with amr amrnb) \
- $(use_with amr amrwb) \
- $(use_with ao) \
- $(use_enable debug) \
- $(use_with encode lame) \
- $(use_with ffmpeg) \
- $(use_with flac) \
- $(use_with id3tag) \
- $(use_with ladspa) \
- $(use_with mad) \
- $(use_enable openmp gomp) \
- $(use_with ogg oggvorbis) \
- $(use_with oss) \
- $(use_with png) \
- $(use_with pulseaudio) \
- $(use_with sndfile) \
- $(use_enable static-libs static) \
- $(use_with twolame) \
- $(use_with wavpack) \
- --with-distro="Gentoo"
-}
-
-src_install() {
- default
- # libltdl is used for loading plugins, keeping libtool files with empty
- # dependency_libs what otherwise would be -exec rm -f {} +
- find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
-}