summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-04 18:15:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-04 18:15:12 +0000
commitea9f6f9885dee704adb3916b452728a7c7a087f5 (patch)
treeb5e2599fedfb8884ff60604ce2a41b2504f8ae76 /media-sound
parentremove inherit || die (diff)
downloadgentoo-2-ea9f6f9885dee704adb3916b452728a7c7a087f5.tar.gz
gentoo-2-ea9f6f9885dee704adb3916b452728a7c7a087f5.tar.bz2
gentoo-2-ea9f6f9885dee704adb3916b452728a7c7a087f5.zip
touchups and removal of ugly code
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild3
-rw-r--r--media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild37
2 files changed, 16 insertions, 24 deletions
diff --git a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild
index 6199afb464e7..1da38fcb29b2 100644
--- a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild
+++ b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild,v 1.2 2004/03/01 05:37:16 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r1.ebuild,v 1.3 2004/03/04 18:15:12 vapier Exp $
MY_PV=rc2_2032
DESCRIPTION="The Teamspeak Voice Communication Tool"
@@ -12,7 +12,6 @@ SLOT="0"
KEYWORDS="~x86"
DEPEND="virtual/x11
- media-libs/jpeg
virtual/glibc"
S=${WORKDIR}/ts2_client_${MY_PV}
diff --git a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
index e9618e26c82d..6c4b5f1efb86 100644
--- a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
+++ b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
@@ -1,35 +1,33 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild,v 1.2 2004/03/04 16:18:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild,v 1.3 2004/03/04 18:15:12 vapier Exp $
+
+MY_PV=rc2_2032
+DESCRIPTION="The Teamspeak Voice Communication Tool"
+HOMEPAGE="http://www.teamspeak.org/"
+SRC_URI="ftp://teamspeak.krawall.de/releases/ts2_client_${MY_PV}.tar.bz2"
-DESCRIPTION="The TeamSpeak voice communication tool"
-HOMEPAGE="http://www.teamspeak.org"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86"
-
IUSE="kde"
-SLOT="0"
-MY_P="`echo ${P} | sed -e 's/teamspeak\([0-9]\)-client-bin-\([0-9]\)\.\([0-9]\)\.\([0-9]\)\([0-9]\)\.\([0-9]\)\([0-9]\)/ts\1_client_rc2_\2\3\4\5/'`"
-SRC_URI="ftp://teamspeak.krawall.de/releases/${MY_P}.tar.bz2"
+# Note: ts2 client comes with its own speex library, so no need to
+# depend on it
DEPEND="virtual/x11
virtual/glibc
- kde? ( >=kde-base/kdelibs-3.1.0 )
- media-gfx/imagemagick"
- # Note: ts2 client comes with its own speex library, so no need to
- # depend on it
+ kde? ( >=kde-base/kdelibs-3.1.0 )"
-S="${WORKDIR}/${MY_P}/setup.data/image"
+S=${WORKDIR}/ts2_client_${MY_PV}/setup.data/image
src_install() {
-
local dir="/opt/teamspeak2-client"
dodir ${dir}
# Edit the Teamspeak startscript to match our install directory
sed -i -e "s:%installdir%:${dir}:g" TeamSpeak
- if [ `use kde` ] ; then
+ if use kde ; then
# Install a teamspeak.protocol file for kde/konqueror to accept
# teamspeak:// links
insinto $(kde-config --prefix)/share/services/
@@ -50,16 +48,13 @@ src_install() {
-name "tsControl" \) -exec chmod -x {} \;
#Install the teamspeak icon.
- dodir /usr/share/pixmaps
- convert ${S}/icon.xpm ${S}/teamspeak.png
- cp ${S}/teamspeak.png ${D}/usr/share/pixmaps/
+ insinto /usr/share/pixmaps
+ newins ${S}/icon.xpm ${S}/teamspeak.xpm
- cp -r * ${D}/${dir}
+ cp -r * ${D}/${dir} || die "cp failed"
}
pkg_postinst() {
-
- echo
einfo "Note: If you just upgraded from a version less than 2.0.32.60-r1,"
einfo "your users' config files will incorrectly point to non-existant"
einfo "soundfiles because they've been moved from their old location."
@@ -68,6 +63,4 @@ pkg_postinst() {
einfo "# ln -s ${dir}/sounds /usr/share/teamspeak2-client/sounds"
einfo "This way, each user won't have to modify their config files to"
einfo "reflect this move."
- echo
}
-