summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2002-12-30 10:33:06 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2002-12-30 10:33:06 +0000
commiteecde0fc9c203b216c0d6c7cfbbd347cf00cc482 (patch)
treef0c8e24ae4996830b4a09a734e8ba6a5f8acab3d /media-sound
parentVersion bumped. (diff)
downloadgentoo-2-eecde0fc9c203b216c0d6c7cfbbd347cf00cc482.tar.gz
gentoo-2-eecde0fc9c203b216c0d6c7cfbbd347cf00cc482.tar.bz2
gentoo-2-eecde0fc9c203b216c0d6c7cfbbd347cf00cc482.zip
disabled -Werror
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.4.1-r11
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.4.1-r1.ebuild66
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.4.1.ebuild7
4 files changed, 78 insertions, 2 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index b409a34aac9e..e1317e2ca1a9 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.8 2002/12/27 18:16:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.9 2002/12/30 10:33:06 lordvan Exp $
+
+*rhythmbox-0.4.1-r1 (30 Dec 2002)
+ 30 Dec 2002; Thomas Raschbacher <lordvan@gentoo.org> rhythmbox-0.4.1-r1.ebuild:
+ disabled -Werror when doing econf because it won't install here with -Werror
*rhythmbox-0.4.1 (26 Dec 2002)
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1-r1 b/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1-r1
new file mode 100644
index 000000000000..7bdf55befcf9
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.4.1-r1
@@ -0,0 +1 @@
+MD5 c371babd76bf54f2f238af040f2b2aa9 rhythmbox-0.4.1.tar.gz 1150107
diff --git a/media-sound/rhythmbox/rhythmbox-0.4.1-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..eac228b7b4c7
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.4.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.4.1-r1.ebuild,v 1.1 2002/12/30 10:33:06 lordvan Exp $
+
+inherit eutils gnome2
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="RhythmBox - an iTunes clone for GNOME"
+SRC_URI="http://www.rhythmbox.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.rhythmbox.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=x11-libs/gtk+-2.0.0
+ =gnome-base/libgnomeui-2.0*
+ =gnome-base/libglade-2.0*
+ =gnome-base/gnome-panel-2.0*
+ =gnome-base/gnome-vfs-2.0*
+ =gnome-base/libbonobo-2.0*
+ =gnome-base/bonobo-activation-1.0*
+ =gnome-base/libgnomecanvas-2.0*
+ >=media-libs/monkey-media-0.6.1
+ >=gnome-base/gconf-1.2.1
+ >=gnome-base/ORBit2-2.4.1
+ >=sys-devel/gettext-0.11.1
+ =media-libs/gst-plugins-0.4.2*"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ dev-util/intltool"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Soften the message displayed at startup, and only do
+ # it once. Ugly hack I know, but somebody with more C
+ # will have to fix this if need be ...
+ # <azarah@gentoo.org> (27 Dec 2002).
+ cd ${S}; epatch ${FILESDIR}/${PN}-0.4.1-check_gentoo-be-nicer.patch
+}
+
+src_compile() {
+ # disable -Werror
+ econf --enable-compile-warnings=yes
+ emake || die "compile failed"
+}
+
+src_install () {
+
+ # this is a fix to disable scrollkeeper-update from running in
+ # "make install" since that breaks sandbox.
+ cd help/C
+ cat Makefile | sed s/"install-data-hook: install-data-hook-omf"/"install-data-hook:"/g >Makefile.new
+ mv Makefile.new Makefile
+ cd ../..
+ gnome2_src_install
+
+}
+
+DOC="AUTHORS COPYING ChangeLog INSTALL INSTALL.GNU HACKING NEWS README THANKS TODO"
+SCHEMA="rhythmbox.schemas"
+
diff --git a/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild b/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild
index 9df34a895a97..b4f8da1f08f1 100644
--- a/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild,v 1.1 2002/12/27 18:16:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.4.1.ebuild,v 1.2 2002/12/30 10:33:06 lordvan Exp $
inherit eutils gnome2
@@ -43,6 +43,11 @@ src_unpack() {
cd ${S}; epatch ${FILESDIR}/${PN}-0.4.1-check_gentoo-be-nicer.patch
}
+src_compile() {
+ econf --enable-compile-warnings=yes #turn of -Werror
+ emake
+}
+
src_install () {
# this is a fix to disable scrollkeeper-update from running in