summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:22:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:22:54 +0000
commitcd298ec42c55006cec6b3a48f84b525de660c96f (patch)
tree297681afc2c6329672a45a710d9f23976022fc34 /media-tv/mythfrontend
parentVersion bumps (diff)
downloadgentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.tar.gz
gentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.tar.bz2
gentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.zip
Version bumps
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog7
-rw-r--r--media-tv/mythfrontend/Manifest4
-rw-r--r--media-tv/mythfrontend/files/digest-mythfrontend-0.131
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.13.ebuild100
4 files changed, 109 insertions, 3 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index e8a3e8e28346..26ee37b1e33d 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.7 2003/10/28 16:15:15 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.8 2003/12/11 21:22:50 aliz Exp $
+
+*mythfrontend-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.13.ebuild:
+ Version bump.
28 Oct 2003; Max Kalika <max@gentoo.org> mythfrontend-0.12.ebuild:
Remove DVB depend. Extend CPU detection. Fix potential portage bug in
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index 2a8438269fc5..a4ed493564d5 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -1,7 +1,7 @@
MD5 c3f67cc91781e0b6358a0a1cf9971157 mythfrontend-0.11.ebuild 1415
-MD5 081ac6f1d465f836b5a9108475cd476f mythfrontend-0.13.ebuild 2808
+MD5 2d320d554a58bb4dbfc1a8153be8f613 mythfrontend-0.13.ebuild 2810
MD5 aed36892462269a8080b52fa26962f65 mythfrontend-0.10.ebuild 1479
-MD5 40f65a16415626a2f9299afa96a4233c ChangeLog 1200
+MD5 cbe2201eaf436b4d1fb30c566e423fc9 ChangeLog 1320
MD5 1b083ee6bfff0d9a00025757e9462061 mythfrontend-0.12.ebuild 2816
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythfrontend-0.10 65
diff --git a/media-tv/mythfrontend/files/digest-mythfrontend-0.13 b/media-tv/mythfrontend/files/digest-mythfrontend-0.13
new file mode 100644
index 000000000000..d64835745f92
--- /dev/null
+++ b/media-tv/mythfrontend/files/digest-mythfrontend-0.13
@@ -0,0 +1 @@
+MD5 bdca237336453cf68835063c1a4efa91 mythtv-0.13.tar.bz2 3263341
diff --git a/media-tv/mythfrontend/mythfrontend-0.13.ebuild b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
new file mode 100644
index 000000000000..7a8b94928c1d
--- /dev/null
+++ b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.1 2003/12/11 21:22:50 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project frontend."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+
+RDEPEND="${DEPEND}
+ !media-tv/mythtv"
+
+S="${WORKDIR}/mythtv-${PV}"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "mythtv.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ rm -rf "${D}"/usr/bin/myth{backend,commflag,filldatabase,transcode} \
+ "${D}/usr/share/mythtv/setup.xml"
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+}